Plex Media Server plugin for unRAID (v0.3 - Aug 7 2011)


198 posts in this topic Last Reply

Recommended Posts

  • 2 weeks later...
  • Replies 197
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Tthanks for this - work like this is really appreciated.

 

Now for the questions

 

I boot from a VM hard disk in ESXi, and i am putting everything that is needed to run onto that disk.  I copied the binaries to the packages folder I created on the disk (/mnt/vmdk/packages/plex) and added the autostart to the go file and it appears to be working.

 

One thing I didn't like was the long delay in installing the package at boot and this is kind of covered with the binaries being persistent on the boot drive, but there is a caveat.

 

With the tgz file removed from teh extras folder, i dont get the icon added to the utilities page and the /utils/plex page is not added to the web server for unraid.  By not having it there I cant configure the server, nor can i stop it.  Is there anyway to get the web page to show plex without having to isntall the package every time?

 

Keep up the great work.

 

Mick

 

Link to post

Up and running thanks for the guide on how to get it set it up. Real noob question, I'm missing some season folders that Plex is not picking up. Is there any way to manually add them?

Thanks

 

I don't know of a way to manually add them, but verify (using thetvdb.com) that your season info is correct and named correctly, then do a Deep Scan (see link to instructions). This is supposed to scan the media again, even if nothing has been changed since the last time it was scanned.

Link to post

I'm wondering if its a permission/ownership issue. What ownership settings should I be using?

If your shares are set up as Public or Secure, permissions should not be the problem. As PMS is scanning other files and I assume you ran the permissions script(this should set it to nobody), I would strongly suggest checking that you are following the recommended naming convention/folder structure and have the correct series name. 

 

The scanners are loose enough to pick up reasonable TV naming structures, but you will get the best results from following the recommended naming guides.

 

Check the proper title of the series from thetvdb.com (as suggested above) and you can find the naming guide here :

 

http://wiki.plexapp.com/index.php/PlexNine_PMS_NamingGuide

 

If you are still having problems post in the Plex forums with an example of the file/folder name, there might be something particular with that series which makes it tricky to scan in.

Link to post
  • 1 month later...

I just found unRAID yesterday and have setup a server running plex/sabnzbd/sickbeard/couchpotato...  I am having the exact issue that was mentioned in the original post.  When I stop the array it hangs.  If I look at the syslog it says my data folder which is in a user share is not empty so it can't unmount....over and over....  When I go look in the user share the only folder still there is the plex folder.  I have tried everything I could think of.  What is the proper way to shutdown plex to get the array to stop?  The only way I can get it unhung is by issuing a reboot command in a telnet session.  Please help!!

Link to post
  • 2 weeks later...

Hi guys,

 

I've taken the plunge and upgraded to 5.0 Beta14. Ive also installed Plex V0.9.3.5. It installed and is running.

 

Where do I go from here? My first attempt was to connect my LG smart TV which runs Plex through its MediaLink app. The app actually see the server "Tower" but when I select it, it attempts to connect then immediately gives a connection error. Meanwhile it has the server displayed and recognized.

 

I'm also wondering where to set my media folders? Is this done through script or does Plex auto scan the whole system?

 

Any advice will be appreciated.

 

HA!!! just read thru this whole thread...how do remove 0.9.3.5 then possibly try 0.9.5.2?

 

Thx again?

 

Link to post
  • 2 months later...

I just installed Plex on my unRAID box following these instructions. Unfortunately, none of my DLNA devices(VLC 2, wmp) can see the Plex Media Server. There is an error in the log file, which I've included below.

 

Does anyone have any knowledge of this?

 

Thanks!

 

May 22, 2012 11:12:15 [0xb0d6fb70] WARN - The plug-in /mnt/disk1/plex/Plex Media Server/Plug-ins/Media-Flags.bundle is not runnable.

May 22, 2012 11:12:15 [0xb105db70] DEBUG - Done waiting for all plug-ins to start.

May 22, 2012 11:12:15 [0xb105db70] ERROR - Couldn't create group: Bad state

May 22, 2012 11:12:15 [0xb422bb70] DEBUG - HTTP request to: http://127.0.0.1:502...mRpY3QKMApyMAo_

May 22, 2012 11:12:15 [0xb422bb70] DEBUG - [com.plexapp.system] HTTP reply status 200, with 70056 bytes of content.

Link to post

Stokkes went off in a huff, and hasn't been seen on this thread since, after seeing the one in the PlugIn forum treading all over his toes, and I really can't say as I blame him.  I too considered it a breach of etiquette amongst open source developers.

 

Too that end, I have kept running this version and have had zero problems with it, and unless something drastic changes with either unRAID or Plex, I foresee it continuing to work.

 

The only proviso, is that you have to run the "light" version, and update the versions of Plex manually.  I use a soft link, from the current Plex directory to point to where this plugin thinks the code resides.  All I have to do, when a new version of Plex comes along, is shut it down, load the new version, re-create the soft link pointing to the new directory, and re-start Plex.  Easy.

 

Cheers.

Link to post
  • 4 weeks later...

I just downloaded Plex for Unraid 0.9.6.4.  I also downloaded the Light version from page 1 of this thread.  Please let me know if that is not the latest link /file.

 

My current setup is Unraid 4.7, so I'll be upgrading to 5 first.  My movie files are on stored on my Unraid via Share.  I use my Popcorn Hour A110 and A300 to connect to the Share and play the movies.

 

I would like to Run Plex on the Unraid and connect my PCH devices (as well as iPhone and others).  Does anyone have this same setup working?

 

UPDATE:  I'm on 5 rc5 and ready to install Plex.  Can anyone confirm I have the correct files and if this will work with my popcorn hour stuff?

 

 

Thanks!

Link to post

I just downloaded Plex for Unraid 0.9.6.4.  I also downloaded the Light version from page 1 of this thread.  Please let me know if that is not the latest link /file.

 

My current setup is Unraid 4.7, so I'll be upgrading to 5 first.  My movie files are on stored on my Unraid via Share.  I use my Popcorn Hour A110 and A300 to connect to the Share and play the movies.

 

I would like to Run Plex on the Unraid and connect my PCH devices (as well as iPhone and others).  Does anyone have this same setup working?

 

UPDATE:  I'm on 5 rc5 and ready to install Plex.  Can anyone confirm I have the correct files and if this will work with my popcorn hour stuff?

 

 

Thanks!

 

Switchblade, you shouldn't need the Light version from this plugin. According to the post on the Plex forums, you only need to use Plex for UnRAID link. This plugin is a little older. With regard to Popcorn Hour, I don't think there's an official client, but a third-part client is mentioned in a forum thread. Others may be having luck with DLNA. I personally haven't used the Popcorn Hour.

 

kingJahfy, if you use the Plex UnRAID version (linked to from this page), you can use these commands (again from the forum post):

 

to start PMS:

"/etc/rc.d/rc.plexmediaserver start" or restart your server or stop/start your array

 

to stop PMS:

"/etc/rc.d/rc.plexmediaserver stop" or stop your array

 

So the new way to do things isn't to use the plugin listed here. I haven't personally upgraded yet, but it's on my to-do list.

Link to post

ok, I think Plex is running now, as it says this at the bottom when viewing the icon in Settings,

 

Plex Media Server is running with version v0.9.6.4.154-c16a2c6

 

Is that the latest / best version?

 

Also, I have a stupid question.  All of my movies are stored on a Share, which means the files are actually located on several disks.  Within Plex config, how do I point the Plex server to the movie Share?  I tried \\ip address\Share  but that didn't work.  The Plex screen is blank, showing no content at all.

 

I created library and temp folds on disk 5 and pointed Plex to those.  I just selected a disk for now but I would prefer to move this to the Cache drive so my array can go to sleep.

 

For my Popcorn hour, I have the new A300.  I'll check and see if there is a special app for Plex.  I will be happy to test this if I can get my Plex server running correctly.  :)

 

Update: I figured out how to point Plex to my share  /mnt/user/share_name

 

Link to post

another dumb question....after I add new movies to my folder, do I have to manually tell Plex to rescan the folder to pick up the new ones?  Or does it scan on some schedule?  The mannual process works but I have to go into Plex on the server and tell it to Update Selection to tell it to scan everything again.  This takes a long time too.

 

I have this all working now, I think.  I'm able to view my movies from my pc, iphone, ipad, etc.  The plugin server side of things seem to be ok.  I guess I still have to manually stop Plex and Start it for reboots.  I also need to move the temp and lib folders to the cache drive so my array will go to sleep. 

 

Oh, for updates to this solution, I would expect I just drop the new updated file in the extra folder and that's it....correct?

 

Link to post

So I am currently running version 0.9.3.5 of this plugin. What i noticed is that there is no myplex login pane in the settings of the server. My first question is if I update to the more current version will I gain this option? My second question is, to update do I only have to place the .tgz file from the first post into the extra folder, or is there more to the update process? Thanks for the help.

 

- Greg

Link to post

I'm sometimes getting chopy playback and Plex has been running a long time.  I'm thinking I need to monitor my cpu and memory to find out.  I see the cpu and memory graphs on the Stats page.

 

How much memory is recommended? I only have 4gb of ram so perhaps I need more.

 

Anyone else notice performance issues re resources?

Link to post
  • 2 weeks later...

is this thread dead or what??  No replies worries me that we will keep this alive.

 

Anyone know where the Plex server log is stored re our Unraid setup?  I'm troubleshooting some choppy playback and need to review the logs.

 

Thanks!

Link to post
  • 1 month later...

No, not dead - It is just there is lots of finegglin to get plex to work right. The newest Plex version has lots of fixes for DLNA faults and general improvements/patches for more devices, so it may be worthwhile to try it now.  Truth is, I plan to try it on an old 1.7 Ghz AMD Dual Core laptop running Vista first. I am almost convinced that it makes more sense to install Plex, Serviio, PS3 Media Server or nearly any of the other media servers on a SNAP drive, and that you need a three or four core 2.4+ Ghz processor to really pull this off. (Or an AMD Bulldozer 8 core to transcode anything to any device or if you just suffer from Tim Taylor Syndrome)

Link to post
  • 1 month later...

Hi all

 

I just installed Stokkes' full install package and it all works really well.

 

However, I notice that Plex has moved on and certain features are no longer supported (such as browse for poster art and Secure Server access).  I need to upgrade to a later version.  Does anyone have any advice to give?

 

[*]Do I need to install the "light" version, and if so, how do I uninstall the full version?

[*]Is the latest version of Plex compatible with this plugin?

[*]Would it be a good idea/ possible to merely install a later version in a different location and point to it instead, thus keeping an escape route handy?

 

Not being very command line savvy, I notice that the current version of Plex is located in /usr/local/plex  I can only get to this via telnet.  Is this right, or should I be able to find it via the Mac Finder window?  Also, is this located on the bootable USB stick?

 

Many thanks for any help you can give.  It is a real shame that Stokkes has withdrawn, I think he has produced something really good here.

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.