Jump to content

VDisk Bus - Virtio: Windows 10 Doesn't Detect Drive To Install To


Go to solution Solved by SimonF,

Recommended Posts

I'm doing something wrong here but I just can't figure it out. I'm trying to create a brand new Windows 10 VM from scratch. I have the latest VirtIO driver iso and set the following:

  • Primary vDisk Location: Auto
  • Primary vDisk Bus: VirtIO
  • Boot Order: 1

Windows doesn't detect any drives to install to, even when I try loading drivers from the VirtIO iso. If I change the vDisk Bus to SATA, it works and Windows shows a drive to install to. My understanding is that VirtIO is superior but regardless...what am I doing wrong? Why can't I install Windows 10 using VirtIO?
Any help will be greatly appreciated! Thank you

Capture1.JPG

Capture2.JPG

Capture3.JPG

Capture4.JPG

Link to comment

There are not many options for this not to work, make sure you are getting your Windows ISO from the Microsoft site, also get the US English release, sometimes there have been some strange issues with some localized releases, also that it's the 64 Bits release, then check the MD5 for the ISO on your Windows PC and confirm it matches after it's transferred to Unraid:

 

After downloading the file in Windows run in Powershell

certutil -hashfile path_to_file MD5

 

After transferring the file to Unraid run in the console:

md5sum path_to_file

 

Compare both results, they must be the same.

 

Do the same for the virtio ISO file you can get it from here:

https://fedorapeople.org/groups/virt/virtio-win/direct-downloads/archive-virtio/?C=M;O=D

 

Get the same release than the one you're using with Unraid and compare the checksums.

 

17 hours ago, eliminatrix2 said:

tried different folders

 

This is the folder that you should use: \viostor\w10\adm64 folder

Link to comment
2 hours ago, JorgeB said:

After transferring the file to Unraid run in the console:

 

Errr....what's the syntax for listing the directory? It's in my 'isos' folder but I can't figure out how to write the directory properly in the Unraid console. I keep getting 'no such file or directory'

Link to comment
6 minutes ago, JorgeB said:

Try what SimonF mentioned.

DSFOIGHESOIGNEGPEWNGEWPOGJEWPOGWEJGPOEWEJGPEWJFGPOFEJDPGOJEQPOGEJEWPOGJWEPOGJEWOPGEWJGPOEWJGPEWOGJWEPOGJEWPOG

GOIHFQPOGJEGPEOQJEG-3-IJP[EOQOGJ3[RTJ32-0T30UT23-03-TU23-0R0U123T-0U23T-02U-023JF23-0JT0G-023JT0-233JT-023JT23-URT328R2390RU2390UR

WROIQWHRPQWO[RJFQWPORJQWOP[3RT32QWI2RIF0[PQ3JR[PQWOTJRQ3PORTJQ3P3O[TJQ3[PORTROJQ3TR[POJQ3RPO[QWJR[POQJRWPOQRW

Wot.
I have been banging my head against this for like...two DAYS straight. That was me just facerolling over the keyboard. I switched it from IDE to SATA and now it's detecting the drive as it should. What the fudge cake banana.

  • Like 2
Link to comment
10 minutes ago, JorgeB said:

Try what SimonF mentioned.

The frusrating thing about this whole situation was that I already had a Windows 10 VM, but it crashed. I'd start it up but it wouldn't boot into Windows. It would either go to the recovery menu or BSOD with inaccessible boot device. I'd had it for months and I'd followed a couple of SI1 videos setting up VirtFS but for the life of me, I couldn't remember how I got it to install Windows in the first place.
Now I'll remember - change IDE to SATA for the install CD / iso

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...