Jump to content

xfs_repair: /dev/md1p1 contains a mounted and writable filesystem


Go to solution Solved by JorgeB,

Recommended Posts

I performed the update to 6.12.0 and after all 16 array dives state unmountable: unsupported or no file system. I have tried xfs_repair and get the following output:

 

xfs_repair: /dev/md1p1 contains a mounted and writable filesystem

fatal error -- couldn't initialize XFS library

 

The above was using the defualt arg of -n with the array in Maintenace mode.

cleverlyserver-diagnostics-20230617-0322.zip

Link to comment

The cause of that was this error:

Jun 16 09:46:01 CleverlyServer emhttpd: error: mdcmd, 4184: Invalid argument (22): write

 

It happens very rarely to some users, not quite sure the cause yet, if you see the same issue again, all disks unmountable, a reboot should always fix it.

 

 

 

 

  • Upvote 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...