Jump to content

Upgrade from 6.11.5 to 6.12.1, array becomes unmountable


Go to solution Solved by 20051231,

Recommended Posts

After upgrading to 6.12.1, the first boot was success and all drives are mountable. Then I restarted the server again, after the next boot, two drives becomes unmountable and log shows following error.

 

XFS (md1p1): Metadata CRC error detected at xfs_sb_read_verify+0x11e/0x1aa [xfs], xfs_sb block 0x0

 

I tried to run xfs_repair on two unmountable drive, it complete successfully but still cannot mount in array.

 

 

tower-diagnostics-20230626-0347.zip

Link to comment
  • Solution

please close the post, I managed to rebuild the parity and fix the issue.

 

I am running parity and two disks got disabled but the parity disk is not sync so the emulated disk is corrupted for the metadata part which is written frequently. I am running fsck on physical disk which is not being used as they are disabled.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...