Jump to content

NIC Passthrough for pfSense VM


Recommended Posts

Hello all,

 

I'm trying to create a pfSense VM on one of my Unraid boxes, but I can't get passing through the NIC to work.

 

Error message:

internal error: qemu unexpectedly closed the monitor: qxl_send_events: spice-server bug: guest stopped, ignoring 2023-07-02T19:10:29.604731Z qemu-system-x86_64: -device {"driver":"vfio-pci","host":"0000:11:00.0","id":"hostdev0","bus":"pci.1","addr":"0x0"}: vfio 0000:11:00.0: failed to setup container for group 40: Failed to set iommu for container: Operation not permitted

 

System Devices:

image.thumb.png.48c10043ced2b0b8d764066bb295956d.png

 

I've tried this with PCIe ACS override disabled, downstream, multi-function, and both; same error every time.

 

 

Please let me know what other information is needed to figure this out. Thanks.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...