Connect to a VM using UNRAID own VNC server/repeater/proxy/or-whatever-it-is...


NLS
Go to solution Solved by JonathanM,

Recommended Posts

So, for some unknown reason, I cannot connect to KVM own VNC when trying from VPN (!), while locally it works.
VPN works fine in all other aspects.

I am actually not looking into resolving this yet.


Instead, I am trying to see how I can utilize my working guacamole to VNC connect to my VMs.
Why? Because it works even if a VM networking is down. Which is the issue with one of my VMs.
I know I can see the VM and fix it when I go home and see the server from LAN, but I would prefer to be able to use it remotely too.
I can see the string "VNC connect" menu item creates, but I couldn't replicate this to a guacamole connection...
(I also tried repeater and proxy fields)

Can it work?

Link to comment
8 hours ago, JonathanM said:

What address and port are you trying in guac? I know a plain VNC client works fine for me using the server ip and the normal 5900, 5901, 5902, etc depending on what order the VM's were started. The VMS tab graphics column shows the port.

 

That was it!
I used 5701 although I should use 5901!

Thanks!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.