Jump to content
We're Hiring! Full Stack Developer ×

Is Plex crashing my Unraid?


Go to solution Solved by paulmorabi,

Recommended Posts

My Unraid server has been freezing randomly over the last few days. I've enabled syslog and the last lines recorded before the system freezing are:

 

Quote

Oct  4 02:10:04 FatBoy kernel: PMS LoudnessCmd[17642]: segfault at 0 ip 00001513356b3920 sp 00001513301180c8 error 4 in libswresample.so.4[1513356ab000+18000] l

ikely on CPU 0 (core 0, socket 0)

Oct  4 02:10:04 FatBoy kernel: Code: cc cc cc cc cc cc cc cc cc cc 8d 04 49 48 98 4d 89 c1 49 29 c1 48 63 c2 48 63 c9 49 39 f9 76 7c 66 2e 0f 1f 84 00 00 00 00 

00 <f3> 0f 10 06 f3 0f 5a c0 f2 0f 11 07 f3 0f 10 04 06 48 01 c6 f3 0f

 

I'm running Plex via docker on the server with GPU pass through via an NVidia card. I've updated Plex recently also upgraded to 6.12.4. However, on the latter, the first crash happened prior to that. 

 

I've attached diagnostics and prior to this happening over the last few days had months of stability without any issues with the same setup. Any help would be appreciated.

 

fatboy-diagnostics-20231004-0817.zip

Link to comment
12 minutes ago, JorgeB said:

Without anything logged difficult to guess what the problem is, you could try downgrading to v6.11.5 and see if the same thing happens.

Why that version? 6.12.3 and all other previous versions were also super stable until this started a few days back (and it was on 6.12.3 when this first happened).

Link to comment
2 hours ago, paulmorabi said:

6.12.3 and all other previous versions were also super stable until this started a few days back (and it was on 6.12.3 when this first happened).

So it was stable with 6.12.3 or not? If the issue started out of the blue with a known good release it could be hardware related, that usually does not leave anything logged.

Link to comment
15 hours ago, JorgeB said:

So it was stable with 6.12.3 or not? If the issue started out of the blue with a known good release it could be hardware related, that usually does not leave anything logged.

 

Yes, it started out of the blue last Sunday. The only thing I did prior to that was update Plex. And one week before that, edit some of the CPU pinning and isolation settings for my docker and VM.

Link to comment
1 hour ago, JorgeB said:

Try with Plex disabled, if it still crashes it's likely hardware, if not Plex would be the likeky problem.

 

I've updated the BIOS and edited the BIOS settings to:

* Disable C states

* Set power supply idle control to typical current

* disabled all over clocking and XMP profile.

* disabled CPPC preferred cores and CPPC

 

I noticed these were mentioned elsewhere as affecting stability especially on older Ryzen's. However,  they've never caused issues before here. I also removed a USB card I no longer use and given it a general dusting inside. High temperature doesn't seem to be an issue though.

 

The Plex error and the kernel code error occurred again overnight and it only froze an hour or so ago so probably not that either. If it crashes again, I'll revert the BIOS settings and disable all dockers, including Plex, and probably also the VM I have running. If it stays up more than 48 hours then the problem is somewhere there and I need to gradually enable things until it freezes again?

 

I can also restore from a backup I took about ~2 months ago. 

 

If it's hardware, where do you recommend I start?

Edited by paulmorabi
Link to comment
22 hours ago, JorgeB said:

Since you have two sticks of RAM, try with just one, if the same try the other one, that would basically rule out bad RAM.

 

OK, had another crash with all of those BIOS changes so reverted the settings and took a stick of memory out. Will alternate if it happens again. 

 

I'm guessing its unlikely both suddenly became faulty so if its happening with both sticks then its somewhere else? 

Link to comment
On 10/8/2023 at 12:35 PM, JorgeB said:

Most likely, it would very bad luck to have 2 bad sticks, but of course not impossible.

 

Last Sunday, I removed a stick of RAM and reseated the CPU heatsink and cleaned a few other areas. I don't want to jinx myself but its been 7 days and no system freezes as yet. Looks like it is probably RAM gone bad and/or cleaning/reseating a few things has fixed it? Either way, I'll give it a couple more days and purchase replacement RAM.

 

On RAM, is there anything I should look out for when it comes to purchasing? Given this will run 24/7, apart from ECC, anything I need to consider?

Link to comment
  • 4 weeks later...
  • Solution
On 10/16/2023 at 8:37 AM, paulmorabi said:

 

Last Sunday, I removed a stick of RAM and reseated the CPU heatsink and cleaned a few other areas. I don't want to jinx myself but its been 7 days and no system freezes as yet. Looks like it is probably RAM gone bad and/or cleaning/reseating a few things has fixed it? Either way, I'll give it a couple more days and purchase replacement RAM.

 

On RAM, is there anything I should look out for when it comes to purchasing? Given this will run 24/7, apart from ECC, anything I need to consider?

 

Crashes stopped after this and I replaced the RAM so seems like it was a faulty RAM stick.

Link to comment
  • 1 month later...

Running 6.12.6, add second solid state drive for cash setup with other 1 tb solid id s raid mirror. 14tb parity. 2 14tb array drives and 1 4tb drive. Been at this for a week now, I have changed setting, bios, removing plugs updated plugin. At this point I have no close what to do. Cache are set to zfs. Have plex,sab, radarrm sonarr, Home assist, I ran the last time with plex just going and in about 30 min, server frozen beaning I have to force power down and reboot. I get something is wrong in docket or its my plex configurations

conwayserver-diagnostics-20231229-0817.zip

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...