Jump to content

After upgrade to 6.12.4 Ubuntu VM no longer works with virtio

Recommended Posts

After upgrading to 6.12.4 from 6.11.5 my ubuntu VM is no longer able to load the os when using virtio. I switch that to sata and then I can get to the OS via VNC but the virtio network still doesn't seem to work at all. I have tried several different network configs to get it to work but none are working. I am currently back to the way it was prior to the upgrade.


VMName: Raichu -- VM settings are contained in the diagnostics bundle.


Attaching details



Link to comment
  • 1 month later...

I've been wracking my brain on this, and have found a bunch of articles close to this, but nothing specific. My ubuntu vm is 20.04, and I have found that loading the e1000 for network model seems to get a good nic loaded. I don't know why after the unraid upgrade that this has occurred, nor have I found information YET on why the e1000 model works. I do have intel dual nics in my unraid server... I also found that the vmxnet model from vmware also seems to work. 


You can also check that the vm sees a nic by running lshw -C network


For me the virtio model yielded the nic as UNCLAIMED.. 

For vmxnet and e1000, the nic was DISABLED.


So I could manually start the nic then. I then edited /etc/network/interfaces and changed the NIC to the correct one from the lshw command. For me, mine changed from ens1p0 to ens1.



Also, at least your vm booted. It took me forever to figure out why the virtual disk was no longer working, and so the vm wouldn't even boot.


Hopefully this helps a bit?

Edited by hamish_18
Added additional information.
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...