Jump to content

Warning needed for SMTP add-on


dgaschk

Recommended Posts

The SMTP add-on or and add-on which uses SMTP writes the users e-mail password in clear text to the syslog. A warning is need for SMTP add-on users to sanitize their syslogs before posting. Search for the password and delete it before posting.

 

Please add this warning to the unMenu package manager and any other SMTP installation instructions.

Link to comment

Under what conditions are you seeing this behaviour? My box sends me status emails every day, and looking at the syslog using the unmenu syslog link the smtp log lines definitely do NOT contain my password. Email address, yes, but not the password. Perhaps the unmenu plugin is already sanitizing it for me?

Link to comment

Wow. My syslog only has three lines for a status email.

Sep 30 06:47:04 AVFILES sSMTP[12706]: Creating SSL connection to host
Sep 30 06:47:04 AVFILES sSMTP[12706]: SSL connection using RC4-SHA
Sep 30 06:47:09 AVFILES sSMTP[12706]: Sent mail for root@[email protected] (221 2.0.0 closing connection fz6sm5052331qab.21) uid=0 username=root outbytes=741

That's it. No transaction details, nothing.

Link to comment

Wow. My syslog only has three lines for a status email.

Sep 30 06:47:04 AVFILES sSMTP[12706]: Creating SSL connection to host
Sep 30 06:47:04 AVFILES sSMTP[12706]: SSL connection using RC4-SHA
Sep 30 06:47:09 AVFILES sSMTP[12706]: Sent mail for root@[email protected] (221 2.0.0 closing connection fz6sm5052331qab.21) uid=0 username=root outbytes=741

That's it. No transaction details, nothing.

Ditto of the above.

Link to comment

The SMTP add-on or and add-on which uses SMTP writes the users e-mail password in clear text to the syslog. A warning is need for SMTP add-on users to sanitize their syslogs before posting. Search for the password and delete it before posting.

 

Please add this warning to the unMenu package manager and any other SMTP installation instructions.

I can certainly add the warning to the unMENU packages I distribute, but am a bit confused as to what caused the behavior you are seeing. 

 

It is as if your installation is invoking the mail command with debugging enabled.  (in other words, invoking "ssmtp" with the "-d" option to debug, rather than invoking mail which then invokes sendmail)  The entire exchange between your mail server and the unRAID ssmtp command are not output unless debugging is enabled with the "-d" option to ssmtp.

 

Tell us more where you got your copy of sSMTP

What other packages have you installed that are not part of stock unRAID? 

Have you edited any of the scripts when initially getting your mail configured?

 

Joe L.

Link to comment

The SMTP add-on or and add-on which uses SMTP writes the users e-mail password in clear text to the syslog. A warning is need for SMTP add-on users to sanitize their syslogs before posting. Search for the password and delete it before posting.

 

Please add this warning to the unMenu package manager and any other SMTP installation instructions.

I can certainly add the warning to the unMENU packages I distribute, but am a bit confused as to what caused the behavior you are seeing. 

 

It is as if your installation is invoking the mail command with debugging enabled.  (in other words, invoking "ssmtp" with the "-d" option to debug, rather than invoking mail which then invokes sendmail)  The entire exchange between your mail server and the unRAID ssmtp command are not output unless debugging is enabled with the "-d" option to ssmtp.

 

Tell us more where you got your copy of sSMTP

What other packages have you installed that are not part of stock unRAID?   

Have you edited any of the scripts when initially getting your mail configured?

 

Joe L.

I'm wondering if he is using the ssmtp that is included in the SimpleFeatures GUI?

Link to comment

The SMTP add-on or and add-on which uses SMTP writes the users e-mail password in clear text to the syslog. A warning is need for SMTP add-on users to sanitize their syslogs before posting. Search for the password and delete it before posting.

 

Please add this warning to the unMenu package manager and any other SMTP installation instructions.

I can certainly add the warning to the unMENU packages I distribute, but am a bit confused as to what caused the behavior you are seeing. 

 

It is as if your installation is invoking the mail command with debugging enabled.  (in other words, invoking "ssmtp" with the "-d" option to debug, rather than invoking mail which then invokes sendmail)  The entire exchange between your mail server and the unRAID ssmtp command are not output unless debugging is enabled with the "-d" option to ssmtp.

 

Tell us more where you got your copy of sSMTP

What other packages have you installed that are not part of stock unRAID?   

Have you edited any of the scripts when initially getting your mail configured?

 

Joe L.

I'm wondering if he is using the ssmtp that is included in the SimpleFeatures GUI?

He could be...  in which case, it is the issue as it has debugging enabled.
Link to comment

I got detail from the user with the issue. He is using SimpleFeatures.

 

5.0Beta12 (not 12a, would never boot on my Server with 12a)

 

Here is my GO file

 

#!/bin/bash

# Start the Management Utility

/usr/local/sbin/emhttp &

installpkg /boot/packages/simpleFeatures-0.9b-unraid-speeding_ant.tgz

/boot/unmenu/uu

unraid_notify start

 

The only unmenu add-ons I think that are running is the UPS stuff and possible the SMART add-on.

 

How does he turn off debugging?

Link to comment

I got detail from the user with the issue. He is using SimpleFeatures.

 

5.0Beta12 (not 12a, would never boot on my Server with 12a)

 

Here is my GO file

 

#!/bin/bash

# Start the Management Utility

/usr/local/sbin/emhttp &

installpkg /boot/packages/simpleFeatures-0.9b-unraid-speeding_ant.tgz

/boot/unmenu/uu

unraid_notify start

 

The only unmenu add-ons I think that are running is the UPS stuff and possible the SMART add-on.

 

How does he turn off debugging?

Contact the author of that package.  Let them know of the issue.  Basically, do NOT use the "-d" option when invoking ssmtp.

 

Joe L.

Link to comment

I got detail from the user with the issue. He is using SimpleFeatures.

 

5.0Beta12 (not 12a, would never boot on my Server with 12a)

 

Here is my GO file

 

#!/bin/bash

# Start the Management Utility

/usr/local/sbin/emhttp &

installpkg /boot/packages/simpleFeatures-0.9b-unraid-speeding_ant.tgz

/boot/unmenu/uu

unraid_notify start

 

The only unmenu add-ons I think that are running is the UPS stuff and possible the SMART add-on.

 

How does he turn off debugging?

 

Settings page-->

Notifications-->

SMTP Configuration-->

The first setting is Debug.. yes or no.

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...