Jump to content

[SOLVED]SAMBA is STOPPED, Shared drives will not be visible on the LAN


Flomaster

Recommended Posts

so I have several problems.

 

unraid version is 4.X as far as I can remember as I can't access the main page at all.

 

1. my 192.16X.X.X/main.htm does not work and I have no idea what version of unraid I am running.

2. unMenu works, but any time I try and click on some thing it try to go to tower:8080/XXXXX  

   2a. //tower:8080 doesn't work nor does any variation of it. I have to type in my IP address to get into unMenu

3.I was transfering a movie from one disk to another via midnight commander when it just froze the sever causing me to do a hard power down with the power button

4. now I get the samba is stopped error.

 

I have tried removing the secrets.tdb file from /etc/samba/private/secrets.tdb and restarting samba  /root/samba restart it was recreated but still not working

 

 

here is a copy of my sys log I have attached it as well

http://pastebin.com/cZAeg0EE

 

 

here is my go script

#!/bin/bash
# Start the Management Utility
/usr/local/sbin/emhttp &
/boot/config/snap/snap.sh -b

#install etherwake
installpkg /boot/packages/etherwake-1.09-i686-3cf.txz

#start unMENU
/boot/unmenu/uu

# Install Nano
installpkg /boot/packages/nano-2.2.4-i486-unRAID.txz

#extrafanart script
cp /boot/extrafanart.sh ~/

# determine if cache drive online, retry upto 7 times
for i in 0 1 2 3 4 5 6 7
do
   if [ ! -d /mnt/cache ]
   then
     sleep 15
   fi
done

# If Cache drive is online, start SABnzbd, Sickbeard, and CouchPotato
if [ -d /mnt/cache ]; then
 cd /mnt/cache/.custom
 installpkg /boot/packages/SABnzbdDependencies-2.1-i486-unRAID.tgz
 python /mnt/cache/.custom/sabnzbd/SABnzbd.py -d -s 0.0.0.0:88
 nohup python /mnt/cache/.custom/sickbeard/SickBeard.py &
 python /mnt/cache/.custom/couchpotato/CouchPotato.py -d
fi

cd /boot/packages && find . -name '*.auto_install' -type f -print | sort | xargs -n1 sh -c 

 

any help would be great as we do not have tv and use the server for all kids movies and tv shows

 

-=Jason=-

syslog-2011-10-01_1.txt

Link to comment

You have many out-of-memory messages in your logs and the linux kernel is killing off processes that have been idle the longest to attempt to free some.

 

Basically, you ran out of free memory.  You are loading too many packages for the amount of memory in your server.

 

It might be "unrar" attempting to uncompress something and using all the memory.

 

Here is where the shared file system was killed (user-shares)

Oct  1 10:59:19 Tower kernel: Out of memory: kill process 1478 (shfs) score 313 or a child

Oct  1 10:59:19 Tower kernel: Killed process 1478 (shfs)

Oct  1 10:59:20 Tower kernel: unrar invoked oom-killer: gfp_mask=0x200d2, order=0, oom_adj=0

Oct  1 10:59:20 Tower kernel: Pid: 2386, comm: unrar Not tainted 2.6.32.9-unRAID #8

and here is where it killed SAMBA

Oct  1 10:59:20 Tower kernel: Out of memory: kill process 1367 (smbd) score 212 or a child

Oct  1 10:59:20 Tower kernel: Killed process 1367 (smbd)

 

You are on version 4.7

Oct  1 10:58:21 Tower emhttp: unRAID System Management Utility version 4.7

 

as far as //tower not working,  configure your "hosts" files on the machines accessing it, and it will.  (Common issue for those using a MAC)

or, for unMENU, set the variables in unmenu_local.conf as described in other posts.

 

You either need to configure unrar to use something other than /tmp, and other than /var/tmp (or, rather, somewhere other than a directory in  RAM) to use as a temp directory for un-compressing files, or stop using unrar for such large files.

 

You might be able to set a TEMPDIR environment variable to point to a directory on a disk, but that will only work if unrar uses it... (I have no idea if it does)

 

Joe L.

Link to comment

what is crazy is I haven't installed anything new or done anything different to my server. im not even sure why I need unrar or what is is doing.

 

basically im at very limited options here. I can't access the main unraid menu and unmenu runs half ass because the buttons aren't working the way they should "going to check out variables in unmenu_local.conf now"

 

-=Jason=-

Link to comment

Joe, I have made the changes in the unmenu.conf file to use my IP address and all is working however when I click on the package manger link or the myMain

e
</BODY></HTML>
0

 

I still can't access the "package manager", or "myMain" also I am blocked from getting into the regular unraid menu  192.x.x.x.x/main.htm no longer works for me  ;(  but when I try and get to it via unmenu "uRAID Main" link I end up with this.

 

TPJh2.jpg

 

 

-=Jason=-

Link to comment

Joe, I have made the changes in the unmenu.conf file to use my IP address and all is working however when I click on the package manger link or the myMain

e
</BODY></HTML>
0

 

I still can't access the "package manager", or "myMain" also I am blocked from getting into the regular unraid menu  192.x.x.x.x/main.htm no longer works for me  ;(  but when I try and get to it via unmenu "uRAID Main" link I end up with this.

 

TPJh2.jpg

 

 

-=Jason=-

Did you notice I said

unmenu_local.conf

(you need to create the file if it does not exist)

You probably also made the changes using an editor that puts carriage returns on the ends of the lines.

 

Joe L.

Link to comment

opps sorry joe.

 

I have copied the unmenu.conf file and named it unmenu_local.conf  I am still experiencing the same problems however I am about to click around on other links and have them work correctly.

 

but "pkg manager" "myMain" "unRAID main" still are not functioning properly.

 

im about ready to just try a fresh install on the flash disk and go through the hours of setting up sabnzbd, sickbeard, and couch potato.

 

might as well just upgrade to 5.X beta while I am at it.

-=Jason=-

Link to comment

By the way - there no point in masking out IP addresses that are private to your network.  They are not unique to you - and no one outside would be able access them directly anyway.  In some cases, showing them can actually help diagnosis of some types of problems.

Link to comment

By the way - there no point in masking out IP addresses that are private to your network.  They are not unique to you - and no one outside would be able access them directly anyway.  In some cases, showing them can actually help diagnosis of some types of problems.

well its nothing special but its been working just fine 192.168.3.10.... everything was chugging along fine until I was moving some movies from one disk to another using Midnight Commander. next thing I know it just locked up I had to press the power button. now its running out of memory, I can't access 192.168.2.10/main.htm. which is pretty big deal since that is how your shares are handled.

 

wife and son are not happy and driving me nuts.

 

-=Jason=-

Link to comment

opps sorry joe.

 

I have copied the unmenu.conf file and named it unmenu_local.conf  I am still experiencing the same problems however I am about to click around on other links and have them work correctly.

 

but "pkg manager" "myMain" "unRAID main" still are not functioning properly.

 

im about ready to just try a fresh install on the flash disk and go through the hours of setting up sabnzbd, sickbeard, and couch potato.

 

might as well just upgrade to 5.X beta while I am at it.

-=Jason=-

I've not yet learned to walk, so instead of getting that figured out, I'll see if I can get a job dancing in a Broadway show.  ;)

 

update your unMENU install.  It will fix the unRAID Main issue I corrected recently.

 

The issues you have with using all your RAM have nothing to do with the version of unRAID you are using.  

IT has everything to do with how the packages you are using are configured and using RAM.

 

apparently one of your added packages has downladed a HUGE file, one when un-compressed occupies more memory than you have when un-compressed.

 

that is the cause of your issues.  But... moving to a different version of unRAID will not fix it.  You need to fix the programs causing the problem. (Or add a LOT more RAM)

Link to comment

sorry joe im very noobish at this unRaid. I had it all setup after spending hours upon hours and late nights getting it dialed in and I just let it be. now I have a problem I seem to have forgot everything I learned along the way.

 

here is what is in my /boot/packages/ folder anything look out of line?



root@Tower:~# ls /boot/packages/
AirVideoServerLinux.jar*
SABnzbdDependencies-2.1-i486-unRAID.tgz*
airvideo-unmenu-package.conf*
apcupsd-unmenu-package.conf*
apcupsd3-unmenu-package.conf*
bwm-ng-0.6-i486-2bj.tgz*
bwm-ng-0.6-i486-2bj.tgz.auto_install*
bwm-ng-0.6-i486-2bj.tgz.manual_install*
bwm-ng-unmenu-package.conf*
compiler-unmenu-package.conf*
cpio-unmenu-package.conf*
cxxlibs-unmenu-package.conf*
dmidecode-unmenu-package.conf*
ds_store_cleanup-unmenu-package.conf*
dynamic-dns-unmenu-package.conf*
encfs-unmenu-package.conf*
etherwake-1.09-i686-3cf.txz*
faac-1.26-i486-1gds.tgz*
faad2-2.6.1-i486-2gds.tgz*
ffmpeg-for-2.2.5.tar.bz2*
file-unmenu-package.conf*
git-1.6.0.3-i486-1.tgz*
hdparm-9.27-unmenu-package.conf*
htop-unmenu-package.conf*
iftop-unmenu-package.conf*
image_server-unmenu-package.conf*
inotify-tools-3.8-i486-1.tgz*
inotify-tools-unmenu-package.conf*
iperf-unmenu-package.conf*
istat-unmenu-package.conf*
jam-2.5-i486-2gal.tgz*
jre-6u11-i586-1.tgz*
jre-unmenu-package.conf*
lame-3.98.2-i486-1gds.tgz*
libX11-1.1.5-i486-1.tgz*
libXau-1.0.4-i486-1.tgz*
libxcb-1.0-i486-1ced.tgz*
lighttpd-unmenu-package.conf*
lsof-unmenu-package.conf*
mail-ssmtp-unmenu-package.conf*
mail_status-unmenu-package.conf*
md5deep-unmenu-package.conf*
midnight_commander-unmenu-package.conf*
monthly-parity-unmenu-package.conf*
mover_conditional_sync-unmenu-package.conf*
mover_exclude_underscore-unmenu-package.conf*
mover_fix-logging-unmenu-package.conf*
mpeg4ip-1.5.0.1-i486-1ahl.tgz*
mysql-5.0.67-i486-1.tgz*
mysql-5.0.67-i486-1.tgz.manual_install*
mysql-unmenu-package.conf*
nano-2.2.4-i486-unRAID.txz*
nohup.out*
ntfs-3g-2010.3.6-i486-1.txz*
ntfs-3g-2010.3.6-i486-1.txz.manual_install*
ntfs-3g-2010.3.6-unmenu-package.conf*
ntfs-src-3g-2010.3.6-unmenu-package.conf*
openssh-unmenu-package.conf*
openssl-unmenu-package.conf*
p910nd-unmenu-package.conf*
pbzip2-unmenu-package.conf*
pciutils-unmenu-package.conf*
perl-unmenu-package.conf*
php-unmenu-package.conf*
powerdown-1.02-noarch-unRAID.tgz*
powerdown-1.02-noarch-unRAID.tgz.auto_install*
powerdown-1.02-noarch-unRAID.tgz.manual_install*
powerdown-overtemp-unmenu-package.conf*
powerdown_ctlaltdel-unmenu-package.conf*
proftp-unmenu-package.conf*
reiserfsck-3.6.21-unmenu-package.conf*
rsync-unmenu-package.conf*
ruby-unmenu-package.conf*
screen-unmenu-package.conf*
smartctl-unmenu-package.conf*
socat-unmenu-package.conf*
svn-unmenu-package.conf*
transmission-unmenu-package.conf*
unraid-mover-fix-logging.auto_install*
unraid-mover-fix-logging.manual_install*
unraid-swapfile-unmenu-package.conf*
unraid-web-unmenu-package.conf*
unrar-3.7.8-i486-1stc_slack12.1.tgz*
unrar-3.7.8-i486-1stc_slack12.1.tgz.manual_install*
unrar-unmenu-package.conf*
vim-unmenu-package.conf*
x264-20100425-i486-1alien.tgz*
xvidcore-1.2.1-i486-1sl.tgz*
yasm-0.7.2-i486-1sl.tgz*
zip-unmenu-package.conf*

 

I haven't installed anything new recently to cause this running out of memory thing so I am really at a loss as to what is going on.

 

and this is the version of unmenu I am using

#UNMENU_RELEASE $Revision: 201 $ $Date: 2010-12-23 16:20:06 -0500 (Thu, 23 Dec 2                                                                                                             010) $

 

I have a cache drive and I use that for Sabnzbd, Sickbeard, and CouchPotato.

 

-=Jason=-

 

 

EDIT: in my go file I have commented out SAb, Sick, and CP. I can now access the web gui and do not seem to be running out of memory. I had a memory problem before I installed a cache drive, but since I have installed one its been working prefect for 6 + months.

 

seems like I'll uncomment them out one by one and try and figure out with one is causing the problem.

 

 

Link to comment

OMG..... I am a freaking dumb ass....

 

so I added a new completion command to SAbnzbd so when i download a "KidsMovies" it goes into  a separate folder

 

it should have been going to /mnt/cache/.Downloads/Complete/KidsMovies

 

well it fat fingered the location to be /mnt/cache.Downloads/Complete/KidsMovies  if you notice this was creating a new directory in /mnt and trying to unrar 4Gigs worth of a movie. now every time I sart SABnzbd it tried to unpack this file which I can't see to locate once memory gets full and starts killing off everything.

 

seems like I need to start Sabnzbd and quickly kill the unpacking process.

 

-=Jason=-

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...