Jump to content

A Few Questions


Recommended Posts

My unRAID server has been running wonderfully for a few months, so I'm a little hesitant to change anything but I do have some questions.  I am currently running v5 b07.   I tried setting up the email notification awhile back and it never worked.  When I go into the Pkg Manager the "Mail and SSMTP" section says:

 

 

Installed, but current version is different.  Current Version=" expected '2.62'

 

 

If I try sending the test email using the send test email button in unMenu it says:

 

 

Mail is being sent to root.  With any luck, it will be forwarded properly.

/usr/sbin/sendemail: Exec format error

. . . message not sent

 

 

Also, I have a total of 3 drives.  2 x 3TB Hitachi HDD's and 1 x 2TB Hitachi.  I'm using one of the 3TB drives as my parity drive.  When I go into disk settings, they aren't all the same.  

 

Disk 1 (3TB)

Partition Format GPT: 4K-aligned

 

Disk 2 (2TB)

Partition Format MBR: 4K-aligned

 

Parity (3TB)

Partition Format GPT: 4K-aligned

 

I'm sure I screwed something up when I was setting everything up awhile back.  

syslog-2011-11-11.txt

Link to comment

No idea on the email, hopefully someone else can help.

 

unRAID is programmed to only use MBR on 2T and smaller so it won't allow you to use GPT. It might be possible if you could create the partition properly (partitioned how unRAID would and marked as precleared) when adding a new disk but I don't know enough about how unRAID checks for a valid partition to know for sure.

 

Peter

 

Link to comment

Cool.  So there is no problem with that.  I was worried for a minute.  

 

Any thoughts on the email issues?

 

as far as I know ssmtp_2.62.orig.tar.gz is the current package.

I know it was updated recently, i believe it was because Hotmail changed something and it broke.

 

 

Try running the unMENU update and see what it comes up with.

 

I had had to run the update (and Hotmail still didn't work, I switched to gmail).

Link to comment

Try running the unMENU update and see what it comes up with.

 

I had had to run the update (and Hotmail still didn't work, I switched to gmail).

 

I think I'm doing something wrong here.  I went into UserScripts in unMENU and hit the "Check for unMENU Updates" button which caused a button at the bottom of the page to appear that said "Install unMENU" updates.  It showed Revision 242 as the most current available.  I hit the "Install unMENU" updates button and then I get this:

 

Downloading dynamic-dns-unmenu-package.conf

rev $Revision: 242 $ $Date: 2011-08-06 10:34:39 -0400 (Sat, 06 Aug 2011) $

#--------------------------------------------------------#

### #AUTO_UPDATE = NO in dynamic-dns-unmenu-package.conf.

### Copied current dynamic-dns-unmenu-package.conf to ./unmenu_old_2011-11-11_1423/dynamic-dns-unmenu-package.conf

### New version NOT installed.

### New version is in /tmp/unmenu_tmp/dynamic-dns-unmenu-package.conf

### To see differences type:

diff /tmp/unmenu_tmp/dynamic-dns-unmenu-package.conf dynamic-dns-unmenu-package.conf

### To install new version of dynamic-dns-unmenu-package.conf type:

cp /tmp/unmenu_tmp/dynamic-dns-unmenu-package.conf dynamic-dns-unmenu-package.conf

#--------------------------------------------------------#

 

Then I hit the Restart unMENU.  The problem is that when I go to About it still shows me having Revision 241.  So something doesn't seem to be installing properly.

Link to comment

thats the dynamic-dns-unmenu-package, that has nothing to do with the SMTP package.

I actually get that also. I don not use the dynamic dns package so i never followed up on that error.

 

what is the full error message you get?

Installed, but version is different. Current version='x.x.x' expected 'x.x.x'

 

it sounds like you have the correct one installed...

 

Link to comment

what is the full error message you get?

 

If I look at the SSMTP package on the management page it shows:

Installed, but current version is different.  Current Version=" expected '2.62'

 

If I try sending an email I get this as an error.

 

Mail is being sent to root.  With any luck, it will be forwarded properly.

/usr/sbin/sendemail: Exec format error

. . . message not sent

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...