Jump to content

[SOLVED]Cannot use new data drive!!!


husky55

Recommended Posts

I have a problem which drives me crazy. I just added a second data drive, disk2 to my array.

 

Everything seems to work fine, no errors, drive 2 TB WD showed up properly. But I cannot write or

 

delete files or folders from my Win7 computer.

 

This only happened with disk2 (just added), with disk1 no problem ot R or W. I had tried for

 

hours on end with the user shares configuration to no avail. Export settings is set as R/W

 

and included disks as blank, disk1,disk2 all varieties of them. same results every times. I

 

can RW disk1 but not disk2.

 

Please help me. I have spent already 2 days adding this new WD 2 TB drive and now I cannot

 

use it.

 

permission.png.8e4c5776687997c62d821cb4eeec3b82.png

Link to comment

I used unraid 4.7. This is the latest info from my syslog. I am real new at unraid and am afraid to try out the 5.xx beta. I did have the WD20EARS drive. But I did set the MBR-4k-aligned and had no jumper on the drive. So that should be OK.

 

I can reboot win7 and see what happens.

 

Nov 12 22:51:20 Tower emhttp: shcmd (208): mv '/mnt/user/Media\Movies' '/mnt/user/Files' (Other emhttp)

Nov 12 22:51:20 Tower emhttp: shcmd (209): mv '/boot/config/shares/Media\Movies.cfg' '/boot/config/shares/Files.cfg' (Other emhttp)

Nov 12 22:51:20 Tower emhttp: _shcmd: shcmd (209): exit status: 1 (Other emhttp)

Nov 12 22:51:20 Tower emhttp: shcmd (210): rm /etc/samba/smb-shares.conf >/dev/null 2>$stuff$1 (Other emhttp)

Nov 12 22:51:20 Tower kernel: nfsd: last server has exited, flushing export cache

Nov 12 22:51:20 Tower emhttp: shcmd (211): cp /etc/exports- /etc/exports (Other emhttp)

Nov 12 22:51:20 Tower emhttp: shcmd (212): echo \"/mnt/disk1\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=11' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:51:20 Tower emhttp: shcmd (213): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:51:20 Tower emhttp: get_config_idx: fopen /boot/config/shares/Personal.cfg: No such file or directory - assigning defaults (Other emhttp)

Nov 12 22:51:20 Tower emhttp: shcmd (214): /etc/rc.d/rc.samba start | logger (Other emhttp)

Nov 12 22:51:20 Tower logger: Starting Samba:  /usr/sbin/nmbd -D

Nov 12 22:51:20 Tower logger:                  /usr/sbin/smbd -D

Nov 12 22:51:20 Tower emhttp: shcmd (215): /etc/rc.d/rc.nfsd start | logger (Other emhttp)

Nov 12 22:51:20 Tower logger: Starting NFS server daemons:

Nov 12 22:51:20 Tower logger:  /usr/sbin/exportfs -r

Nov 12 22:51:20 Tower logger:  /usr/sbin/rpc.nfsd 8

Nov 12 22:51:20 Tower logger:  /usr/sbin/rpc.mountd

Nov 12 22:51:20 Tower emhttp: disk_temperature: ATTR_Temperature_Celsius not found (Other emhttp)

Nov 12 22:52:00 Tower emhttp: shcmd (216): mkdir '/mnt/user/Media' (Other emhttp)

Nov 12 22:52:00 Tower emhttp: _shcmd: shcmd (216): exit status: 1 (Other emhttp)

Nov 12 22:52:00 Tower emhttp: shcmd (217): chmod 700 '/mnt/user/Media' (Other emhttp)

Nov 12 22:52:00 Tower shfs: shfs_chmod: chmod: /mnt/disk2/Media 040700 (30) Read-only file system

Nov 12 22:52:00 Tower emhttp: _shcmd: shcmd (217): exit status: 1 (Other emhttp)

Nov 12 22:52:00 Tower emhttp: shcmd (218): rm /etc/samba/smb-shares.conf >/dev/null 2>$stuff$1 (Other emhttp)

Nov 12 22:52:00 Tower emhttp: shcmd (219): cp /etc/exports- /etc/exports (Other emhttp)

Nov 12 22:52:00 Tower emhttp: shcmd (220): echo \"/mnt/disk1\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=11' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:52:00 Tower emhttp: shcmd (221): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:52:00 Tower emhttp: get_config_idx: fopen /boot/config/shares/Personal.cfg: No such file or directory - assigning defaults (Other emhttp)

Nov 12 22:52:00 Tower emhttp: shcmd (222): killall -HUP smbd (Minor Issues)

Nov 12 22:52:00 Tower emhttp: shcmd (223): /etc/rc.d/rc.nfsd restart | logger (Other emhttp)

Nov 12 22:52:00 Tower mountd[31109]: Caught signal 15, un-registering and exiting.

Nov 12 22:52:01 Tower kernel: nfsd: last server has exited, flushing export cache

Nov 12 22:52:02 Tower logger: Starting NFS server daemons:

Nov 12 22:52:02 Tower logger:  /usr/sbin/exportfs -r

Nov 12 22:52:02 Tower logger:  /usr/sbin/rpc.nfsd 8

Nov 12 22:52:02 Tower logger:  /usr/sbin/rpc.mountd

Nov 12 22:52:02 Tower emhttp: disk_temperature: ATTR_Temperature_Celsius not found (Other emhttp)

Nov 12 22:56:00 Tower emhttp: disk_temperature: ATTR_Temperature_Celsius not found (Other emhttp)

Nov 12 23:35:01 Tower last message repeated 3 times

Link to comment

I found out that the disk1 (problem free disk) has a FS reiserfs, while disk2 FS is unknown. So how do I fix this? I know that unraid used reiserfs file system FS. I did  preclear and it showed no errors . so I formatted and added to the array. I am pretty sure I messed up somewhere.

 

So something is making my disk2 as read only file system. How do I change this to read and write?

 

 

Nov 12 22:31:06 Tower emhttp: shcmd (88): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:33:24 Tower emhttp: shcmd (99): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:34:14 Tower shfs: shfs_rename: rename: /mnt/disk2/Files /mnt/disk2/Media/Files (30) Read-only file system

Nov 12 22:34:14 Tower emhttp: shcmd (109): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:34:39 Tower emhttp: shcmd (119): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:35:25 Tower shfs: shfs_rename: rename: /mnt/disk2/Media /mnt/disk2/Backups (30) Read-only file system

Nov 12 22:35:25 Tower emhttp: shcmd (129): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:35:49 Tower shfs: shfs_rmdir: rmdir: /mnt/disk2/Media (30) Read-only file system

Nov 12 22:35:49 Tower emhttp: shcmd (139): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:36:13 Tower shfs: shfs_chmod: chmod: /mnt/disk2/Files 040700 (30) Read-only file system

Nov 12 22:36:13 Tower emhttp: shcmd (148): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:39:33 Tower shfs: shfs_rename: rename: /mnt/disk2/Files /mnt/disk2/Media/Files (30) Read-only file system

Nov 12 22:39:33 Tower emhttp: shcmd (158): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:42:47 Tower shfs: shfs_rename: rename: /mnt/disk2/Media /mnt/disk2/Backups (30) Read-only file system

Nov 12 22:42:47 Tower emhttp: shcmd (168): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:45:25 Tower emhttp: shcmd (178): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp)

Nov 12 22:45:32 Tower emhttp: shcmd (185): echo \"/mnt/disk2\" '-async,no_subtree_check,anongid=0,anonuid=0,all_squash,fsid=12' '*(rw)' >>/etc/exports (Other emhttp

Link to comment

 

Thanks for the link. I am just too tired now but will try the check disk tool tomorrow. I noticed that my preclear was done but there is something called the post-read still going on since yesterday. It may be because I added the drive and formatted it with the unraid server before this post-read was complete. It seems like it's been going for a very long time, longer than when I first setup the parity and data drive the first time. In any case I figured I would just take the drive out, use windows to delete everything and format it and redo the unraid again if this persists.

 

Hopefully you just gave me a life line and that could make a difference!!!! :)

 

PS By tomorrow this post-read should be done.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...