Jump to content

Transmission 2.33 on unRaid 5.0b13 starting, restarting, installing problems


rutherford

Recommended Posts

I've sort of got this problem fixed. I thought I'd share my solution with the forums.

 

It's crazy to ignore regular bittorrents as sources for media. That being said, I really don't want to leave my main computer running in addition to the unRaid file server - the bittorrents should clearly live on the unRaid server. The support for a bittorrent client on unRaid seems pretty poor, but I've managed to hobble it together from bits and pieces that I've found around the web.

 

Be sure you get unMenu installed. Use the Package Manager to install the necessary files for Transmission to work properly. I wanted my installed to my cache drive, so the installation directory was /mnt/cache/.transmission

 

For one reason or another, the unMenu "User Scripts" section has buttons for starting and stopping Transmission, but neither work. "Start Transmission" says it's already running, and "Stop Transmission" gets confused because Transmission is not running.

 

Anyways, as I had unMenu install Transmission to the /mnt/cache/.transmission directory, here's the command you want to run in your shell to get it running:

 

/usr/bin/transmission-daemon -g /mnt/cache/.transmission/conf

 

the first part is the daemon program for Transmission (daemon means "runs in the background"), -g means use configuration file directory, and the following of that is the location of my configuration directory.

 

This isn't a perfect solution to this problem because I cannot mount and unmount drives automatically. When I run transmission in daemon, it grabs a hold of a drive and will not let it spin down until I kill the process through the shell. My other programs (sickbeard, sabnzbd, couchpotato) all behave nicely, going up and down with the spinup/down commands.

 

Here are my wishes/requests for Transmission. Bittorrent isn't going anywhere, I want it running on my unRaid server.

1. unMenu Packages should install Transmission to a cache drive successfully

2. unMenu Scripts should run/stop Transmission correctly

3. unMenu Packages should have a more recent version of Transmission available. (at the time of this writing they are up to 2.42 on transmissionbt.com. unMenu is at 2.33)

 

I really wish I had more time to dabble with this stuff - figure out what makes unMenu, Slackware, and different configuration files all sing together - but I don't :(

 

One last note, if you haven't tried the Transmission Remote GUI: get on it. It's fantastic. A native Windows front end with more options than the webgui. Really top notch stuff.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...