Jump to content

APC BX1600MI-GR UPS constant "battery disconnected"/"battery reattached"


Recommended Posts

I'm running Unraid 6.12.8 and I've hooked up my APC BX1600MI-GR UPS yesterday but am running into an issue.

 

I noticed this morning that my server had shut down overnight, and is now running a parity check. I found that rather strange as it's never happened before I connected the UPS.

 

Looking at the System log I can see that the battery is constantly showing as disconnected/reattached, even though the info on the UPS settings page looks perfectly fine.

 

Any idea what's going on here? I suspect this has something to do with the server shutting down overnight.

 

Thanks!

log.jpg

info.jpg

Link to comment

The APC BX series is bugged both with APCUPSD ("UPS Settings") and NUT:

Basically low battery states are falsely interpreted, in turn leading to wrongful shutdowns. This is most likely due to unexpected changes in the APC UPS firmware on that series which the respective drivers cannot (yet) handle. For NUT, at least, an investigation into this is underway, so hopefully we'll get this fixed before too long as many people seem to be having these problems. Feel free to comment in the GitHub issue that you're also affected with your specific UPS model so the issue will gain more traction and visibility.

 

Edited by Rysz
Link to comment
22 minutes ago, Rysz said:

The APC BX series is bugged both with APCUPSD ("UPS Settings") and NUT:

Basically low battery states are falsely interpreted, in turn leading to wrongful shutdowns. This is most likely due to unexpected changes in the APC UPS firmware on that series which the respective drivers cannot (yet) handle. For NUT, at least, an investigation into this is underway, so hopefully we'll get this fixed before too long as many people seem to be having these problems. Feel free to comment in the GitHub issue that you're also affected with your specific UPS model so the issue will gain more traction and visibility.

 

That's a bummer, I'll try NUT when I get home. For now I guess I'll just leave the UPS USB-cable unplugged. Thanks anyway! Posted in the github issue too.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...