Jump to content

NUT Plugin not connecting to UPS Phasak 1260VA according to the drivers


Recommended Posts

Hello i am trying to connect my ups a Phasak Sirius 1260VA to the NUT plugin, when try to introduce the correct driver that is in the guide for this vendor, the plugin does not start and i get an error saying that i don't have permissions or other kind of problems associated, could that be because it's not supported at all, or am i doing something wrong in the config. I already switched off the UPS plugin that is in the unraid. I tried all the different combinations of drivers, I tried both plugins for this vendor, nutdrv_qx and blazer ser, all of them with same outcome. Can someone help me with this issue, i'm kind a new in the unraid world, and starting to understand the system.

The error that i get is this one

Apr 12 23:17:33 Excalibur ool www[2658]: /usr/local/emhttp/plugins/nut-dw/scripts/start

Apr 12 23:17:34 Excalibur rc.nut: Writing NUT configuration...

Apr 12 23:17:36 Excalibur rc.nut: Updating permissions for NUT...

Apr 12 23:17:36 Excalibur rc.nut: Checking if the NUT Runtime Statistics Module should be enabled...

Apr 12 23:17:36 Excalibur rc.nut: Disabling the NUT Runtime Statistics Module...

Apr 12 23:17:37 Excalibur rc.nut: Network UPS Tools - Generic Q* USB/Serial driver 0.36 (2.8.2)

Apr 12 23:17:37 Excalibur rc.nut: USB communication driver (libusb 1.0) 0.47

Apr 12 23:17:37 Excalibur rc.nut: libusb1: Could not open any HID devices: insufficient permissions on everything

Apr 12 23:17:37 Excalibur rc.nut: No supported devices found. Please check your device availability with 'lsusb'

Apr 12 23:17:37 Excalibur rc.nut: and make sure you have an up-to-date version of NUT. If this does not help,

Apr 12 23:17:37 Excalibur rc.nut: try running the driver with at least 'subdriver', 'vendorid' and 'productid'

Apr 12 23:17:37 Excalibur rc.nut: options specified. Please refer to the man page for details about these options

Apr 12 23:17:37 Excalibur rc.nut: (man 8 nutdrv_qx). Apr 12 23:17:37 Excalibur rc.nut:

Apr 12 23:17:37 Excalibur rc.nut: Driver failed to start (exit status=1) Apr 12 23:17:37 Excalibur rc.nut: Network UPS Tools - UPS driver controller 2.8.2

 

Link to comment
10 hours ago, lazarojz said:

Hello i am trying to connect my ups a Phasak Sirius 1260VA to the NUT plugin, when try to introduce the correct driver that is in the guide for this vendor, the plugin does not start and i get an error saying that i don't have permissions or other kind of problems associated, could that be because it's not supported at all, or am i doing something wrong in the config. I already switched off the UPS plugin that is in the unraid. I tried all the different combinations of drivers, I tried both plugins for this vendor, nutdrv_qx and blazer ser, all of them with same outcome. Can someone help me with this issue, i'm kind a new in the unraid world, and starting to understand the system.

The error that i get is this one

Apr 12 23:17:33 Excalibur ool www[2658]: /usr/local/emhttp/plugins/nut-dw/scripts/start

Apr 12 23:17:34 Excalibur rc.nut: Writing NUT configuration...

Apr 12 23:17:36 Excalibur rc.nut: Updating permissions for NUT...

Apr 12 23:17:36 Excalibur rc.nut: Checking if the NUT Runtime Statistics Module should be enabled...

Apr 12 23:17:36 Excalibur rc.nut: Disabling the NUT Runtime Statistics Module...

Apr 12 23:17:37 Excalibur rc.nut: Network UPS Tools - Generic Q* USB/Serial driver 0.36 (2.8.2)

Apr 12 23:17:37 Excalibur rc.nut: USB communication driver (libusb 1.0) 0.47

Apr 12 23:17:37 Excalibur rc.nut: libusb1: Could not open any HID devices: insufficient permissions on everything

Apr 12 23:17:37 Excalibur rc.nut: No supported devices found. Please check your device availability with 'lsusb'

Apr 12 23:17:37 Excalibur rc.nut: and make sure you have an up-to-date version of NUT. If this does not help,

Apr 12 23:17:37 Excalibur rc.nut: try running the driver with at least 'subdriver', 'vendorid' and 'productid'

Apr 12 23:17:37 Excalibur rc.nut: options specified. Please refer to the man page for details about these options

Apr 12 23:17:37 Excalibur rc.nut: (man 8 nutdrv_qx). Apr 12 23:17:37 Excalibur rc.nut:

Apr 12 23:17:37 Excalibur rc.nut: Driver failed to start (exit status=1) Apr 12 23:17:37 Excalibur rc.nut: Network UPS Tools - UPS driver controller 2.8.2

 


Please post the NUT Debug Package found in NUT Settings.

Link to comment
2 minutes ago, lazarojz said:

Sorry i should have attached the package in the first message, my mistake.

nut-debug-20240413122931.zip 165.7 kB · 1 download

 

I'm afraid your UPS doesn't seem to be supported at all, it cannot find or communicate with the device. NUT's hardware compatibility list also doesn't list that specific UPS as supported, so unfortunately it seems we're unlucky in this case.  You can try with Unraid's "UPS Settings" (which use a different program: APCUPSD) if maybe the device will be detected there - but I'm not very hopeful. 😞 

 

Link to comment

That was what i expected,  before installing the NUT driver i tried all different combiantions, in the UPS Settings, but i had no luck, NUT settings was my second option, but i was not very hopeful, i will try to send all the data needed to the development team, to see if they have something to solve with that. Without that i just can try to see the stats in the UPS lcd, has a lot of information, but the gold would be manage that with unraid. No problem, i will try to understand another ways. Thanks for the help :) 

 

Link to comment
2 minutes ago, lazarojz said:

That was what i expected,  before installing the NUT driver i tried all different combiantions, in the UPS Settings, but i had no luck, NUT settings was my second option, but i was not very hopeful, i will try to send all the data needed to the development team, to see if they have something to solve with that. Without that i just can try to see the stats in the UPS lcd, has a lot of information, but the gold would be manage that with unraid. No problem, i will try to understand another ways. Thanks for the help :) 

 

 

Actually can you try something else - change NUT Backend to "legacy (2.7.4 stable)" in NUT Settings and reboot the system or reinstall NUT. Then try again with same driver (nutdrv_qx) - sometimes the old backend works better with some UPS.

Link to comment

I reboot the system and changed to legacy, but still no luck with (nutdrv_qx), but i tried with different driver (blaser_ser) and now i have different message.

Apr 13 13:42:41 Excalibur dnsmasq[14145]: compile time options: IPv6 GNU-getopt DBus no-UBus i18n IDN2 DHCP DHCPv6 no-Lua TFTP conntrack ipset no-nftset auth cryptohash DNSSEC loop-detect inotify dumpfile

Apr 13 13:42:41 Excalibur dnsmasq-dhcp[14145]: DHCP, IP range 192.168.122.2 -- 192.168.122.254, lease time 1h

Apr 13 13:42:41 Excalibur dnsmasq-dhcp[14145]: DHCP, sockets bound exclusively to interface virbr0 Apr 13 13:42:41 Excalibur dnsmasq[14145]: reading /etc/resolv.conf

Apr 13 13:42:41 Excalibur dnsmasq[14145]: using nameserver 192.168.1.1#53

Apr 13 13:42:41 Excalibur dnsmasq[14145]: read /etc/hosts - 3 names

Apr 13 13:42:41 Excalibur dnsmasq[14145]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 names

Apr 13 13:42:41 Excalibur dnsmasq-dhcp[14145]: read /var/lib/libvirt/dnsmasq/default.hostsfile

Apr 13 13:43:05 Excalibur ool www[11477]: /usr/local/emhttp/plugins/nut-dw/scripts/start

Apr 13 13:43:06 Excalibur rc.nut: Writing NUT configuration...

Apr 13 13:43:07 Excalibur rc.nut: Updating permissions for NUT...

Apr 13 13:43:07 Excalibur rc.nut: Checking if the NUT Runtime Statistics Module should be enabled...

Apr 13 13:43:07 Excalibur rc.nut: Disabling the NUT Runtime Statistics Module...

Apr 13 13:43:08 Excalibur rc.nut: Fatal error: unusable configuration

Apr 13 13:43:08 Excalibur rc.nut: Network UPS Tools - Megatec/Q1 protocol serial driver 1.58 (2.7.4.1)

Apr 13 13:43:08 Excalibur rc.nut:

Apr 13 13:43:08 Excalibur rc.nut: Unable to open auto: No such file or directory

Apr 13 13:43:08 Excalibur rc.nut:

Apr 13 13:43:08 Excalibur rc.nut: Things to try:

Apr 13 13:43:08 Excalibur rc.nut:

Apr 13 13:43:08 Excalibur rc.nut: - Check 'port=' in ups.conf

Apr 13 13:43:08 Excalibur rc.nut:

Apr 13 13:43:08 Excalibur rc.nut: - Check owner/permissions of all parts of path

Apr 13 13:43:08 Excalibur rc.nut:

Apr 13 13:43:08 Excalibur rc.nut: Driver failed to start (exit status=1)

Apr 13 13:43:08 Excalibur rc.nut: Network UPS Tools - UPS driver controller 2.7.4.1

Link to comment
Just now, lazarojz said:

I reboot the system and changed to legacy, but still no luck with (nutdrv_qx), but i tried with different driver (blaser_ser) and now i have different message.

Apr 13 13:42:41 Excalibur dnsmasq[14145]: compile time options: IPv6 GNU-getopt DBus no-UBus i18n IDN2 DHCP DHCPv6 no-Lua TFTP conntrack ipset no-nftset auth cryptohash DNSSEC loop-detect inotify dumpfile

Apr 13 13:42:41 Excalibur dnsmasq-dhcp[14145]: DHCP, IP range 192.168.122.2 -- 192.168.122.254, lease time 1h

Apr 13 13:42:41 Excalibur dnsmasq-dhcp[14145]: DHCP, sockets bound exclusively to interface virbr0 Apr 13 13:42:41 Excalibur dnsmasq[14145]: reading /etc/resolv.conf

Apr 13 13:42:41 Excalibur dnsmasq[14145]: using nameserver 192.168.1.1#53

Apr 13 13:42:41 Excalibur dnsmasq[14145]: read /etc/hosts - 3 names

Apr 13 13:42:41 Excalibur dnsmasq[14145]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 names

Apr 13 13:42:41 Excalibur dnsmasq-dhcp[14145]: read /var/lib/libvirt/dnsmasq/default.hostsfile

Apr 13 13:43:05 Excalibur ool www[11477]: /usr/local/emhttp/plugins/nut-dw/scripts/start

Apr 13 13:43:06 Excalibur rc.nut: Writing NUT configuration...

Apr 13 13:43:07 Excalibur rc.nut: Updating permissions for NUT...

Apr 13 13:43:07 Excalibur rc.nut: Checking if the NUT Runtime Statistics Module should be enabled...

Apr 13 13:43:07 Excalibur rc.nut: Disabling the NUT Runtime Statistics Module...

Apr 13 13:43:08 Excalibur rc.nut: Fatal error: unusable configuration

Apr 13 13:43:08 Excalibur rc.nut: Network UPS Tools - Megatec/Q1 protocol serial driver 1.58 (2.7.4.1)

Apr 13 13:43:08 Excalibur rc.nut:

Apr 13 13:43:08 Excalibur rc.nut: Unable to open auto: No such file or directory

Apr 13 13:43:08 Excalibur rc.nut:

Apr 13 13:43:08 Excalibur rc.nut: Things to try:

Apr 13 13:43:08 Excalibur rc.nut:

Apr 13 13:43:08 Excalibur rc.nut: - Check 'port=' in ups.conf

Apr 13 13:43:08 Excalibur rc.nut:

Apr 13 13:43:08 Excalibur rc.nut: - Check owner/permissions of all parts of path

Apr 13 13:43:08 Excalibur rc.nut:

Apr 13 13:43:08 Excalibur rc.nut: Driver failed to start (exit status=1)

Apr 13 13:43:08 Excalibur rc.nut: Network UPS Tools - UPS driver controller 2.7.4.1

 

blazer_ser only works with UPS connected via serial cable (that's why it wants a port = physical location of the device).

Sorry then we're really out of luck, 2.7.4. was my last idea for this UPS basically 😕 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...