Jump to content
TheStapler

5.0 beta 12a unknown error... :(

9 posts in this topic Last Reply

Recommended Posts

Not sure what this means... but I got this today...

 

New motherboard/CPU, running Unraid 5.0 beta 12a

MOBO: ASRock H61M/U3S3

CPU: Celeron Dual Core 2.5

 

the onboard ETH isn't working, I am using a DLINK gig-e card

 

Dec  4 23:29:44 Tower kernel: irq 17: nobody cared (try booting with the "irqpoll" option)
Dec  4 23:29:44 Tower kernel: Pid: 0, comm: swapper Not tainted 3.0.3-unRAID #7
Dec  4 23:29:44 Tower kernel: Call Trace:
Dec  4 23:29:44 Tower kernel:  [<c104f684>] __report_bad_irq+0x1f/0x95
Dec  4 23:29:44 Tower kernel:  [<c104f831>] note_interrupt+0x137/0x1a8
Dec  4 23:29:44 Tower kernel:  [<c104e3a6>] handle_irq_event_percpu+0xef/0x100
Dec  4 23:29:44 Tower kernel:  [<c104fd53>] ? handle_edge_irq+0xcb/0xcb

Share this post


Link to post

apparently, this also locked up the server...  web gui is not respodning, but the terminal is there...

 

SMB is down, not really quite sure what to do here?  I read the other post about this, and i have already disabled the COM and the LPT, sound and onboard eth (since there wasn't a driver that worked for it yet)

 

 

Share this post


Link to post

So, after reboot, i enabled the onboard ETH just for testing, (in my other post)...  anyways, it appears unless something else caused it to move, that my DLINK is on IRQ18...

 

Now, before I upgraded, I never had any issues.  it was running in an old celeron 2.8, with 512mb ram... and never complained (except for sickbeard, as it is a HOG in resources).

 

Would you think that the mother board is bad?  or maybe my card?   

Share this post


Link to post

Run memtest for 8 hours to see if it finds anything.

 

if that does not work then try adding the irqpoll option to the syslinux.cfg file on the flash drive.  Look for some other posts of mine to see where it should go.

Share this post


Link to post

I just got this.... but i yanked the PS/2 Keyboard/mouse out of the computer... so that may have caused this issue...

 

Dec  5 21:59:56 Tower kernel: irq 16: nobody cared (try booting with the "irqpoll" option)
Dec  5 21:59:56 Tower kernel: Pid: 0, comm: swapper Not tainted 3.0.3-unRAID #7
Dec  5 21:59:56 Tower kernel: Call Trace:
Dec  5 21:59:56 Tower kernel:  [<c104f684>] __report_bad_irq+0x1f/0x95
Dec  5 21:59:56 Tower kernel:  [<c104f831>] note_interrupt+0x137/0x1a8
Dec  5 21:59:56 Tower kernel:  [<c104e3a6>] handle_irq_event_percpu+0xef/0x100
Dec  5 21:59:56 Tower kernel:  [<c104fd53>] ? handle_edge_irq+0xcb/0xcb
Dec  5 21:59:56 Tower kernel:  [<c104e3db>] handle_irq_event+0x24/0x3b
Dec  5 21:59:56 Tower kernel:  [<c104fd53>] ? handle_edge_irq+0xcb/0xcb
Dec  5 21:59:56 Tower kernel:  [<c104fdbc>] handle_fasteoi_irq+0x69/0x82
Dec  5 21:59:56 Tower kernel:  <IRQ>  [<c10035c6>] ? do_IRQ+0x37/0x90
Dec  5 21:59:56 Tower kernel:  [<c130b8a9>] ? common_interrupt+0x29/0x30
Dec  5 21:59:56 Tower kernel:  [<c11dd945>] ? acpi_idle_enter_bm+0x22a/0x25e
Dec  5 21:59:56 Tower kernel:  [<c127387e>] ? cpuidle_idle_call+0x6b/0xa1
Dec  5 21:59:56 Tower kernel:  [<c1001a60>] ? cpu_idle+0x3a/0x52
Dec  5 21:59:56 Tower kernel:  [<c12fb388>] ? rest_init+0x58/0x5a
Dec  5 21:59:56 Tower kernel:  [<c1448717>] ? start_kernel+0x28c/0x291
Dec  5 21:59:56 Tower kernel:  [<c14480b0>] ? i386_start_kernel+0xb0/0xb7
Dec  5 21:59:56 Tower kernel: handlers:
Dec  5 21:59:56 Tower kernel: [<c1244012>] usb_hcd_irq
Dec  5 21:59:56 Tower kernel: Disabling IRQ #16

 

here is what is IRQ16

00:1a.0 USB Controller: Intel Corporation Unknown device 1c2d (rev 05) (prog-if 20 [EHCI])
Subsystem: ASRock Incorporation Unknown device 1c2d
Flags: bus master, medium devsel, latency 0, IRQ 16
Memory at fe703000 (32-bit, non-prefetchable) [size=1K]
Capabilities: [50] Power Management version 2
Capabilities: [58] Debug port: BAR=1 offset=00a0
Capabilities: [98] PCIe advanced features 
Kernel driver in use: ehci_hcd

Share this post


Link to post

So, last night, after it had been up for 1 1/2 days without issue, I rebooted it, disabled the OB NIC (i enabled it for testing things out last time, and hadn't rebooted to turn it off).

 

everythign came up fine, SAB/SB started up without issue.... all was good... then about 1 hour later, it crashed...

 

Dec  6 22:53:43 Tower kernel: irq 16: nobody cared (try booting with the "irqpoll" option)
Dec  6 22:53:43 Tower kernel: Pid: 1130, comm: mdrecoveryd Not tainted 3.0.3-unRAID #7
Dec  6 22:53:43 Tower kernel: Call Trace:
Dec  6 22:53:43 Tower kernel:  [<c104f684>] __report_bad_irq+0x1f/0x95
Dec  6 22:53:43 Tower kernel:  [<c104f831>] note_interrupt+0x137/0x1a8
Dec  6 22:53:43 Tower kernel:  [<c104e3a6>] handle_irq_event_percpu+0xef/0x100
Dec  6 22:53:43 Tower kernel:  [<c104fd53>] ? handle_edge_irq+0xcb/0xcb
Dec  6 22:53:43 Tower kernel:  [<c104e3db>] handle_irq_event+0x24/0x3b
Dec  6 22:53:43 Tower kernel:  [<c104fd53>] ? handle_edge_irq+0xcb/0xcb
Dec  6 22:53:43 Tower kernel:  [<c104fdbc>] handle_fasteoi_irq+0x69/0x82
Dec  6 22:53:43 Tower kernel:  <IRQ>  [<c10035c6>] ? do_IRQ+0x37/0x90
Dec  6 22:53:43 Tower kernel:  [<c130b8a9>] ? common_interrupt+0x29/0x30
Dec  6 22:53:43 Tower kernel:  [<c118b593>] ? drive_stat_acct+0x5e/0x110
Dec  6 22:53:43 Tower kernel:  [<c118c25a>] ? bio_attempt_back_merge+0x64/0x77
Dec  6 22:53:43 Tower kernel:  [<c118cd41>] ? __make_request+0x78/0x200
Dec  6 22:53:43 Tower kernel:  [<c118ba04>] ? generic_make_request+0x24c/0x2a9
Dec  6 22:53:43 Tower kernel:  [<f858066c>] ? handle_stripe+0xc54/0xcd7 [md_mod]
Dec  6 22:53:43 Tower kernel:  [<c130b8a9>] ? common_interrupt+0x29/0x30
Dec  6 22:53:43 Tower kernel:  [<f8580be6>] ? unraid_sync+0x32/0x42 [md_mod]
Dec  6 22:53:43 Tower kernel:  [<f857cb07>] ? md_do_sync+0x154/0x3ba [md_mod]
Dec  6 22:53:43 Tower kernel:  [<c1093abd>] ? mntput+0x19/0x1b
Dec  6 22:53:43 Tower kernel:  [<c103be2d>] ? wake_up_bit+0x5b/0x5b
Dec  6 22:53:43 Tower kernel:  [<f857d274>] ? md_do_recovery+0x115/0x197 [md_mod]
Dec  6 22:53:43 Tower kernel:  [<f857d274>] ? md_do_recovery+0x115/0x197 [md_mod]
Dec  6 22:53:43 Tower kernel:  [<f857d91c>] ? md_thread+0xcc/0xe3 [md_mod]
Dec  6 22:53:43 Tower kernel:  [<c103be2d>] ? wake_up_bit+0x5b/0x5b
Dec  6 22:53:43 Tower kernel:  [<f857d850>] ? import_device+0x142/0x142 [md_mod]
Dec  6 22:53:43 Tower kernel:  [<c103bb3d>] ? kthread+0x62/0x67
Dec  6 22:53:43 Tower kernel:  [<c103badb>] ? kthread_worker_fn+0x10a/0x10a
Dec  6 22:53:43 Tower kernel:  [<c130b8b6>] ? kernel_thread_helper+0x6/0xd
Dec  6 22:53:43 Tower kernel: handlers:
Dec  6 22:53:43 Tower kernel: [<c1244012>] usb_hcd_irq
Dec  6 22:53:43 Tower kernel: Disabling IRQ #16
Dec  6 22:53:51 Tower kernel: usb 2-1.5: USB disconnect, device number 4

 

then, abotu an hour after that:

Dec  6 23:42:03 Tower kernel: irq 17: nobody cared (try booting with the "irqpoll" option)
Dec  6 23:42:03 Tower kernel: Pid: 0, comm: swapper Not tainted 3.0.3-unRAID #7
Dec  6 23:42:03 Tower kernel: Call Trace:
Dec  6 23:42:03 Tower kernel:  [<c104f684>] __report_bad_irq+0x1f/0x95
Dec  6 23:42:03 Tower kernel:  [<c104f831>] note_interrupt+0x137/0x1a8
Dec  6 23:42:03 Tower kernel:  [<c104e3a6>] handle_irq_event_percpu+0xef/0x100
Dec  6 23:42:03 Tower kernel:  [<c104fd53>] ? handle_edge_irq+0xcb/0xcb
Dec  6 23:42:03 Tower kernel:  [<c104e3db>] handle_irq_event+0x24/0x3b
Dec  6 23:42:03 Tower kernel:  [<c104fd53>] ? handle_edge_irq+0xcb/0xcb
Dec  6 23:42:03 Tower kernel:  [<c104fdbc>] handle_fasteoi_irq+0x69/0x82
Dec  6 23:42:03 Tower kernel:  <IRQ>  [<c10035c6>] ? do_IRQ+0x37/0x90
Dec  6 23:42:03 Tower kernel:  [<c130b8a9>] ? common_interrupt+0x29/0x30
Dec  6 23:42:03 Tower kernel:  [<c11dd945>] ? acpi_idle_enter_bm+0x22a/0x25e
Dec  6 23:42:03 Tower kernel:  [<c127387e>] ? cpuidle_idle_call+0x6b/0xa1
Dec  6 23:42:03 Tower kernel:  [<c1001a60>] ? cpu_idle+0x3a/0x52
Dec  6 23:42:03 Tower kernel:  [<c12fb388>] ? rest_init+0x58/0x5a
Dec  6 23:42:03 Tower kernel:  [<c1448717>] ? start_kernel+0x28c/0x291
Dec  6 23:42:03 Tower kernel:  [<c14480b0>] ? i386_start_kernel+0xb0/0xb7
Dec  6 23:42:03 Tower kernel: handlers:
Dec  6 23:42:03 Tower kernel: [<f8469fba>] skge_intr
Dec  6 23:42:03 Tower kernel: Disabling IRQ #17

 

I had gone to bed, but the only thing that was different, was I enabled SAB/SB, so i had a few more packages running, and it was downloading stuff... prior to that, I copied over about 1TB of stuff during that 1 1/2 days it was up before, and never had any issues...

 

I have since rebooted, re-enabled the OB NIC, but still using the NIC CARD (since the OB NIC isn't supported), and SAB is downloading again... so we'll see...

 

but IRQ17 is my DLINK NIC, IRQ16 is my USB (but that still works, when IRQ17 goes, the server is not network reachable)

 

Any ideas??

Share this post


Link to post

this is still an ongoing issue... and nothing seems to resolve it.

 

I am not sure what more I can do...    is it possible that I just have to run the full version of the OS, and install the unraid as an application?

 

I have spent numerous hours on this issue, and I am going insane... it sometimes works fine for days, and then sometimes, it wont stay up for an hour...

 

please help!

Share this post


Link to post

this is still an ongoing issue... and nothing seems to resolve it.

 

I am not sure what more I can do...    is it possible that I just have to run the full version of the OS, and install the unraid as an application?

 

I have spent numerous hours on this issue, and I am going insane... it sometimes works fine for days, and then sometimes, it wont stay up for an hour...

 

please help!

 

I mentioned a few things in my prior post, did you run/do either of those things?  What was the outcome?

Share this post


Link to post

i haven't done the irqpoll, but i did run memtest, and nothing came up

 

also ran ubuntu-live, and there wasn't any issues at all while it was running.

 

i will try the irqpoll though

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.