Jump to content
aaronwt

Asmedia contoller card

31 posts in this topic Last Reply

Recommended Posts

Will any of the Asmedia controllers work with any version of unRAID? I have a couple with the ASM1061 chip lying around and am going to setup a second unRAID build. So if unRAID works with it I won't need to purchase any other port multiplier capable controllers.

Share this post


Link to post

I don't know, as Asmedia controllers aren't commonly used.  If you have them already, why not just try them out and see what happens?

Share this post


Link to post

I plan to give it a try, but I went ahead and ordered a couple of the Sil3132 cards. So I'll be covered one way or another with my 4 bay external enclosures on my new unRAID build. But first I'll need to transfer some content from my WHS to drives connected to the unRAID MB SATA ports. Then, after I free up some enclosures I can move them over to my new unRAID build.

Share this post


Link to post

I don't know, as Asmedia controllers aren't commonly used.  If you have them already, why not just try them out and see what happens?

 

Well....  I just did :(

 

No dice.  Pooh.    Unraid 5-beta14

 

SATA Chipset:  Asmedia ASM1061 -- firmware 0.89  -- {Came with that onboard, and appears to be the latest available}

 

Wish they did work.  It was nice as an 'experiment' (translated, cheap) -- but I guess I've got to go back to my MoBo Sata II headers for now.  These were 2x Sata III (on a PCI x1 - yea, I know it doesn't have the bandwidth for full Sata III)

 

If anybody else got them to work -- let me know, please :)

 

This is what I tried:  http://www.amazon.com/dp/B005B0A6ZS/ref=pe_175190_21431760_cs_sce_dp_1

 

Syba 2 Port SATA III PCI-Express x1 Card (SY-PEX40039)

 

 

Also, I don't know what this means, but the chipset literature says it "Support Port Multiplier" http://www.asmedia.com.tw/eng/e_show_products.php?cate_index=117&item=118

 

But while I was researching why this wasn't working (originally with an external external port-multiplying array) I did run across this on another forum

I’m not familiar with the linked Astrotek AT-CPES6AE, which has the relatively new ASMedia ASM1061 chipset. It’s listed as supporting “Port Multiplier Command Based Switching”, which is not the right type for your Hotway HF2-SU3S2. I’d recommend you choose one of the other cards mentioned in the previous threads for the reasons stated there.

 

But even when I took it out of "external port multiply" duty and just hooked up a single drive to it, the drive also didn't show up in Unraid.

Share this post


Link to post

Not sure where/if there is a "feature" (or driver) request thread/place...

 

But I'd toss in that I'd like to see the ASMedia ASM1042 chipset be supported in a future Unraid version.

 

It's well beyond my skill set to figure out how to create a custom kernel for it.

 

Inexpensive cards are coming out with that chipset,  and new motherboards as well.

 

Example Motherboard:  ASRock X79 Extreme4-M

http://www.asrock.com/mb/overview.us.asp?Model=X79%20Extreme4-M&cat=Specifications

 

Example Card: Syba 2 Port SATA III PCI-Express x1 Card (SY-PEX40039)

http://www.amazon.com/dp/B005B0A6ZS/ref=pe_175190_21431760_cs_sce_dp_1

 

...Chuck

 

Share this post


Link to post

As far as i have found info's on this Chipset support should be added to the 3.2 Series of the Linux Kernel.

unRaid 5.0beta14 works with Kernel 3.1.1 so there is no native support for the Asmedia Chipset in the Kernel used.

 

If you are willing to experiment you could try the package which peter_sm provides here http://lime-technology.com/forum/index.php?topic=16840.msg173385#msg173385

This features the 3.3.1 Linux Kernel but i cannot tell you if there is also support for the Asmedia chipset in there.

 

Nevertheless be careful when experimenting with it, you can never know what happens.

Share this post


Link to post

I have a 4.7 version to try (amd optimized only at this point, it will work fine on intel hardware):

 

bzimage + bzroot

 

I can have a 5.0beta version as soon as someone wants to test on a particular version.

Share this post


Link to post

An Update:

 

As of 5.0-rc3 my Asmedia 1061's now work fine, without any modification to the unraid or adding scripts.

 

YMMV.

 

Elkay14 had developed a script that would enable them -- I had returned my cards by the time the script came out -- decided to re-order them again, and volia in the mean time I had already upgraded to 5.0-rc3 and didn't need to do anything.

 

But that script, for those interested, is here:

 

http://lime-technology.com/forum/index.php?topic=19882.0

Share this post


Link to post

 

SATA Chipset:  Asmedia ASM1061 -- firmware 0.89  -- {Came with that onboard, and appears to be the latest available}

 

 

Two questions for the community:

 

 

1) Is 0.89 the latest firmware avaialble for the ASMedia AS1061 based cards?  If not, what is and where?

 

2) Anybody have the ASMedia cards working with an external Multi-Port bay.  (aka, like a Sans Media, etc) -- according to the literature, it's supposed to support "multi-port" --but my cards only recognize one drive in the external cage, not up to 4.  Or is this an Unraid issue?

 

http://www.asmedia.com.tw/eng/e_show_products.php?item=118&cate_index=117

 

"Serial ATA Features

- 2 ports Serial ATA PHY for 1.5, 3.0 and 6.0GHz signaling

- Support Native Command Queue

- Support Gen 1m and 2m SATA PHY

- Support Port Multiplier"

Share this post


Link to post

An Update:

 

As of 5.0-rc3 my Asmedia 1061's now work fine, without any modification to the unraid or adding scripts.

 

YMMV.

 

Elkay14 had developed a script that would enable them -- I had returned my cards by the time the script came out -- decided to re-order them again, and volia in the mean time I had already upgraded to 5.0-rc3 and didn't need to do anything.

 

But that script, for those interested, is here:

 

http://lime-technology.com/forum/index.php?topic=19882.0

 

 

Yep, the kernel used by rc3 has native support.

Share this post


Link to post

An Update:

 

As of 5.0-rc3 my Asmedia 1061's now work fine, without any modification to the unraid or adding scripts.

 

YMMV.

 

Elkay14 had developed a script that would enable them -- I had returned my cards by the time the script came out -- decided to re-order them again, and volia in the mean time I had already upgraded to 5.0-rc3 and didn't need to do anything.

 

But that script, for those interested, is here:

 

http://lime-technology.com/forum/index.php?topic=19882.0

 

 

Yep, the kernel used by rc3 has native support.

 

And BTW -- just simple empirical evidence -- I like the cards.  A very nice, and very cheap replacement for my old SATA I - SIL based cards from Monoprice {that have a SERIOUS problem accessing both channels at the same time with silent data corruption)

 

I haven't gotten the port-multiplier claims (chipset references) to work though...

 

2) Anybody have the ASMedia cards working with an external Multi-Port bay.  (aka, like a Sans Media, etc) -- according to the literature, it's supposed to support "multi-port" --but my cards only recognize one drive in the external cage, not up to 4.  Or is this an Unraid issue?

 

There is a firmware on station-drivers for the 106x -- I'm at .89 -- it's .95 -- http://station-drivers.com/page/asmedia.htm

 

I'll see about trying it and the port-multiplier again.

Share this post


Link to post

I've got 3x SATA cards with chipset ASM1061. However they aren't working out-of-the-box with unraid. If they were working in RC4, surely they should still work in RC11?

 

Will try the script

 

Script doesn't work with card in PCI-16x slot (my other does), but does in PCI-1x slot. However quite a few errors  :(

Share this post


Link to post

hi!

 

just trying to double confirm here. the- IO Crest 2 Port SATA III PCI-Express x1 Card (SY-PEX40039) -will work with unraid5-rc11?

the card is dirt cheap with $15, i have pcix1 ports unused (2 of them). so if it is confirmed that the card works, it would take some load of my stretched budget at this point. i rather spend $30 right now, filling the otherwise useless pciex1 ports and be able to add hdd's to get much needed space instead of waiting til i have cash left over for a fully blown pciex4 card supporting 4,6 or 8 drives. just don't need that right now and cant really afford it.

Share this post


Link to post

just trying to double confirm here. the- IO Crest 2 Port SATA III PCI-Express x1 Card (SY-PEX40039) -will work with unraid5-rc11?

Sure does!

Share this post


Link to post

just trying to double confirm here. the- IO Crest 2 Port SATA III PCI-Express x1 Card (SY-PEX40039) -will work with unraid5-rc11?

Sure does!

 

ok, thx m8!!! guess i go ahead and order 2 of this babies  :)

as mentioned before, at the moment money is tight. i have a huge assortment of hdd's sitting around at this point, even more with ext. usb drives (i had 12 at the time i switched to unraid) just need to take them apart at one point. for now i would be fine with another 4 hdd's hooked up to 2 of this cards. $15 is a steal i think, i can't see any other use for the pcie x1 ports - so, perfect use i guess. gives me for now 2x3tb, 1x1tb for data drives and a port for a 250gb cache drive. leaving still one pcie slot for another low cost syba card + 2 more drives before we get into bigger cards on the pcie x4 and x16 ports. by that time i guess i look into another psu and case as well LOL.

 

actually, that was another think i wanted to ask! any experience with multiple of the syba cards? any probs there to your knowledge?

 

as always, thx in advance for your time and knowledge....

L

Share this post


Link to post

I've only tried one card (see my link above) in a x1 and x16 port.  I'm thinking of getting a second one or looking for an 4 or 8-port card.

 

Let us know how it goes with two cards but I doubt you'll have any trouble.

Share this post


Link to post

I've only tried one card (see my link above) in a x1 and x16 port.  I'm thinking of getting a second one or looking for an 4 or 8-port card.

 

Let us know how it goes with two cards but I doubt you'll have any trouble.

yep well...  ::)....

anyway, just ordered 2 of them, cheapskate that i am...

will once again take about 2 days to get to miami and another week to get to me here in jamaica. once they are here i will take the 2 step process (get one in and working first and see what happen with two as second step). generally i do not really see probs... who knows. so far this whole build goes way to smooth in my opinion. that might be the superior unraid software solution  ;) or just pure luck so far.

run actually in minor probs. nothing to do with the server. the majority of the network here was still running on 100base-t. so i was initially really p*ssed when i got trans rates of about 9mb LOL. than starting to do the math, that's actually not so bad on 100mbit  ;D. so i ordered a 1gbit switch (should get here by next week) and 1gbit cards for the pc's still running on 100. should solve that prob.

 

anyway, back to the multiple syba controllers - i don't see any prob really sofar putting them in. i was more wondering about potential speed issues. at least on my mb all 3 pcie x1 slots are on the same pcie-bus (northbridge amd 970). i should have made that clear. i am more concerned about probs/ speed issues due to having 2 of this cards hooked up to the same bus, especially if the are used at the same time (read or write). so any ideas along this line would be welcome!

as said before, it's the cheap way out at the moment + it gives otherwise "useless" ports a meaning for really little money (the cards get actually good reviews for what they are). and i sure wanna keep the x4 and x16 slots open for better/ more port controllers at a later time.

so far (pretty firm) i look at 2 'old' seagate 750/7200 (data), a seagate 250/7200 (cache - yep big enough, read it all... no question there) and a wd-green 3tb to hook up to this cards. anything to keep in mind, as far as you guys can think about it!?

 

once again, thx for any help in advance...

L

 

Share this post


Link to post

Just thought I would share that I built a new 5.0rc11 system with an ASRock Extreme 4 Z77 MB which has an on-board ASMedia ASM1061 controller and it's working great in unRAID so far.  Have not tried to use the port multiplier.

Share this post


Link to post

Very interesting read on port multiplier and the ASMedia ASM1061:

http://forums.gentoo.org/viewtopic-t-948964.html

yep it is. thx jimmyjoe! since the cards are ordered now and coming anyway i guess it will become an experiment in low cost building and the potential downfalls  ;D, hope martinq was rite and it worx in unraid (at least one of them  ::) )

anyway, once they get here and i try it myself i shall keep you guys updated on the results.

Share this post


Link to post

anyway, once they get here and i try it myself i shall keep you guys updated on the results.

Awesome!  Looking forward to it.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.