Jump to content
speeding_ant

"SimpleFeatures" - WebServer Plugin [SUPPORT]

308 posts in this topic Last Reply

Recommended Posts

I'm trying to install the web server on UnRaid 5.0. I downloaded and unzipped the package, moved the file simpleFeatures.web.server-1.0.11-noarch-1.plg to /boot/config/plugins, and ran installplg /boot/config/plugins/simpleFeatures.web.server-1.0.11-noarch-1.plg.

 

It looks like it upgraded openssl and some other packages, then failed because wget could not be run due to a missing shared library.

 

I was able to recover wget by running this: upgradepkg --install-new /boot/packages/openssl-solibs-0.9.8i-i486-1.tgz

 

I then reran installplg, and this time is looks like /usr/bin/php won't run due to missing shared libraries. My web UI is also busted.

 

Help! I'm going to move the plugin file out of the plugins dir and reboot to try to recover.

Share this post


Link to post

From what I gather, SimpleFeatures is not compatible with the final versions of unRAID 5.0. Your best bet is to look elsewhere for what you're trying to do.

Share this post


Link to post

From what I gather, SimpleFeatures is not compatible with the final versions of unRAID 5.0. Your best bet is to look elsewhere for what you're trying to do.

Check out DYNAMIX in the forums...it seems to be the successor to SF and has a web server plugin.

Share this post


Link to post

I'm trying to install the web server on UnRaid 5.0. I downloaded and unzipped the package, moved the file simpleFeatures.web.server-1.0.11-noarch-1.plg to /boot/config/plugins, and ran installplg /boot/config/plugins/simpleFeatures.web.server-1.0.11-noarch-1.plg.

 

It looks like it upgraded openssl and some other packages, then failed because wget could not be run due to a missing shared library.

 

I was able to recover wget by running this: upgradepkg --install-new /boot/packages/openssl-solibs-0.9.8i-i486-1.tgz

 

I then reran installplg, and this time is looks like /usr/bin/php won't run due to missing shared libraries. My web UI is also busted.

 

Help! I'm going to move the plugin file out of the plugins dir and reboot to try to recover.

 

Your observation is the biggest challenge in plugin development. Different plugins install different versions of slackware packages and end up interfering with each other.

 

The openSSL package is used by PHP and that in turn is used by the webGui to build the pages, a failing PHP results in an empty webGui.

 

Some people edit their PLG files manually to make sure the same packages are installed by the different plugins they are using, it is a workaround and far from ideal, but at the moment no good system exists to cope with package installation.

 

Share this post


Link to post

I just installed the package simpleFeatures.web.server-1.0.11-i486-1.txz and now I cannot access my server GUI or files any more.

 

How do I undo this?

 

**EDIT** I was able to access my server again after hard reboot.  I now installed simpleFeatures 11 via plg file, but I get the following warning through the web server GUI, and the status is stopped:

 

Warning: parse_ini_file(/var/local/emhttp/simpleFeatures.web.server.ini): failed to open stream: No such file or directory in /usr/local/emhttp/plugins/simpleFeatures.webServer/WEBsettings.php on line 11

Share this post


Link to post

Forget about SimpleFeatures. It is dead. Remove everything related to it from your system.

 

Use Dynamix instead. If you are on v6 it is already integrated! For installing a webserver you need this apache plugin.

 

If you are on v5 install Dynamix like you did with SimpleFeatures and use the dynamix web server plugin.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.