Jump to content
speeding_ant

"SimpleFeatures" - WebServer Plugin [SUPPORT]

308 posts in this topic Last Reply

Recommended Posts

also scrolling by during bootup on the console screen

 

libcurl.so.4 is looking for libidn.so.11 and trys several times to find it from www.perl.org

Share this post


Link to post

after commenting out the sqlite modules its now holloring about a modules called enchant?  never heard of that

 

commenting it out and rebooting again

Share this post


Link to post

ok, after commenting out the 3rd library - it is no longer complaining on the console about unable to load those

 

the other module that it is looking for from www.perl.org looks like when CPAN was running......, so a added library is looking for something else...

 

Myk

 

Share this post


Link to post

ok, will see if this persist thru a reboot.... but i did a CPAN update via

>cpan

install CPAN

quit

 

and ran it a 2nd time, and it didnt hollar about that module it could not find.  Doing another reboot to see if the update is persistant thru a reboot

 

Myk

 

Share this post


Link to post

ok, your php must be clobbering subsonics version, as now it will not start after commenting out those 3 libraries.  I can put up with the scrolling on tty1, just use 2 thru 6 :)

 

putting modules back in...

 

Myk

 

Share this post


Link to post

ya, subsonic is working now so we will need to figure something out

 

too bad there is not a standard location for php that everyone can share ....

 

going to bed for the night - see ya tomorrow

 

Myk

 

Share this post


Link to post

Could you do me a favour..  Remove the webserver plugin and make sure Subsonic is installed and running. Then get the output of php -i , php -v & php --ini ?

 

Cheers  :)

Share this post


Link to post

Just wanted to chime in, if anyone is using VirtualBox on Unraid, this new webserver is fully compatible with the phpvirtualbox web app front end.

 

Running latest version of Virtualbox built with my headers etc, works like a champ.

 

Nice work bud.

 

 

Share this post


Link to post

Could you do me a favour..  Remove the webserver plugin and make sure Subsonic is installed and running. Then get the output of php -i , php -v & php --ini ?

 

Cheers  :)

 

php -i

attached, too big for message

 

php -v

PHP 5.2.8 (cli) (built: Dec  8 2008 04:38:12) 
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies

 

php --ini

Configuration File (php.ini) Path: /etc/httpd
Loaded Configuration File:         /etc/httpd/php.ini
Scan for additional .ini files in: /etc/php
Additional .ini files parsed:      (none)

php_-i.txt

Share this post


Link to post

just noticed, unmenu's php package is install and set to reinstall

 

I dont remember if I did that or not, I can try removing it if you like.

 

Let me know

 

Myk

 

Share this post


Link to post

ok, but i cant do it until i get home from work in about 6 hrs, I can remove/reboot remote - but cant see console screen :)

 

will post then

 

Myk

 

Share this post


Link to post

This is kinda awesome. Does the webserver shut down properly if there is a need to disable the array and shutdown the system?

Share this post


Link to post

This is kinda awesome. Does the webserver shut down properly if there is a need to disable the array and shutdown the system?

 

Yes, once the disks are told to unmount then the webserver will shut down!

Share this post


Link to post

Should now be pretty stable. Works great on a stock setup, please take note of the instructions on install page. Make sure no other PHP/Web package is installed via unMenu or otherwise before using this package.

 

Download the new simplefeatures_webserver.plg file here: http://unraid-simplefeatures.googlecode.com/files/simplefeatures_webserver.plg

 

Change Log:

0.3 - Fixed port disappearing act on startup. Auto create data folder, with welcome screen. Fixed logging issue.

Share this post


Link to post

Wow!  This looks great! i need to install it!  Hey could you Please add WebDav to it as well?  Please!

 

Thanks again for your hard work!

Share this post


Link to post

WebDav is quite a bit of work, with no easy way of configuring authentication, etc.

 

Best way to get WebDav is to install something like: AjaxPlorer or Mollify.

Share this post


Link to post

First off...  +1  on the "Very Nice" comments!  Excellent work, SimpleFeatures improves with each new release.

 

Just noticed... The web server plugin seems to break the unRAID stats graphs, Processor, Network, Memory  all just "loading...".  Doesn't seem to care whether the web-server is actually running, only installed.  I do not have any other PHP installation, only this one. Removing the webserver plugin brings the graphs back.

 

A phpinfo and a static test page both serve up fine.

 

Reproducible on 5.0-beta12a  using both 0.2 and 0.3  (didn't test on 0.1).

 

 

Share this post


Link to post

First off...  +1  on the "Very Nice" comments!  Excellent work, SimpleFeatures improves with each new release.

 

Just noticed... The web server plugin seems to break the unRAID stats graphs, Processor, Network, Memory  all just "loading...".  Doesn't seem to care whether the web-server is actually running, only installed.  I do not have any other PHP installation, only this one. Removing the webserver plugin brings the graphs back.

 

A phpinfo and a static test page both serve up fine.

 

Reproducible on 5.0-beta12a  using both 0.2 and 0.3  (didn't test on 0.1).

 

Cheers! Compliments and feedback are appreciated!

 

I've been looking into that issues since a month or so back. Finally could reproduce, funnily enough, with my own package! I've fixed the problem in the soon to be released SimpleFeatures package updates. It was down to the timezone compensation code to make sure times/dates stay in sync from archived and real-time stats.

Share this post


Link to post

sorry it took so long to get back to ya - had to let a drive clearning finish 1st...

 

removed the unmenu PHP, and all is well on the console.... so that ver and your ver fight with each other....

 

also noticed on the console, you are using a # for a comment in the webserver.cfg file, that has been deprecated and php is hollering about it, comments are the ; character now....

 

Thanks for the package

Myk

 

Share this post


Link to post

One idea for a plugin... Have a navbar for the various sites / apps hosted on unRAID.  I used your web server plugin and mixed in some dynamic html to have a navigation bar across the bottom that autohides.  In there I placed launcher images for each of the various sites hosted on the unRAID box.  Makes quick work of jumping between them!

 

Thanks!

 

(screenshots attached)

main-nav.jpg.8c651c6227f402b0b49bd03ac322de10.jpg

main-navhide.jpg.9c5d35b2a0d2c42b866168449786c0bf.jpg

Share this post


Link to post

installed. change the default data directory. disable and reenable. since the new default directory is not automatically created, i created the directory myself. then i created empty index.htm file.

 

when i try to open http://tower:81/index.htm, all i get is

 

 

This program cannot display the webpage

 

Most likely causes:

•You are not connected to the Internet.

•The website is encountering problems.

•There might be a typing error in the address.

 

What you can try:

 

Check your Internet connection. Try visiting another website to make sure you are connected.

Retype the address.

Go back to the previous page.

 

 

thanks.

 

i want to report that after restarting, everything works fine.

 

thank you for your effort.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.