Jump to content
speeding_ant

"SimpleFeatures" - WebServer Plugin [SUPPORT]

308 posts in this topic Last Reply

Recommended Posts

Damn... same effect as the last time I reinstalled the webserver... the unraid main gui becomes unavailable... And I have a preclear running that will take several more days so I cannot reboot the server :-(

 

When I try to reinstall the core webgui I get an error message (in an attempt to fix the main pages):

 

root@Tower:/boot/plugins# installplg simpleFeatures.core.webGUI-1.0.11-noarch-1.plg

/usr/bin/php: error while loading shared libraries: libssl.so.0: cannot open shared object file: No such file or directory

 

 

Any idea ?

 

EDIT: I Aborted the preclear and rebooted, main gui is back.

I found the second plugin using SSL, its the plugin for SABnzbd (the unplugged one by influencer).

 

Now this is a concern, I have no idea how to fix this.. I do not want to loose SABnzbd but I also need the web plugin..

 

What should be my way forward on this ?

 

 

Share this post


Link to post

What should be my way forward on this ?

 

You can modify the plg file, either downgrade the webserver plugin to version 0.9.8 (I have not tested this so can't guarantee it works) or upgrade the sabnzb plugin to version 1.0.0. (perhaps influencer can tell whether this works).

 

 

Share this post


Link to post

I just upgraded my SimpleFeatures from v1.05 to v1.11 including the web server, but the new PHP doesn't work with my newznab installation, whereas the PHP in v1.05 was fine.

 

What's the difference with the new version? Were there more php packages installed in v1.05, and if yes how can I get them back in v1.11?

 

Thanks for letting me know, Alex.

 

PS: If the above is too complex or impossible, can I use the old webserver plugin v1.05 but keep all other plugins as v1.11?

Share this post


Link to post

I just upgraded my SimpleFeatures from v1.05 to v1.11 including the web server, but the new PHP doesn't work with my newznab installation, whereas the PHP in v1.05 was fine.

 

What's the difference with the new version? Were there more php packages installed in v1.05, and if yes how can I get them back in v1.11?

 

Thanks for letting me know, Alex.

 

PS: If the above is too complex or impossible, can I use the old webserver plugin v1.05 but keep all other plugins as v1.11?

 

It is not possible to run version 1.0.5 and 1.0.11 together.

 

See the suggestion about upgrading the openSSL package in the previous post.

 

Share this post


Link to post

I think the best course of action will be for me to change the SimpleFeatures plugin to work with the previous openssl version. Reason is that I actually rely MORE on the functionality of SABnzbd and the webserver will be more easy to test.

 

I have adjusted the PLG file to work with the previous version and have attached it. Issue is that I am afraid that installing it will break my main core web gui again and I am again far into a preclear I do not want to interrupt. So if anyone having this issue wants to try be my guest. Otherwise I will test somewhere during the weekend.

 

Nothing bad can happen, only thing I can imagine is the webserver nog working, and that is not working anyhow at the moment. I would advise placing this plugin in /boot/plugins, removing the regular simplefeatures webserver plugin and then rebooting the system.

simpleFeatures.web.server-1.0.11-_downgraded_openssl-noarch-1.zip

Share this post


Link to post

Your modification won't work.

 

Please try this updated web.server.plugin

 

Thanks, I will try as soon as I dare (to afraid to have my main gui die off again). I am not a plugin author at all but there are still a lot of reference to the 1.01 version of openssl in here, is that correct ?

Share this post


Link to post

I did it and the plugin shows running at the moment.. So it looks like this did it.

 

I however am still not able to reach my pages. I placed the lighttpd.cfg in the directory. I get a HTTP error 500 which means (I think) there is nothing listening on the port that is specified in the lighttpd.cfg:

# Add your own settings here. These won't get overwritten upon reboot
#

$SERVER["socket"] == "192.168.1.13:8086" {
server.document-root = "/mnt/cache/www/spotweb/"

url.rewrite-once = ( 
	"^/api\?(.*)" => "/index.php?page=newznabapi&$1" 
)
}

 

The webgui settings point to port 81 with server root /mnt/cache/www/main.

 

There is nothing behind that port, but if I go to it I get a 404 not found which means no pages foud.

 

Leads me to conclude that the webserver is running but the lighttpd.cfg is not picked up.

 

Its located in /config/simpleFeatures which should be correct, because when I remove it the webserver refuses to start..

 

Any idea ?

Share this post


Link to post

try this, change path and IP and port to your own

 

$SERVER["socket"] == "192.168.0.199:8084" {
        server.document-root = "/mnt/cache/www/newznab/www/"

        url.rewrite-once = (
                "^/.*\.(css|jpg|jpeg|gif|png|js|ico)" => "$0",
                "^/(admin|install).*$" => "$0",
                "^/([^/\.]+)/?(?:\?(.*))$" => "index.php?page=$1&$2",
                "^/([^/\.]+)/?$" => "index.php?page=$1",
                "^/([^/\.]+)/([^/]+)/?(?:\?(.*))$" => "index.php?page=$1&id=$2&$3",
                "^/([^/\.]+)/([^/]+)/?$" => "index.php?page=$1&id=$2",
                "^/([^/\.]+)/([^/]+)/([^/]+)/?$" => "index.php?page=$1&id=$2&subpage=$3"
        )
}


$SERVER["socket"] == "192.168.0.199:8088" {
        server.document-root = "/mnt/cache/www/phpMyAdmin-3.5.6-all-languages/"
}

$SERVER["socket"] == "192.168.0.199:8086" {
        server.document-root = "/mnt/cache/www/spotweb/"
}

$SERVER["socket"] == "192.168.0.199:8087" {
        server.document-root = "/mnt/cache/www/owncloud/"
}

Share this post


Link to post

try this, change path and IP and port to your own

 

$SERVER["socket"] == "192.168.0.199:8084" {
        server.document-root = "/mnt/cache/www/newznab/www/"

        url.rewrite-once = (
                "^/.*\.(css|jpg|jpeg|gif|png|js|ico)" => "$0",
                "^/(admin|install).*$" => "$0",
                "^/([^/\.]+)/?(?:\?(.*))$" => "index.php?page=$1&$2",
                "^/([^/\.]+)/?$" => "index.php?page=$1",
                "^/([^/\.]+)/([^/]+)/?(?:\?(.*))$" => "index.php?page=$1&id=$2&$3",
                "^/([^/\.]+)/([^/]+)/?$" => "index.php?page=$1&id=$2",
                "^/([^/\.]+)/([^/]+)/([^/]+)/?$" => "index.php?page=$1&id=$2&subpage=$3"
        )
}


$SERVER["socket"] == "192.168.0.199:8088" {
        server.document-root = "/mnt/cache/www/phpMyAdmin-3.5.6-all-languages/"
}

$SERVER["socket"] == "192.168.0.199:8086" {
        server.document-root = "/mnt/cache/www/spotweb/"
}

$SERVER["socket"] == "192.168.0.199:8087" {
        server.document-root = "/mnt/cache/www/owncloud/"
}

 

Its the exact same config that was working with previous version, also the spotweb part of your file is fully identical to mine..

Share this post


Link to post

OK, everything is working for me

 

//P

 

I used your total lighttpd with only correction for ip... same result...

 

Help...

Share this post


Link to post

this is my completed file, exactly what is not working ? what error do you get ?

 

# User customizations
# Add your own settings here. These won't get overwritten upon reboot
## Abdd your own settings here. These won't get overwritten upon reboot
#

$SERVER["socket"] == "192.168.0.199:8084" {
        server.document-root = "/mnt/cache/www/newznab/www/"

        url.rewrite-once = (
                "^/.*\.(css|jpg|jpeg|gif|png|js|ico)" => "$0",
                "^/(admin|install).*$" => "$0",
                "^/([^/\.]+)/?(?:\?(.*))$" => "index.php?page=$1&$2",
                "^/([^/\.]+)/?$" => "index.php?page=$1",
                "^/([^/\.]+)/([^/]+)/?(?:\?(.*))$" => "index.php?page=$1&id=$2&$3",
                "^/([^/\.]+)/([^/]+)/?$" => "index.php?page=$1&id=$2",
                "^/([^/\.]+)/([^/]+)/([^/]+)/?$" => "index.php?page=$1&id=$2&subpage=$3"
        )
}


$SERVER["socket"] == "192.168.0.199:8088" {
        server.document-root = "/mnt/cache/www/phpMyAdmin-3.5.6-all-languages/"
}

$SERVER["socket"] == "192.168.0.199:8086" {
        server.document-root = "/mnt/cache/www/spotweb/"
}

$SERVER["socket"] == "192.168.0.199:8087" {
        server.document-root = "/mnt/cache/www/owncloud/"
}

$SERVER["socket"] == "192.168.0.199:8089" {
        server.document-root = "/mnt/cache/www/ajaxplorer/"
}
$SERVER["socket"] == "192.168.0.199:8092" {
        server.document-root = "/mnt/cache/www/ajaxplorer-20121011-3186/"
}
$SERVER["socket"] == "192.168.0.199:8090" {
        server.document-root = "/mnt/cache/www/eXtplorer/"
}

$SERVER["socket"] == "192.168.0.199:8091" {
        server.document-root = "/mnt/cache/www/phpvirtualbox/"
}

Share this post


Link to post

I did some more checking.. looks like the server cannot read /write in the spotweb directory.. what rights do you have on your /spotweb and underlying files ?  i have nobody:users and 750 ..

Share this post


Link to post

-rwxrwxrwx  1 nobody users 25194 2013-01-16 20:11 usenetservers.xml*
-rwxrwxrwx  1 nobody users  4678 2013-01-16 20:11 upgrade-db.php*
drwxrwxrwx  2 nobody users   272 2013-01-16 20:11 tests/
drwxrwxrwx  6 nobody users   160 2013-01-16 20:11 templates/
-rwxrwxrwx  1 nobody users  8015 2013-01-16 20:11 settings.php*
-rwxrwxrwx  1 nobody users 11611 2013-01-16 20:11 retrieve.php*
-rwxrwxrwx  1 nobody users 17411 2013-01-16 20:11 notifications.xml*
drwxrwxrwx  3 nobody users    72 2013-01-16 20:11 locales/
drwxrwxrwx  9 nobody users   240 2013-01-16 20:11 js/
-rwxrwxrwx  1 nobody users 28255 2013-01-16 20:11 install.php*
-rwxrwxrwx  1 nobody users 15638 2013-01-16 20:11 index.php*
drwxrwxrwx  3 nobody users   320 2013-01-16 20:11 images/
lrwxrwxrwx  1 nobody users    18 2013-01-16 20:11 favicon.ico -> images/favicon.ico*
-rwxrwxrwx  1 nobody users  1941 2013-01-16 20:11 README.md*
drwxrwxrwx  3 nobody users   104 2013-01-16 20:11 NNTP/
-rwxrwxrwx  1 nobody users 14607 2013-01-16 20:11 Mobile_Detect.php*
drwxrwxrwx  2 nobody users    80 2013-01-16 20:11 Math/
-rwxrwxrwx  1 nobody users  1488 2013-01-16 20:11 LICENSE*
-rwxrwxrwx  1 nobody users  1403 2013-01-16 20:11 INSTALL*
drwxrwxrwx  2 nobody users   128 2013-01-16 20:11 Crypt/
-rwxrwxrwx  1 nobody users   149 2013-01-16 20:11 .htaccess*
-rwxrwxrwx  1 nobody users   214 2013-01-16 20:11 .gitignore*
-rwxrwxrwx  1 nobody users   484 2013-01-16 20:11 .gitattributes*
-rw-r--r--  1 root   root    169 2013-01-19 10:57 dbsettings.inc.php
-rwxrwxrwx  1 root   root   8015 2013-01-20 08:40 ownsettings.php_old*
drwxrwxrwx 12 nobody users   864 2013-01-20 09:53 ./
drwxrwxrwx 15 nobody users  1368 2013-02-10 20:22 lib/
drwxrwxrwx  8 nobody users   392 2013-02-19 21:17 .git/
drwxrwxrwx 16 nobody users  1112 2013-02-21 18:45 ../

 

drwxrwxrwx  2 nobody users      48 2012-12-26 12:39 main/
drwxrwxrwx 10 nobody users    1112 2013-01-11 13:29 eXtplorer/
drwxrwxrwx  6 nobody users     392 2013-01-11 13:52 ajaxplorer/
drwxr-xr-x  8 nobody users    3872 2013-01-17 21:45 phpMyAdmin-3.5.5-all-languages/
drwxrwxrwx  8 nobody users    3808 2013-01-30 21:25 phpMyAdmin-3.5.6-all-languages/
drwxr-xr-x 14 nobody users     664 2013-01-19 10:48 owncloud/
drwxrwxrwx 12 nobody users     864 2013-01-20 09:53 spotweb/
drwxr-xr-x  9 root   root      576 2013-02-03 16:17 phpvirtualbox/
drwxrwxrwx 22 nobody users    1016 2013-02-17 10:24 ../
drwxrwxrwx  7 nobody users     416 2013-02-21 18:45 ajaxplorer-20121011-3186/
drwxrwxrwx 16 nobody users    1112 2013-02-21 18:45 ./
drwxrwxrwx  8 nobody users     368 2013-02-21 19:00 newznab/

Share this post


Link to post

Right.... I was able to access the following url:

 

http://192.168.1.13:8086/install.php

 

This starts up a "test your installation".

 

The fact that this page loads means that the webserver actually is working.

 

There are a lot of "not ok's" here so something is messed up. I will reinstall the lot.

Share this post


Link to post

Well... this is way above my head... before the new simplefeatures this was all working :-(  Not to say you guys are the cause of the issue. But I have no idea how to fix this now.

 

PHP settings Value Result

PHP version 5.3.17 OK

timezone settings Europe/Berlin OK

Open base dir OK

Allow furl open 1 OK

PHP safe mode OK

Memory limit 128M OK

 

PHP extension Result

ctype NOT OK

curl NOT OK

DOM OK

gettext NOT OK

mbstring NOT OK

json OK

xml OK

zip NOT OK (You need this module to select multiple NZB files)

zlib NOT OK

Database support NOT OK

DB::mysql NOT OK

DB::pdo_mysql NOT OK

DB::pgsql NOT OK

GD OK

FreeType Support OK

GIF Read Support OK

GIF Create Support OK

JPEG Support OK

PNG Support OK

OpenSSL

Share this post


Link to post

Well that seriously did something positive !

 

I have been able to go through the setup, only when I come to page 3 of "install.php" nothing happens .. looks like something did not load..

Share this post


Link to post

edit php.ini

 

change this line (966)

 

;extension=gettext.so

 

to

 

extension=gettext.so

 

:D

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.