Friday at 08:50 PM3 days I've gotten some odd errors with my hdds recently. One drive was showing as disabled, so i removed it and rebuilt it from parity. Was working ok for a few days and then added a second parity drive to ensure everything would be ok. Now the 2nd parity isn't showing up in the array and the original parity is showing disabled with the 1st original drive now showing as Unmountable: wrong or no file system. I tried replacing power cables, sas cables, and power supply. Anyone know what the best next steps are? diagnostics-20260918-1539.zip
Saturday at 06:37 AM2 days Community Expert Diags are after rebooting, so we can't see what happened. Start by check filesystem on disk1Parity SMART doesn't look very good; run an extended SMART test.
Saturday at 12:44 PM2 days Author results of the check disk 1 and another diagnostic found previously. I think that was after a reboot unfortunately. Will add the extended smart test after it completes. check_disk1_20260919.txt diagnostics-20260914-1842.zip
Saturday at 01:01 PM2 days Author When I attempt to fix disk1, should I continue with the zero log?Phase 1 - find and verify superblock... Phase 2 - using internal log - zero log... ERROR: The filesystem has valuable metadata changes in a log which needs to be replayed. Mount the filesystem to replay the log, and unmount it before re-running xfs_repair. If the filesystem is a snapshot of a mounted filesystem, you may need to give mount the nouuid option. If you are unable to mount the filesystem, then use the -L option to destroy the log and attempt a repair. Note that destroying the log may cause corruption -- please attempt a mount of the filesystem before doing this. Edited Saturday at 01:02 PM2 days by ricerony
Saturday at 01:30 PM2 days Community Expert Yep, continue; it's the only option since the disk doesn't mount and typically fine.
Saturday at 02:04 PM2 days Author Thank you, disk 1 is now back in the array. Will probably place the other drive in parity 2 after the smart test.
11 hours ago11 hr Author Parity 1 was stuck at 100% yesterday after 30 hours. Restarted it yesterday and its showing up at 100% again, but not finishing. Does it need more time or is stuck somewhere? Here is the smartctl output=== START OF INFORMATION SECTION ===Vendor: IBM-ESXSProduct: ST14000NM0288 ERevision: ECH8Compliance: SPC-5User Capacity: 13,902,809,137,152 bytes [13.9 TB]Logical block size: 4096 bytesLU is fully provisionedRotation Rate: 7200 rpmForm Factor: 3.5 inchesLogical Unit id: 0x5000c500aec78203Serial number: ZHZ4Y02M0000J830VTSUDevice type: diskTransport protocol: SAS (SPL-4)Local Time is: Mon Sep 21 06:50:28 2026 CDTSMART support is: Available - device has SMART capability.SMART support is: EnabledTemperature Warning: Enabled=== START OF READ SMART DATA SECTION ===SMART Health Status: Data channel impending failure data error rate too high [asc=5d, ascq=32]Grown defects during certification <not available>Total blocks reassigned during format <not available>Total new blocks reassigned = 500Power on minutes since format <not available>Current Drive Temperature: 38 CDrive Trip Temperature: 65 CAccumulated power on time, hours:minutes 49038:18Elements in grown defect list: 505Error counter log:Errors Corrected by Total Correction Gigabytes TotalECC rereads/ errors algorithm processed uncorrectedfast | delayed rewrites corrected invocations [10^9 bytes] errorsread: 0 6615 0 6615 25278 796680.496 3581write: 0 0 0 0 0 379017.683 0verify: 0 0 0 0 0 17404.574 0Non-medium error count: 1Pending defect count:0 Pending DefectsSelf-test execution status: 0% of test remainingSMART Self-test logNum Test Status segment LifeTime LBA_first_err [SK ASC ASQ]Description number (hours)# 1 Background long Self test in progress ... - NOW - [- - -]# 2 Background long Aborted (by user command) - 49018 - [- - -]# 3 Background short Completed - 48667 - [- - -]# 4 Background short Completed - 30785 - [- - -]# 5 Background short Completed - 15604 - [- - -]# 6 Background short Aborted (by user command) - 2 - [- - -]Long (extended) Self-test duration: 80400 seconds [22.3 hours] Edited 11 hours ago11 hr by ricerony
7 hours ago7 hr Community Expert There's no rebuild/check in the logs, please reboot to clear them and start a new parity sync, if it stil fails, post new diags and a screesnhto from Main.
7 hours ago7 hr Author Apologies, it looks like parity is still disabled. Attached are the diagnostics after reboot. Adding diagnostic when I added the other drive to parity 2.diagnostics-20260921-1120.zip diagnostics-20260921-1125.zip Edited 7 hours ago7 hr by ricerony
7 hours ago7 hr Community Expert I see the parity2 sync now logged, see if it finishes; if not, post new diags.
Join the conversation
You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.