9 hours ago9 hr Hi,I installed a new SSD and tried adding it to my boot pool. Unraid recognized it correctly, but when I tried starting my array, it gave me a "no device identification" error and wouldn't mount the disks. After rebooting through the UI, the array won't start at all and gives me a "Wrong Pool State - Invalid Expansion" error.I looked up how to resolve this error and it said that I had to remove the pool and recreate it. However, Remove pool is grayed out (prob because it's the data partition of the boot pool).Any way I can restore my boot pool without data loss?
7 hours ago7 hr Community Expert The problem is with the data partition, but since the diags are after a reboot cannot see what heppen.I assume there was data there. Also, post the output from btrfs fi show
5 hours ago5 hr Author here’s the output:Label: none uuid: 65b77da7-f29f-42b4-9c09-dab5938c58c0 Total devices 1 FS bytes used 277.11GiB devid 1 size 1.80TiB used 281.02GiB path /dev/nvme0n1p4I’ve added a new diag file after trying to start the array. Hope it helps! atlas-diagnostics-20260921-1939.zip
5 hours ago5 hr Community Expert That confirms the data partition is only using one device still; my recommendation would be to remove the new device from the boot pool, then try adding it again, if it still fails post-new diagnostics before rebooting.Unassign nvme1n1, start array, stop array, change boot pool slot to 2, and add it again.
1 hour ago1 hr Author Tried that, but the array still won't start. Getting the same error message.I've added the new diagnostic file. atlas-diagnostics-20260921-2348.zip
Join the conversation
You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.