Another split level topic

Recommended Posts

Dear Unraid community.

Please help me with the split level issue i experience.

I have read all of the info (including the wiki topic) but still have problems.

My setup for all of the disks in my array are the following:





                              /HD Movies



                              /TV Shows

                                              /TV Show Folder













The split level I set for all my HDDs is 3, HighWater. From what i understood, UNRAID will fill up 50% of the capacity of DISK1 and then will start to fill another 50% of DISK2, etc.... None of this is working for me. Unraid is writing only to DISK1, although i have tried every single split level number (from 1 to 5) and none of them gave any result. Curently my DISK1 is 60% full.

Please help me resolving this issue.


Thank you very much in advance.

Link to comment

Dear lionelhutz,

Thank you for your answer.


It is not dependant on the content. I tried to copy music, hd moves and tv shows directly to /usershares/media/(respective sub-folder) and the result is always the same. The content is written directly to DISK1 instead of the other empty disks. What i thought is that probably it is a split level issue. I don't mind TV Shows series to be stored only on DISK1, but why HD Movies, Documentaries and Music are still written on DISK1 instead of other ones?

Probably it is worth to be mentioned that i didn't restarted the server after changes being made in the splitlevel.

Best regards.


Link to comment

split level only comes into play when the fill type is hit.  If you have all empty drives than everything is going to write to the first drive until the fill level setting causes unraid to switch to another drive.


Check out the wiki for fill level info...that's what your seeing right now.


Edit1: Sorry, it's called Allocation method

Link to comment

Thanks for your answer Tybio,

If i got it right (according to wiki- Link ) the high water mode means that unraid will start to write on the next drive when the information on the first disk reaches 50% of the volume. So I thought after this 50% Unraid will start writing to the next HDD. Probably I misunderstood the idea.

Thanks again.


Best regards.

Link to comment

Is the directory structure like this?


Usershare is the share that appears over the network?

Media is a directory inside Usershare, Movies is inside Media and HD Movies is inside Movies?


If so, that is 4 directories deep so the HD Movies can not split with the split level set to 3.


Level 4 should have worked for movies but each complete TV series has to remain on a single disk.


Level 5 is too high for movies but it would allow a new season of a TV series to go to a new disk.


Care to share the complete Usershare settings or is that a secret?



Link to comment

Thanks for your answer. I have exactly the same folder structure on the second disk. If I write directly on disk2 the movie appears on the user shares. It is obviously writing when I force it but I had the impression that unraid is going to write automatically to the disks based on certain criteria. Probably the problem appears only to rc3?



Sent from my iPhone using Tapatalk

Link to comment

once disk1 is 50% full it will start to write to disk2.


Yes, theoretically it should be like this. Unfortunately DISK-1 is 55 % full and Unraid continue writing to it...



if you want to test the split level's, change allocation method to "most-free".

Just tested "Most free" method. Split level 3 or 4- it is the same. Only DISK-1 is used by Unraid.


Link to comment

Thank you all.

In case high-water means equal free space and not equal percentage of free space then it means that Unraid will start writing to Disk 2 (which is 750gb) once Disk 1 has only 750gb or less free space.

I will rename the topic to "Solved" now.

Best regards.

Link to comment
  • 2 weeks later...

Sadly I have to report that after filling DISK1 with data and only 750gb free remained (the same free space DISK2 has) unraid continues to write to DISK1 only using User Shares. Again tried to change high-level to 2,3, is just the same. Restarts performed on every split-level change. Even tried Most-free option.... To me user shares split-levels just don't work. Disk 2 is never used. Do I need to upgrade to RC6 as I am using RC3 recently?


EDIT: Upgraded to 8168-test version. Still no go.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.