Help please: I/O Error in syslog + parity error (appears unconnected)

Recommended Posts



Happy New Year to everyone!


I've woken up to the monthly parity check, but found that there was (for the first time) an error (just the one).  I have the monthly parity check set not to correct, so before committing the parity check error, started digging through the syslog to see if there was anything obviously amiss, and found a bunch of I/O errors (attached).  The errors relate to /dev/sdk, which is a disk not used in the array (fortunately!)  The particular drive in question is connected to a SAS2-AOC-LP with 7 other drives.  It therefore seems as if the parity error and drive issue aren't connected. 


I went into unmenu and tried to check the smart report for the drive, but got a message saying


I powered down, opened up and reseated all the cables.  Powered back up, and restarted the array, and still getting the same error message in the syslog.  Now the funny thing is that for some reason a different drive got assigned to sdk, but it is the same drive that has the error.  The previous drive is now fully querable through unmenu's smart report.


I checked the SMART reports for all disks, and none have any errors so haven't bothered to post these here (although happy to do so of course)


Could someone be kind enough to give me some advice on this?  Please let me know if there's any other information that would be helpful.

Link to comment

Thank you for the reponse @dgaschk


This is what it spits out:


smartctl 5.40 2010-10-16 r3189 [i486-slackware-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen,

Smartctl: Device Read Identity Failed (not an ATA/ATAPI device)

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.


Like I say though, I don't think it's drive related - I have 2 disks outside the array... let's call them Disk 1 and 2.  SMART previously gave this same error when disk 1 was on sdk, and I got a good SMART report on disk 2.  When I rebooted disk 2 got put on sdk and now I get a good readout for disk 1.  Am I making sense here?

Link to comment

Sorry for the delay - got called out of town for a while.


Ran the memtest without issue.  When I restarted, I noticed a command in the console relating to sdk... and then I remembered that I had a command in my go file to force a spindown on the hot spare.  So my problem is solved!


Glad I noticed the output in the console as I suspect we'd have been going round and round on this... would have probably ended up changing hardware without success!


Thank you for the help @dgaschk. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.