ProFTPD Plugin for unRAID v6.8.x


SlrG

Recommended Posts

@SlrG

 

Currently I only have one user (the one I use to remotely FTP to my server).

 

I have given myself full root access however when trying to delete files it is saying permission denied.

 

I want to have full read/write access.

Edited by blade227
forgot something
Link to comment
9 hours ago, blade227 said:

@SlrG

 

Currently I only have one user (the one I use to remotely FTP to my server).

 

I have given myself full root access however when trying to delete files it is saying permission denied.

 

I want to have full read/write access.

I wrote a quick blurb before on how I setup shares for FTP users that you may want to check out:

 

Default permissions are deny to the best of my knowledge, so you may have incorrectly set permissions.
When you say you have given yourself full root access, are you referring to full Read / Write permissions and not the root of the file system correct?

 

Edited by JaY_III
Link to comment
On 3/27/2019 at 1:01 PM, H2O_King89 said:

Un install the one from the App Store. Copy the link>plugins>install plugin tab then paste

Got it back up and running using this - thank you.  Once I'd re-made the changes to the conf file to get it through my pfsense router I was back in (which fortunately I had a copy of).  Thanks for your help.

Link to comment
  • 3 weeks later...

Hi guys, I am new in Unraid. I use proftpd and works perfectly.

Can you tell me how i can give only read permission for specific user?

 

I define home directory in description of user and this user have RW permissons.

 

How i can restart proftpd service via terminal?

Link to comment
23 hours ago, SlrG said:

@Kristijan

Please check Jay_III's excellent post on how he sets up his system. He is describing how to make a directory read only, too:

To restart proftpd from the command line:


/etc/rc.d/rc.ProFTPd restart

 

Tnx, but i dont undrestand. I have this situation.

I want try setup FTP acess for two differenet users, one RW permission one only R on same home directory.

Link to comment

@Kristijan

JaY_III uses the limit clause to create read only directories. You need to do that, too. But instead of DenyAll you will need to set DenyUser UserName.

#File Permissions
<Directory /path/to/dir>
<Limit WRITE>
DenyUser UserName
</Limit>
</Directory>

Check here for more explanations.

Edited by SlrG
Link to comment
On 5/9/2019 at 7:42 PM, SlrG said:

@Kristijan

JaY_III uses the limit clause to create read only directories. You need to do that, too. But instead of DenyAll you will need to set DenyUser UserName.


#File Permissions
<Directory /path/to/dir>
<Limit WRITE>
DenyUser UserName
</Limit>
</Directory>

Check here for more explanations.

Tnx. This is working. 

 

I have one folder which contain 7 subfolder and all users have FTP acess. I want one user only have RW, but other only read. In this situation a must add every directory and DenyUser.

 

My question is, is it possible add RW permission only for one user? but other have automatically denied permission if i didn't define?

Link to comment
[mention=16166]SlrG[/mention]: Just wanted to let you know that ProFTPd works perfectly on unRAID 6.7 if installed and updated in the default Plugins menu -> Install Plugin tab. If the app is installed via CA, it doesn't start after installation.
 
Cheers!
Assuming that the URL that was set up in the xml template is identical to the URL you manually entered in, then there is no reason for what you describe If the URLs do not match, then@SlrG needs to update the xml

Sent via telekinesis

Link to comment

@RoderickBasinB

Thank you for testing and reporting. But I can't replicate the problem. For me, it works fine with both installation types. I had once a hiccup, where the download of the dependency files from github got broken and the installation failed because of that. But simply trying again worked fine afterwards.

 

If it still doesn't work for you, can you please post the log messages from the installation window?

Link to comment

@SlrG Sure! First, I uninstalled the working version of ProFTPd (Note: I didn't reboot the server), and then I installed the one from CA (Installation log below). When I enabled ProFTPd, the plugin didn't start, as described previously by others. Then uninstalled CA's version (didn't reboot the server either), and then I installed as described in my previous post using the link you provided here:

On 3/18/2019 at 12:00 PM, SlrG said:

@H2O_King89

Well, lets try another way. Please install the modified plugin from here: http://sdevel.de/ProFTPd.plg

Does this work?

After installing,  an update button was present in the settings. Hit that button, updated, and everything worked brilliantly as soon as I enabled ProFTPd. The only difference between the installation logs from the CA method and "traditional" method is the URL in the first three lines: instead of the GitHub URL it shows the one you provided. You'll find attached a file with the Syslog of the whole uninstall - reinstall.

 

plugin: installing: https://github.com/SlrG/unRAID/raw/master/Plugins/ProFTPd.plg
plugin: downloading https://github.com/SlrG/unRAID/raw/master/Plugins/ProFTPd.plg
plugin: downloading: https://github.com/SlrG/unRAID/raw/master/Plugins/ProFTPd.plg ... done
Cleaning up previous install files...
Executing selfremoval commands if present...
...Cleanup complete!
Downloading any missing plugin files...
Latest plugin control files downloading
Plugin control files have passed MD5 check
Latest plugin dependency files downloading
Plugin dependency files have passed MD5 check
...Downloading complete!
Running install script for ProFTPd...
Installing plugin control files
Installing plugin dependency files
Detect if MySQL/MariaDB is installed...
Move Config Editor archive to plugin dir...

+==============================================================================
| Installing new package /tmp/ProFTPd-inst/install-B/ProFTPd-x86_64.tgz
+==============================================================================

Verifying package ProFTPd-x86_64.tgz.
Installing package ProFTPd-x86_64.tgz:
PACKAGE DESCRIPTION:
Executing install script for ProFTPd-x86_64.tgz.
Package ProFTPd-x86_64.tgz installed.
Disable builtin FTP-Server...
Restart inetd to apply change...
Starting Internet super-server daemon: /usr/sbin/inetd
Disable icon of builtin FTP-Server...
Remove example config file...
Symlink new config file...
ProFTPd is disabled. Please enable before starting.
Cleaning up temp files/folders
...Install complete!
plugin: installed

Updating Support Links

ProFTPd --> http://lime-technology.com/forum/index.php?topic=25695.0

Syslog.txt

Edited by RoderickBasinB
Insert syslog file
Link to comment

@RoderickBasinB

The url for the beta plugin is different, as I didn't wanted it to show as update until 6.7.0 was officially released.

 

The beta plugin looks for updates at the same github url as the normal version or CA. Once I pushed the beta version to github as new official release yesterday, it got made available as update in the plugin settings (no matter if old or beta) and it is now available in CA or for manually installing it from github https://github.com/SlrG/unRAID/raw/master/Plugins/ProFTPd.plg.

 

The beta version link is now obsolete. It provides the now old beta version with old version number, which is essentially the same as the new official version with a new version number.

 

I guess when you tried to install from CA it was before I pushed the beta version to github as new official release and so you got the old version still.

 

I hope this explains what was happening.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.