ProFTPD Plugin for unRAID v6.8.x


SlrG

753 posts in this topic Last Reply

Recommended Posts

I have this version installed proftpd-0.2-i486.plg, how do I upgrade to the latest version.

 

I did trying deleting the old plugin and installing the new plugin.  But could not get the plugin to start in the gui.

 

I also deleted the proftd folder, that didn't make any difference either.

 

Are there other files that need to be deleted prior to the updating?

Link to post
  • Replies 752
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

ProFTPd Support the plugin?   This is the support thread for my ProFTPD Plugin for unRAID v6.8.x   To install it: If you have installed the Community Applications

@Kristijan JaY_III uses the limit clause to create read only directories. You need to do that, too. But instead of DenyAll you will need to set DenyUser UserName. #File Permissions <Direct

I was having issues getting ProFTP running again after upgrading Unraid to version 6.9.1 using ProFTP 1.3.7a. ProFTP just would not start and I could not get anything in the log. I tried enabling debu

Posted Images

If you have modified the proftpd.conf, make a backup of it first. Then you should delete the whole proftpd folder and the plugin file and reboot your server.  Afterwards put the version from the first post into /boot/config/plugins/ and reboot again. Then replace the base proftpd.conf with your backup.

 

If this doesn't get you going, please post a full syslog.

 

regards,

 

SlrG

Link to post

If you have modified the proftpd.conf, make a backup of it first. Then you should delete the whole proftpd folder and the plugin file and reboot your server.  Afterwards put the version from the first post into /boot/config/plugins/ and reboot again. Then replace the base proftpd.conf with your backup.

 

If this doesn't get you going, please post a full syslog.

 

regards,

 

SlrG

 

I hadn't modified the proftpd.conf at all.  But I had already deleted the Proftpd folder prior to my post.

Link to post

The syslog doesn't contain any error messages regarding the plugin. The plugin should show under settings. :)

 

edit:

 

If it doesn't please check the following locations:

/usr/local/emhttp/plugins/proftpd/proftpd.png                        # plugin page icon file

/usr/local/emhttp/plugins/proftpd/proftpd.page                      # plugin page file

/usr/local/emhttp/plugins/proftpd/proftpd.php                        # plugin page file

/usr/local/emhttp/plugins/proftpd/event/disks_mounted        # event handler will start proftpd

/usr/local/emhttp/plugins/proftpd/event/unmounting_disks  # event handler will stop proftpd

 

They should all be present.

Link to post
  • 3 weeks later...

I hope this is the right place to post ProFTPD related questions.

 

I downloaded the .plg file and set it up. Added a user (shrek) with description (ftpuser /mnt/disk1/FTP)

Shows like this in /ets/passwds

 

shrek:x:1000:100:ftpuser /mnt/disk1/FTP:/mnt/disk1/FTP:/bin/false

 

2 issues I'm facing:

 

1st Issue :

On the ProFTP setting page : Status shows as STOPPED even though the service is running (I can login via FTP):

 

Connected to 192.168.1.100.

220 ProFTPD 1.3.5rc3 Server (ProFTPD Default Installation) [192.168.1.100]

 

2nd Issue:

If I login with that user : I'm still able to browse to a higher level (all the way up to root and anywhere I want). How do I restrict the user to that particular folder?

 

Attaching my proftpd.conf file here

proftpd.conf

Link to post

OK. So I was able to resolve the access perms (to lock user to their home dir)

 

I had to add the DefaultRoot ~ property to proftpd.conf to do that.

 

So the only issue remaining is that my proFTPd config screen still shows the status as STOPPED even though the process is running and accepting FTP connections (see attached image)

 

Untitled.png.06431a3c1cd9ebf13542d81058772e83.png

Link to post

Why are you using a different config file instead modifying the one provided by me? :)

 

The problem is, that you have to add the following line to your config (below "DefaultServer on"):

PidFile /var/run/proftpd.pid

 

This file is used to detect the running process. With your conf it will be created at a different position than the plugin expects it to be.

Link to post
  • 2 weeks later...

Plugin version is 0.5g now from 2013-07-17. If you have another version, please try to download from the first post and reinstall. If it doesn't work, please provide a syslog. If you already are at this version, please provide a syslog, too.

Link to post
  • 2 months later...

Just installed the plugin, Downloaded it from the first page, initially i tried installing it with instalplg proftpd.plg, but something went wrong and unraid console crashed. I removed proftpd folder and pplg and rebooted.

 

after that i copied proftpd to /boot/config/plugins and rebooted, proftpd installed without errors. however.. i cannot start the plugin..

 

all i have in syslog is this.

 

Oct 30 14:35:37 Tower sudo:    root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/local/sbin/proftpd -c /etc/proftpd.conf

 

Any idea what this is? .

 

edit: attached syslog.

syslog.zip

Link to post

@Madhouse:

I did look through your syslog, but didn't find anything unusual. The plugin should work fine.

 

So i'll have to ask some questions to find the problem.

 

Do you have a proftpd icon under settings? If you have and click on it, what do you see? Is the status "running" or "stopped"?

 

Is a newer version reported under updates?

 

Do you have a config editor in the lower half of the window? Did you do any changes to the base config file?

 

Do you have created a ftpuser using unraids "Users" dialog? Did you restart proftpd after creating the user? The name of the user is free for you to choose, but the keyword ftpuser has to be put into the comment field for each user you want to access your proftp.

Link to post

@spylex:

glftpd looks nice, but I think it will be hard getting it to run on unraid. I'll give it a try and report back. :)

 

edit:

Using the install script in the archive it is possible to install glftpd on unraid. To get the server to work, a ssl certificate hast to be created. For this to work the openssl.cfg has to be symlinked to openssl.cnf. Then use the script provided by glftpd to create the cert. Add glftpd: ALL to hosts.allow.

 

As the created files should be identical to each unraid installation it should be possible to put them in a plugin. I don't have the time to do this however. glftpd is nice, but I found no way to limit users to specific directories. A requirement I just need.

Link to post

@Madhouse:

I did look through your syslog, but didn't find anything unusual. The plugin should work fine.

 

So i'll have to ask some questions to find the problem.

 

Do you have a proftpd icon under settings? If you have and click on it, what do you see? Is the status "running" or "stopped"?

Status is Stopped

 

Is a newer version reported under updates?

Version is 1.3.5rc3

 

Do you have a config editor in the lower half of the window? Did you do any changes to the base config file?

Nope, no config editor.

Do you have created a ftpuser using unraids "Users" dialog? Did you restart proftpd after creating the user? The name of the user is free for you to choose, but the keyword ftpuser has to be put into the comment field for each user you want to access your proftp.

User is created. - ftpuser /mnt/user/Shared/Backups/

Link to post

Please open a shell window and type:

/etc/rc.d/rc.proftpd start

 

Please post the output and syslog messages this generates.

 

here's the output, no errors.

 

Renewing userjail...

...OK

Starting ProFTPD...

...OK

 

however, its still not running.. according to unraid / setting

 

I really appreciate your help. :)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.