VirtualBox Plugin for unRAID v5 and v6


Recommended Posts

Same deal. Now that my eth0 reads I try bridged with eth0. Still fails.


Everything other than NAT fails in one way or another. (network unreachable or interface doesn't come up)


My windows installation of VirtualBox has no issues creating bridged network. :(


UPDATE: I have got it working, but I am curious as to why it fails initially.


Boot Server.

Wait 2 mins for the DHCP stupid "For Wait For" to timeout

Log in.

ifdown enp0s3

    Returns Network is Unreachable blah blah

ifup enp0s3



I can ping my network. All is good. Why won't it do this in the FIRST place!? Arhghghgh


Temporary workaround is /etc/rc.local added


ifdown enp0s3

ifup enp0s3

Link to comment

just a quick note of something I did just noticed... if any of you guys are running vboxwebsrv manually with "--logfile /dev/null" param (as many suggested on a few old topics on this forum) you should always also add "--logrotate 0" else it rotates the /dev/null to /dev/null.1, etc... and creates a new /dev/null that it's actually a regular file on ramfs... like this:


root@unRAID:~# ls -l /dev/null*
-rw------- 1 root root 4093779968 2016-01-10 06:53 /dev/null
-rw------- 1 root root      54991 2015-12-26 06:37 /dev/null.1
-rw------- 1 root root     157941 2015-12-25 19:58 /dev/null.2
-rw------- 1 root root        868 2015-11-30 00:43 /dev/null.3
crw-rw-rw- 1 root root       1, 3 2015-11-24 23:50 /dev/null.4


not good :(


btw, think it doesn't affect current theone's plugin, as apparently he runs vbox using rc init script.

Link to comment

I'm new to Unraid and this virtualbox plugin.

I installed it, but its not working. I could not find any tutorial or "getting started" blog post on this.

I do see the webui with some config options but thats it.. it doesn't have a "add VM" button.


What should i enable to enable such a button?

And should i install phpVirtualbox? If so, mentioning that and adding link to that plugin in the 1st post would be of great use for noobs like me.

And the Help button does nothing. Mentioning the "goto defaults to get things working" would be practical.


Or do the "No online package No local package Not Installed" indicators mean i should "wait for laine" ?


Link to comment
  • 3 weeks later...

Thanks for the headsup. So i take it this fixes the Dynamix web interface going down?


I cant use virtualbox plugin without crashing the webinterface..

I have been running virtualbox for the past few 5 years (at least) and have not had it crash the webUI. I did have segfaults due to lack of memory.

I am not running any Dockers.


Your problem seems to be reappearing in the forum and might be due to docker issues.


do you get the problem when running without Virtualbox?

do you get the problem when running without Dockers?


Link to comment
  • 2 weeks later...

Hi All


i have a some basic questions regarding the plugin:


do i need to install an additional web server and if not/yes where i need to copy the phpvbox stuff?


i read the Wikis but i cannot find any clue for my problem.


You need to install a webserver and phpvirtualbox.

Link to comment

Thx it worked ... but is it really necessary to install another web server? is for the unraid gui already a server?


but i works now, and really good compared with the builtin qemu stuff.




Just remember not to upgrade unRAID to a new version if it has a new kernel until I release/compile a new VirtualBox package, otherwise you will be still without VirtualBox until I do.


Link to comment
  • 2 weeks later...
  • 1 month later...



I installed the virtualbox plugin,

installed apache webserver, put the phpvirtualbox..


when I connect to the webserver, I can see RECENT CONNECTIONS




there is dolphin plugin there that works..


how can I add new windows 7 for example?



Link to comment

Please post:

* screenshot of webserver plugin page

* screenshot of webserver folder you defined

* what URL address you are using to access phpvirtualbox

* screenshot of virtualbox plugin page


attached all,

trying to connect to which is my unraid IP address.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.