VirtualBox Plugin for unRAID v5 and v6


theone

Recommended Posts

No problem, as long as I am still using it... ;)

Just promise us this: when you abandon Unraid/VB as an OVF-compatible virtualization/storage platform, tell us where you went so we can follow along :-)

There are other reasons to use virtualbox, but OVF works just fine with unraid's built in KVM manager. Frankly it's less work to extract and use the disk image from the OVF archive in KVM than it is to install and use the virtualbox plugin. The automatic disk image selection in unraid doesn't pick up the ova or vdi file, but you can easily type it in to the selection box and it works fine.
Link to comment
There are other reasons to use virtualbox, but OVF works just fine with unraid's built in KVM manager. Frankly it's less work to extract and use the disk image from the OVF archive in KVM than it is to install and use the virtualbox plugin. The automatic disk image selection in unraid doesn't pick up the ova or vdi file, but you can easily type it in to the selection box and it works fine.

Oh my, that is interesting. I hadn't realized that Limetech had transitioned from Xen to KVM. Here's a blog post about it. This question may be a little dumb: do we know which GA version of UnRAID includes KVM instead of Xen? How would one tell?

Link to comment

There are other reasons to use virtualbox, but OVF works just fine with unraid's built in KVM manager. Frankly it's less work to extract and use the disk image from the OVF archive in KVM than it is to install and use the virtualbox plugin. The automatic disk image selection in unraid doesn't pick up the ova or vdi file, but you can easily type it in to the selection box and it works fine.

Oh my, that is interesting. I hadn't realized that Limetech had transitioned from Xen to KVM. Here's a blog post about it. This question may be a little dumb: do we know which GA version of UnRAID includes KVM instead of Xen? How would one tell?

Xen was only available in the early v6 beta releases while it was being evaluated as an alternative to KVM..    All v6 releases since then have used KVM.
Link to comment

There are other reasons to use virtualbox, but OVF works just fine with unraid's built in KVM manager. Frankly it's less work to extract and use the disk image from the OVF archive in KVM than it is to install and use the virtualbox plugin. The automatic disk image selection in unraid doesn't pick up the ova or vdi file, but you can easily type it in to the selection box and it works fine.

Oh my, that is interesting. I hadn't realized that Limetech had transitioned from Xen to KVM. Here's a blog post about it. This question may be a little dumb: do we know which GA version of UnRAID includes KVM instead of Xen? How would one tell?

Xen was only available in the early v6 beta releases while it was being evaluated as an alternative to KVM..    All v6 releases since then have used KVM.

Looks like xen was dropped in v6rc3, about a year before you registered for the forum.
Link to comment
  • 1 month later...
  • 3 weeks later...
  • 1 month later...

I uploaded latest Virtualbox 5.1.16 compiled package for:

 

* unRAID version 6.3.2 - kernel 4.9.10

 

Edit:

I uploaded latest Virtualbox 5.1.18 compiled package for:

 

* unRAID version 6.3.2 - kernel 4.9.10

Edited by theone
Link to comment
  • 3 weeks later...
  • 4 weeks later...

Looks like issue with 5.1.20 extension pack.  I see a brief question something like do I agree to these terms or whatever with a y/n? along the bottom of the GUI before a message saying install failed.  Nothing in log to clue other than failed.

Apr 29 23:25:05 Tower rc.virtualbox[14283]: Installing Virtualbox Extension package (v5.1.20)...
Apr 29 23:25:07 Tower rc.virtualbox[14354]: Installation of Virtualbox Extension package failed

Edit: Confirmed it is a license accept prompt preventing it from installing.  If I run '/opt/VirtualBox/VBoxManage extpack install /boot/config/plugins/virtualbox/Oracle_VM_VirtualBox_Extension_Pack-5.1.20.vbox-extpack' and accept the license agreement it will install.

 

 

Edited by unevent
Link to comment
  • 3 weeks later...
On ‎4‎/‎29‎/‎2017 at 11:29 PM, unevent said:

Looks like issue with 5.1.20 extension pack.  I see a brief question something like do I agree to these terms or whatever with a y/n? along the bottom of the GUI before a message saying install failed.  Nothing in log to clue other than failed.


Apr 29 23:25:05 Tower rc.virtualbox[14283]: Installing Virtualbox Extension package (v5.1.20)...
Apr 29 23:25:07 Tower rc.virtualbox[14354]: Installation of Virtualbox Extension package failed

Edit: Confirmed it is a license accept prompt preventing it from installing.  If I run '/opt/VirtualBox/VBoxManage extpack install /boot/config/plugins/virtualbox/Oracle_VM_VirtualBox_Extension_Pack-5.1.20.vbox-extpack' and accept the license agreement it will install.

 

 

Thank you for this!  Very helpful.  I have to reinstall the extpack every time my server restarts.  Any idea how to prevent that?

Link to comment

I didn't have that problem.  My issue was everything would install except for the extension pack.  Running the command manually via telnet allowed me to accept the license agreement and then the GUI showed everything was installed.  The extpack file should remain in the plugin folder on the flash drive and the filename should also be kept the same as how the plugin downloads it.

Link to comment
On 30.4.2017 at 6:29 AM, unevent said:

Looks like issue with 5.1.20 extension pack.  I see a brief question something like do I agree to these terms or whatever with a y/n? along the bottom of the GUI before a message saying install failed.  Nothing in log to clue other than failed.


Apr 29 23:25:05 Tower rc.virtualbox[14283]: Installing Virtualbox Extension package (v5.1.20)...
Apr 29 23:25:07 Tower rc.virtualbox[14354]: Installation of Virtualbox Extension package failed

Edit: Confirmed it is a license accept prompt preventing it from installing.  If I run '/opt/VirtualBox/VBoxManage extpack install /boot/config/plugins/virtualbox/Oracle_VM_VirtualBox_Extension_Pack-5.1.20.vbox-extpack' and accept the license agreement it will install.

 

 

The prompt is new (since virtualbox 5.1.20).

 

Does anyone know if there is a way to accept the license ("y") via a script?

If so I will add it to the plugin...

 

 

P.S.

 

I uploaded latest Virtualbox 5.1.22 compiled package for:

 

* unRAID version 6.3.4 - kernel 4.9.28

 

Edit:

Nevermind - I think I found the answer "yes | command....".

I will update the plugin.

Edited by theone
Link to comment
  • 2 weeks later...

I just install Virtualbox for the first time and set it up.

Downloaded and started it on port 8084.

when i go to the Webui i get this error.

 

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<faultcode>message</faultcode>
<faultstring>HTTP GET method not implemented</faultstring>
</SOAP-ENV:Fault>
 
When i restart the service from CLI nothing shows an error.
# /etc/rc.d/rc.virtualbox restart
<190>Jun  1 02:31:30 rc.virtualbox[29546]: No Virtual Machines running - nothing to save
No Virtual Machines running - nothing to save
<190>Jun  1 02:31:30 rc.virtualbox[29548]: vboxwebsrv service stopped
vboxwebsrv service stopped
<190>Jun  1 02:31:41 rc.virtualbox[29928]: /opt/VirtualBox/VBoxManage setproperty websrvauthlibrary null
/opt/VirtualBox/VBoxManage setproperty websrvauthlibrary null
<190>Jun  1 02:31:41 rc.virtualbox[29955]: vboxwebsrv service started
vboxwebsrv service started
<190>Jun  1 02:31:41 rc.virtualbox[30110]: No Virtual Machines in previous session (list is empty)
No Virtual Machines in previous session (list is empty)
 
The logs don't show anything.
 
00:00:00.000511 main     Log opened 2017-06-01T09:31:41.088211000Z
00:00:00.000512 main     Build Type: release
00:00:00.000513 main     OS Product: Linux
00:00:00.000513 main     OS Release: 4.9.30-unRAID
00:00:00.000514 main     OS Version: #1 SMP PREEMPT Fri May 26 13:56:36 PDT 2017
00:00:00.000528 main     DMI Product Name: To be filled by O.E.M.
00:00:00.000531 main     DMI Product Version: To be filled by O.E.M.
00:00:00.000562 main     Host RAM: 13929MB (13.6GB) total, 12980MB (12.6GB) available
00:00:00.000564 main     Executable: /opt/VirtualBox/vboxwebsrv
00:00:00.000565 main     Process ID: 29954
00:00:00.000565 main     Package type: LINUX_64BITS_GENERIC
00:00:00.002462 main     IPC socket path: /tmp/.vbox-root-ipc/ipcd
00:00:00.005497 main     Pumping COM event queue
00:00:00.005508 main     Pumping COM event queue
00:00:00.005529 Watchdog Watchdog thread started
00:00:00.005530 Watchdog Watchdog: sleeping 5 seconds
00:00:00.005803 SQPmp    Socket connection successful: host = 10.0.10.252, port = 8084, master socket = 9
00:00:00.049696 main     Pumping COM event queue
00:00:00.069668 main     Pumping COM event queue
00:00:00.077944 main     Pumping COM event queue
00:00:00.091738 main     Pumping COM event queue
00:00:00.106308 SQPmp    Request 1 on socket 10 queued for processing (1 items on Q)
00:00:00.107965 SQW01    New SOAP thread started
00:00:00.107986 SQW01    Processing connection from IP=10.0.10.251 socket=10 (0 out of 1 threads idle)
00:00:00.182273 SQPmp    Request 2 on socket 10 queued for processing (1 items on Q)
00:00:00.182287 SQW01    Processing connection from IP=10.0.10.251 socket=10 (0 out of 1 threads idle)
00:00:01.987649 SQPmp    Request 3 on socket 10 queued for processing (1 items on Q)
00:00:01.987665 SQW01    Processing connection from IP=10.0.10.251 socket=10 (0 out of 1 threads idle)
00:00:01.987810 SQPmp    Request 4 on socket 11 queued for processing (1 items on Q)
00:00:01.987830 SQW02    New SOAP thread started
00:00:01.987847 SQW02    Processing connection from IP=10.0.10.251 socket=11 (0 out of 2 threads idle)
 
 
Can anyone help.. :)
 
Link to comment
9 hours ago, Maticks said:

I just install Virtualbox for the first time and set it up.

Downloaded and started it on port 8084.

when i go to the Webui i get this error.

That's normal AFAIK. I believe you are looking for phpVirtualBox, which needs to be installed and configured separately.

 

If you want to make sure the virtualbox part is working without dealing with phpVirtualBox, you will need to use the command line.

https://www.virtualbox.org/manual/ch08.html#idm3463

Link to comment

Managed to get phpVirtualBox working and some VM's setup.

They show up in the WebUI in Unraid but when i reboot Unraid it seems to wipe out the VirtualBox.xml file in /opt/VirtualBox on boot and defaults it back without the VM's in it.

Is there a reason it is wiping it out.

I am getting around it with copying the XML back into place and restarting the VirtualBox.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.