Jump to content
theone

VirtualBox Plugin for unRAID v5 and v6

778 posts in this topic Last Reply

Recommended Posts

How exactly do I get pphpVirtualBox on to unraid?

 

I have instructions at http://vbox.a1aina.com/install.php.

 

If using this plugin, you can skip the steps for the extension pack for VirtualBox & the tgz compiled package of VirtualBox.

 

There is a wiki page for phpvirtualbox at http://code.google.com/p/phpvirtualbox/w/list that lists some common errors with phpvirtualbox. If you have a problem with it that is not listed there, click the Issues tab link, click the dropdown box next to Search (which is default set to Open Issues) & change it to "All Issues" then use the next box to type part of your error message & click the Search button.

Share this post


Link to post

Ok I got phpVirtualBox on my unRAID server but I get this message when I log in.

 

PHP does not have the SOAP extension enabled.

 

Exception Object
(
    [message:protected] => PHP does not have the SOAP extension enabled.
    [string:Exception:private] => 
    [code:protected] => 32
    [file:protected] => /boot/webserver/web/lib/ajax.php
    [line:protected] => 128
    [trace:Exception:private] => Array
        (
        )

    [previous:Exception:private] => 
)

 

I am primarily a windows user and know next to nil about linux.  I have done a google search and from what I under stand is that I need to install php-soap.  The google.code forum had a post showing me how to install it but that was for another distro of linux.

 

Will anybody here be able to help me out?

Share this post


Link to post

sgibbers17, What do you see when you type:

php -i | grep Soap

 

If you do not see

   Soap Client 	enabled 
   Soap Server 	enabled

then you will need to edit your php.ini file (mine is located at /boot/config/plugins/sf_webserver/php/php.ini). Look for a line like this in the file:

;extension = soap.so

Remove the ; at the beginning of that line and restart your web server.

 

Found this from searching http://code.google.com/p/phpvirtualbox/issues/list?can=1&q=SOAP+extension+enabled&colspec=ID+Type+Status+Priority+Milestone+Owner+Summary&cells=tiles

Share this post


Link to post

Theone, Lainie

 

i have been looking around for another management app then phpvirtualbox but i can't seem to find one :(

i rather would not want to install an extra webserver on my unraid

so i was looking for something like vsphere client for vmware ....

i searched google but there seems to be nothing different out there that can manage and make guests on virtualbox

any apps you guys know about ?

 

 

Share this post


Link to post

Theone, Lainie

 

i have been looking around for another management app then phpvirtualbox but i can't seem to find one :(

i rather would not want to install an extra webserver on my unraid

so i was looking for something like vsphere client for vmware ....

i searched google but there seems to be nothing different out there that can manage and make guests on virtualbox

any apps you guys know about ?

 

I am not sure there is any other GUI for VirtualBox aside from phpvirtualbox... however everything can be done via command line. I use these commands to cron a startup & shutdown time of a VM that only needs to run some of the time. You can also do the entire creation and management of a VM from a command line.

 

Share this post


Link to post

Maybe some one can create a new plugin that manage/create/delete machines, like it's done from the command prompt (from the link on post above), then we have a new interface to our VM machines  ;D:D

 

//Peter

Share this post


Link to post

Maybe some one can create a new plugin that manage/create/delete machines, like it's done from the command prompt (from the link on post above), then we have a new interface to our VM machines  ;D:D

 

//Peter

What you are talking about is phpVirtualBox.

 

I have incorporated simple VM start and stop for individual VMs in my plugin.

 

Share this post


Link to post

No, a alternative to phpvirtualbox

 

What I meant was the developing what you wanted is not necessary because phpVirtualBox exists and works.

 

Starting to develop a plugin (or extension to my plugin) with the features you stated will end up with something like phpVirtualBox which already exists so why develop it?

 

Share this post


Link to post

Ok, I got phpvirtualbox up and running.  Now I am trying to get my first OS installed.  How do I get the Remote Display working?

 

This is what it reads under Display

 

Remote Desktop Server Port: (null):9000

 

When I try to remote desktop into the VM I get computer (null) cannot be found.  I assume that (null) should be a IP address.

Share this post


Link to post

 

via the phpVirtualBox interface you can set an RCP port and access it via your server IP:port.

Go to your Virtual Machnie settings -> Display -> Remote Display tab -> Enable Server

Choose appropriate port, authentication method etc. (chapter 7 "Remote virtual machines" from VirtualBox manual will clarify everything), then e.g. on Windows 7 look for Remote Desktop Connection programme and type [your.unRAID.IP.address]:[VMPortNumber] (look at the attached screenshot) and press Connect.

 

This did not work at first.

 

I am using Windows 8 and trying to install kubuntu onto my unraid virtualbox.

 

had to increase video memory.

Share this post


Link to post

New Version:

 

0.5.2 - Added Latest Release version available from VirtualBox.org (not necessarily existing for unRAID yet)

        - Local versions extraction

        - Cosmetic changes

Share this post


Link to post

After update it doesnt work.

 

I belive its a problem with new simplefearures 1.0.11.

 

Webserver plugin doesn't work. Log:

 

[08-Mar-2013 18:25:21 UTC] PHP Notice: Undefined variable: vm_run_cnt in /usr/local/emhttp/plugins/virtualbox/virtualbox.php on line 39

 

I notice this problem days ago but virtualbox worked fine (VMs). Not the phpadmin but I have all running and dont use it a lot.

 

Today I upgrade plugin and download to local 4.2.8. Ok to download but never install. I reboot and now i have no virtualbox installed. Log:

 

Mar 8 19:19:01 unraid rc.virtualbox[28576]: Installing Virtualbox package (v4.2.8)...

Mar 8 19:19:03 unraid rc.virtualbox[28744]: Symbolically linked /mnt/cache/Apps/virtualbox/vbox-files to /root/.VirtualBox

Mar 8 19:19:03 unraid rc.virtualbox[28745]: Installing Virtualbox Extension package (v4.2.8)...

Mar 8 19:19:03 unraid rc.virtualbox[28772]: VirtualBox and/or VirtualBox Extension not installed - cannot start vboxwebsrv

Mar 8 19:19:03 unraid rc.virtualbox[28798]: VirtualBox and/or VirtualBox Extension not installed - cannot start Virtual Machines

 

Maybe the problem is the diferent php version of new simplefeatures webserver?

 

Share this post


Link to post

After update it doesnt work.

 

I belive its a problem with new simplefearures 1.0.11.

 

Webserver plugin doesn't work. Log:

 

[08-Mar-2013 18:25:21 UTC] PHP Notice: Undefined variable: vm_run_cnt in /usr/local/emhttp/plugins/virtualbox/virtualbox.php on line 39

I notice this problem days ago but virtualbox worked fine (VMs). Not the phpadmin but I have all running and dont use it a lot.

 

Today I upgrade plugin and download to local 4.2.8. Ok to download but never install. I reboot and now i have no virtualbox installed. Log:

 

Mar 8 19:19:01 unraid rc.virtualbox[28576]: Installing Virtualbox package (v4.2....

Mar 8 19:19:03 unraid rc.virtualbox[28744]: Symbolically linked /mnt/cache/Apps/virtualbox/vbox-files to /root/.VirtualBox

Mar 8 19:19:03 unraid rc.virtualbox[28745]: Installing Virtualbox Extension package (v4.2....

Mar 8 19:19:03 unraid rc.virtualbox[28772]: VirtualBox and/or VirtualBox Extension not installed - cannot start vboxwebsrv

Mar 8 19:19:03 unraid rc.virtualbox[28798]: VirtualBox and/or VirtualBox Extension not installed - cannot start Virtual Machines

Maybe the problem is the diferent php version of new simplefeatures webserver?

384461800.153944.jpg.9b4bb904735460e9060568bae8eb1d06.jpg

Share this post


Link to post

I uninstall SF webserver (and reboot) and problem is still on. With previous update all was fine.

 

system.log

 

Mar 8 21:21:11 unraid rc.virtualbox[22187]: Latest VirtualBox (v4.2.8)/(k3.4.26) exists locally - no need to download

Mar 8 21:21:11 unraid rc.virtualbox[22188]: Latest VirtualBox Extension (v4.2.8) exists locally - no need to download

Mar 8 21:21:11 unraid rc.virtualbox[22189]: Installing VirtualBox packages during array mount ...

Mar 8 21:21:11 unraid rc.virtualbox[22215]: Installing Virtualbox package (v4.2.8)...

Mar 8 21:21:15 unraid rc.virtualbox[22381]: Symbolically linked /mnt/cache/Apps/virtualbox/vbox-files to /root/.VirtualBox

Mar 8 21:21:15 unraid rc.virtualbox[22382]: Installing Virtualbox Extension package (v4.2.8)...

Mar 8 21:21:15 unraid rc.virtualbox[22409]: VirtualBox and/or VirtualBox Extension not installed - cannot start vboxwebsrv

Mar 8 21:21:15 unraid rc.virtualbox[22435]: VirtualBox and/or VirtualBox Extension not installed - cannot start Virtual Machines

 

.

.

.

.

.

Mar 8 21:29:43 unraid rc.virtualbox[24848]: Installing Virtualbox package (v4.2.8)...

Mar 8 21:29:44 unraid rc.virtualbox[25013]: Symbolically linked /mnt/cache/Apps/virtualbox/vbox-files to /root/.VirtualBox

Mar 8 21:29:44 unraid rc.virtualbox[25014]: Installing Virtualbox Extension package (v4.2.8)...

Mar 8 21:33:30 unraid rc.virtualbox[25703]: Latest VirtualBox (v4.2.8)/(k3.4.26) and VirtualBox Extension (v4.2.8) exist in local plugin folder

Mar 8 21:33:30 unraid rc.virtualbox[25729]: Virtualbox not installed - nothing to stop

Mar 8 21:33:30 unraid rc.virtualbox[25730]: vboxwebsrv not running - nothing to stop

Mar 8 21:33:35 unraid rc.virtualbox[25766]: Installing Virtualbox package (v4.2.8)...

Mar 8 21:33:36 unraid rc.virtualbox[25932]: Symbolically linked /mnt/cache/Apps/virtualbox/vbox-files to /root/.VirtualBox

Mar 8 21:33:36 unraid rc.virtualbox[25933]: Installing Virtualbox Extension package (v4.2.8)...

Mar 8 21:33:36 unraid rc.virtualbox[25960]: VirtualBox and/or VirtualBox Extension not installed - cannot start vboxwebsrv

Mar 8 21:33:36 unraid rc.virtualbox[25986]: VirtualBox and/or VirtualBox Extension not installed - cannot start Virtual Machines

Mar 8 21:33:36 unraid rc.virtualbox[25987]: Updated VirtualBox to version 4.2.8

 

but not installed

 

----

vboxwebserver.log

 

VirtualBox web service 4.2.6 r82870 linux.x86 (Dec 19 2012 15:42:02) release log

00:00:00.001001 main    Log opened 2013-03-08T18:03:22.320501000Z

00:00:00.001007 main    OS Product: Linux

00:00:00.001010 main    OS Release: 3.4.26-unRAID

00:00:00.001014 main    OS Version: #2 SMP Mon Jan 28 17:00:22 PST 2013

00:00:00.001054 main    Host RAM: 3854MB total, 2367MB available

00:00:00.001060 main    Executable: /opt/VirtualBox/vboxwebsrv

00:00:00.001062 main    Process ID: 17213

00:00:00.001065 main    Package type: LINUX_32BITS_GENERIC

00:00:00.037681 SQPmp    Socket connection successful: host = 127.0.0.1, port = 18083, master socket = 12

 

 

VBoxSVC.log

 

VirtualBox XPCOM Server 4.2.6 r82870 linux.x86 (Dec 19 2012 15:42:02) release log

00:00:00.001043 main    Log opened 2013-03-08T18:14:53.831770000Z

00:00:00.001049 main    OS Product: Linux

00:00:00.001052 main    OS Release: 3.4.26-unRAID

00:00:00.001054 main    OS Version: #2 SMP Mon Jan 28 17:00:22 PST 2013

00:00:00.001088 main    Host RAM: 3854MB total, 2715MB available

00:00:00.001094 main    Executable: /opt/VirtualBox/VBoxSVC

00:00:00.001096 main    Process ID: 19408

00:00:00.001098 main    Package type: LINUX_32BITS_GENERIC

00:00:00.137554 nspr-2  Loading settings file "/root/.VirtualBox/VirtualBox.xml" with version "1.12-linux"

00:00:00.341121 nspr-2  Successfully initialised host USB using sysfs

00:00:00.343415 nspr-2  VDInit finished

00:00:00.345788 nspr-2  rtldrNativeLoad: dlopen('libasound.so.2', RTLD_NOW | RTLD_LOCAL) failed: libasound.so.2: cannot open shared object file: No such file or directory

00:00:00.347284 nspr-2  Loading settings file "/mnt/cache/Apps/virtualbox/Windows7-64/Windows7-64.vbox" with version "1.12-linux"

00:00:05.393270 main    ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={29989373-b111-4654-8493-2e1176cba890} aComponent={Medium} aText={Medium '/mnt/cache/Apps/virtualbox/Windows7-64/Windows 7 64.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false

00:00:05.495885 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={3b2f08eb-b810-4715-bee0-bb06b9880ad2} aComponent={VirtualBox} aText={The object is not ready}, preserve=false

 

 

 

Share this post


Link to post

 

more tests  :D

 

I delete VB packages in flash. Plugin download again and voila..... installed fine and works¡¡

 

 

 

 

Share this post


Link to post

 

more tests  :D

 

I delete VB packages in flash. Plugin download again and voila..... installed fine and works¡¡

 

According to your logs and what you described it seems that the packages (vbox and extension) were not installed properly probably due to a bad download of the packages.

If the download is done from the plugin WEBUI it is important not to interrupt it by refreshing the WEBUI - that kills the download and gives a partially downloaded package.

 

Share this post


Link to post

 

Yes. It seems I refresh UI.

 

Really lot of problems with UI freezes in last SF update, lets see if I keep it or move to base UI.

 

I cant solve the webserver issue but again this is not due to VB plugin. Webserver and phpvirtualbox work like a charm before last SF update.

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.