Jump to content
Sign in to follow this  

[SOLVED]unRAID under ESXi without USB key?

12 posts in this topic Last Reply

Recommended Posts

Is it at all possible to set up an unRAID VM without having physical USB stick (or emulate such)?


I'd like to set up another test VM with minimal unRAID version (which doesn't require a licence tied to USB drive).


I'm under the impression that unRAID expects USB to be there as its config files are stored  on USB itself.


Any workaround for this? At least we know bzroot and bzimage can be a part of VM.



Share this post

Link to post

Yes, you can setup the free version in a VM without a flash drive as long as you set the virtual disk volume name to "UNRAID". If it's named anything else the VM won't boot and you'll probably see a "waiting for USB subsystem" error repeating down the screen.


If that's the case just attach the VMDK as a second drive to another VM (i.e. Windows XP) and change the volume label to "UNRAID". Shutdown the VM and reattach the VMDK to your unRaid VM and it should boot just fine.


If you want to use the features of the Plus or Pro version you will need the USB flash key installed with the license in the config folder. In that case the flash key volume must be named "UNRAID" with the VMDK volume named anything else. This will make a hybrid boot (which is very fast BTW). After it boots from the VMDK it will find the "UNRAID" volume on the flash key and use the license/config files from there. In fact the only thing you need on the flash key is the config folder. All the other stock files can reside on the VMDK.

Share this post

Link to post

Did I understand your advice correctly?


-created new unRAID VM with two virtual disks:

first 4GB labeled whatever containing all *.zip contents except for 'config' directory

2nd 1GB labeled UNRAID containing just 'config' dir


both disks formatted as FAT32 and first one made bootable from windows by running .bat file


unRAID boots from disk1, but at some point complains that UNRAID disk can't be located: "waiing for /dev/disk/by-label/UNRAID"


It also didn't work when I had one virtual disk called UNRAID with all the files and dirs from *.zip.


I got something wrong  :(

Share this post

Link to post

You only need the one disk not two. It's volume label should be UNRAID. All files, including 'config' dir, should be on that one disk.

As long as the volume label is UNRAID there won't be any complaints from the system.


There's probably a bunch of ways to do it but I just setup a second drive on a Win XP VM. I only made it 512 megs since my datastore is low on space and I don't use any unRaid plugins. Install unRaid to that second drive following the same method you would for a USB install. The only difference is you'd edit the .bat file to include the -f option when making the disk bootable.


In VSphere, edit the unRaid settings and remove the hard drive(s) associated. Then Add a new hard drive but tell it to use an existing drive, browse to the VMDK you just installed unRaid on.


You can copy/move the VMDK to the unRaid VM folder beforehand using the datastore browser or just leave it in the WinXP VM folder. If you leave it be sure to detach it from the XP VM so only one VM is accessing it at a time. It will be named something like Windows XP_1.vmdk. You can't change the name, I didn't care.


You probably could create the drive in the unRaid VM first which would give it a name associated with unRaid. Then attach it to the XP VM to do the install followed but reattaching it to the unRaid VM. If I were to do it again I'd try doing it this way.


Boot the unRaid VM.


Share this post

Link to post

//You only need the one disk not two. It's volume label should be UNRAID. All files, including 'config' dir, should be on that one disk.

//As long as the volume label is UNRAID there won't be any complaints from the system.


Hmm,this doesn't work for me (5.0rc11).

I tried a few times, volume inside virtual disk is surely called UNRAID.


I use "hybrid solution" for production unRAID BTW and that works great.


Share this post

Link to post

Sorry I can't be much more help without seeing how you're setting things up.

Last time I did this was with 5rc8a but can't imagine rc11 would be any different. Later tonight I'll do a test with rc11 to see how it behaves.

Share this post

Link to post

I've done this as well, after my pending meeting at work I'll look up what I did.  I think I remember having to fool around with making the boot disk an IDE disk rather than SCSI/SAS.

Share this post

Link to post

Correct. I just ran several tests with different configurations and it seems that the VMDK you install unRaid on must be IDE.


When setting up an unRaid VM the only option for drive creation is SCSI. Installing to that drive gives the 'waiting for /dev/disk/by-label/UNRAID' error after booting.


Creating an IDE drive under Windows XP works fine with rc11.

Share this post

Link to post
Posted (edited)

I've followed your instructions but unRAID is "unable to connect to localhost" after it loads:


1. install unRAID on a virtual hard drive

  • I created a new IDE hard drive for an existing "Win 8.1 Pro"-VM with 1 GB size stored into a single file named "unraid_test.vdmk"
  • within Windows I created a new FAT32 partition named "UNRAID"
  • I copied all unraid files to this partition
  • I executed "make_bootable.bat" (the f option was already included)


2. start unRAID from virtual hard drive

  • I created a new VM named "unraid test" with os "Other Linux 4.x or later kernel 64-bit"
  • I used virtual disk type "IDE" and used the existing virtual disk file "unraid_test.vdmk"
  • I started the VM and selected to boot in "unraid OS GUI mode"
  • within the booting procedure it showed the following messages:
waiting for /dev/disk/by-label/UNRAID (will check for 30 sec)....

after 8 seconds:
random: fast init done
random: crng init done
Cannot find device "bond0"


Then the login window appears. I login as "root" without password and it shows the firefox browser for the url "localhost" and saying:


Unable to connect

Firefox can't establish a connection to the server at localhost.

I went back to the Windows-VM in order to check if the label of the partition/volume is wrong but it is still "UNRAID".


Do you know what the problem is and how can I solve this?


Thanks in advance!

Edited by tardezyx

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this