Jump to content
Joe L.

unMENU 1.6 - now available (A major upgrade in appearance)

745 posts in this topic Last Reply

Recommended Posts

Cool!

 

What new apart from Skin?

As described earlier, 99% is the same (if not 99.9%)

 

Major change

1. New .css skinning capability and two new skins in addition to the "Classic" skin.

2. Three new buttons on user-scripts page to change between skins.

 

Minor changes in a few commands

1. On System-Info screen, "Memory Info" presents output of "free -l" instead of "free"

2. On System-Info screen, "Open Files" presents output of "lsof" instead of "lsof /dev/md*"

3. On Network and Disk performance screens, formatting fixed to deal with higher performance data rates.

4. On syslog view, newer definition file to prevent "sas: ata[0-9].*dev error handler" from being marked as an error.

5. On syslog view, newer definition added to prevent media file name in syslog with "*terror" in name from being flagged as an error.

6. PERL package has option added to NOT load MP3 library every time it starts from CPAN

 

Joe L.

 

Share this post


Link to post

I used to use it as a quick way to see what was being streamed via Plex, I'll just have to find another way. Thanks for all the hard work!

Download this file, un-zip it and put it (150-unmenu-lsof.cgi) in your unmenu directory.

It will add a tab on the main menu that works like the original command and it will be even more accessible.

It is basically a 4 line shell script (since it also looks in /mnt/cache, otherwise it would be 2 lines)

 

The "comments" at the top define the "tab label" and "url"

 

Have fun.  (unMENU was designed to be easily extended.)

 

Joe L.

 

Thanks a million!

Share this post


Link to post

Did a reinstall, cleared cache (twice!) but no dice. Some pages sometimes show the new layout, others always show the old ones.

Or do i have to remove the unmenu folder completely before re-installing, and do a reboot?

Share this post


Link to post

If i do an uninstall again i get:

 

root@UNRAID:/boot/unmenu# unmenu_install -u
Downloading myMain_local.conf
rev $Revision: 182 $ $Date: 2010-12-04 08:15:52 -0500 (Sat, 04 Dec 2010)$
5a0630afc49c196a23db71a5d02bf18f != a5d02879e3d52eb0dffda20f12d0111c or 7799da8e46bf08d7a328617cb1a48442,  /tmp/unmenu_tmp/myMain_local.conf not installed

Share this post


Link to post

Deleted everything again, new install again, still the same... the pages sometimes show the new design but mostly not.

And again, YES i did clear the browser cache....

Share this post


Link to post

Did a reinstall, cleared cache (twice!) but no dice. Some pages sometimes show the new layout, others always show the old ones.

Or do i have to remove the unmenu folder completely before re-installing, and do a reboot?

no, you do not have to remove anything.  It is normal for myMail_local.conf to not install if you have modified it.  (and you have, since it does not match the original checksum)  It would be up to you to migrate any changes if needed.

 

You must re-start unmenu for it to take effect. 

you can do that from the command line by typing

cd /boot/unmenu

killall awk

./uu

Or, you can do it from the user-scripts page using the button there.

Share this post


Link to post

Deleted everything again, new install again, still the same... the pages sometimes show the new design but mostly not.

And again, YES i did clear the browser cache....

Nowhere did I say to perform a re-install, or to delete everything.  (in fact, I never said to delete anything)  What made you go through those un-needed steps?

 

I simply said to use the button on the user-scripts page to check for updates, and subsequently install the updates and THEN to use the re-start unMENU button to re-start unMENU.

 

What I suspect has happened is that even though you've deleted the unmenu files you are still running the same old version since it is a running process that has not been re-started.

 

One of the pages will have the old style even after you upgrade, the FILE BROWSER.  It has not been converted.

 

Joe L.

Share this post


Link to post

ok got 1.6 installed.. use the user script to check for updates.. apply updates.. then user script to restart unmenu. cleared browser cache. all good.

some things i noticed that need updating.

 

first off, i do like the new menu and things look much nicer. liking the vertical menu.

 

  • the top left logo (lime tech) gets cut off when using the vertical menu
  • the 'myMain' logo doesnt go with the new skin.. prob should switch to a .png/gif for transparent background if you really want this to be skin friendly.
  • the 'buttons' throughout unmenu look just like the fieldset headers.. so its hard to know what REALLY is a button since it no longer looks like a button in the sense of how one acts..  also there are still some unskined buttons (array management - parity check, syslog page)
  • mymain config view.. logo hides save button
  • system info page -- the ' • Items in red are not installed on your system. ' items are not red.

 

also note, that the myMainLogo.jpg is hard coded in the .html myMain config pages.. doesnt use myMain.conf -- hmm doesnt seem like setting SetConstant(MYMAINLOGO does anything. looks like 07-unmenu-mymain.awk is responsible for overriding the logo.. :(

 

anyways, attached a quick gif version of myMainLogo.jpg (kept white outline) so that you could actually read the text on dark backgrounds... looks better than before but still think it could be better.

myMainLogo.gif.9b478f1887cd3e347572cd72524b645f.gif

Share this post


Link to post

Nowhere did I say to perform a re-install, or to delete everything.  (in fact, I never said to delete anything)  What made you go through those un-needed steps?

It says so on the google page you refer to:

 

If you already have an older unmenu version installed type

unmenu_install -u

 

And since that didnt seem to work i thought i just remove all and start all over.

 

Anyway, the killall awk stuff seems to do the trick. Maybe add that to the instructions.

Share this post


Link to post

ok got 1.6 installed.. use the user script to check for updates.. apply updates.. then user script to restart unmenu. cleared browser cache. all good.

some things i noticed that need updating.

 

first off, i do like the new menu and things look much nicer. liking the vertical menu.

 

the top left logo (lime tech) gets cut off when using the vertical menu

 

the 'myMain' logo doesnt go with the new skin.. prob should switch to a .png/gif for transparent background if you really want this to be skin friendly.

the 'buttons' throughout unmenu look just like the fieldset headers.. so its hard to know what REALLY is a button since it no longer looks like a button in the sense of how one acts.. also there are still some unskined buttons (array management - parity check, syslog page)

 

system info page -- the ' • Items in red are not installed on your system. ' items are not red.

I saw many of those things, and in fact had to deal with some of them in one way or another already.  The myMain logo goes completely to the top of the screen when in classic mode.  It needs to be fixed better so it works with all the skins.  I forced it to be a bit higher, but I'm sure my css skills are beginner level compared to many.    Originally it was being rendered so low it obscured the "refresh" images just below it.

 

Perhaps all the 'red" items it is referring to ARE installed on your system??  (or, as likely, the style sheet is overriding the color)

I agree, the fieldset legends now look like buttons, that should be changed (for one or the other)  That should not be too hard now, but they were the style put into place by mvdzwaan. Yes, the un-skinned buttons should have the appropriate class assigned.

 

In any case, I think it is a really great start and the only way to get people like yourself involved is to put the basic framework into place.  I saw how the lime-tech logo gets cut off, I figure it needs to have a width applied, or a local copy made smaller (I think it is being sourced from Tom's site, or at least I think that is what I remember seeing as I was merging in the code.) I actually like the local copy better, as many people have limited connectivity to the internet.

 

What I find fascinating is how little .css style directives needed to be added to existing code to impliment the vertical and horizontal styles.

 

All I can say is everybody with the skills should go for it, and submit any improvements you might make.  It is definitely easy enough to make changes to the source.  The basics are in place.

 

Joe L.

Share this post


Link to post

ok got 1.6 installed.. use the user script to check for updates.. apply updates.. then user script to restart unmenu. cleared browser cache. all good.

some things i noticed that need updating.

 

first off, i do like the new menu and things look much nicer. liking the vertical menu.

 

the top left logo (lime tech) gets cut off when using the vertical menu

 

the 'myMain' logo doesnt go with the new skin.. prob should switch to a .png/gif for transparent background if you really want this to be skin friendly.

the 'buttons' throughout unmenu look just like the fieldset headers.. so its hard to know what REALLY is a button since it no longer looks like a button in the sense of how one acts.. also there are still some unskined buttons (array management - parity check, syslog page)

 

system info page -- the ' • Items in red are not installed on your system. ' items are not red.

I saw many of those things, and in fact had to deal with some of them in one way or another already.  The myMain logo goes completely to the top of the screen when in classic mode.  It needs to be fixed better so it works with all the skins.  I forced it to be a bit higher, but I'm sure my css skills are beginner level compared to many.    Originally it was being rendered so low it obscured the "refresh" images just below it.

 

Perhaps all the 'red" items it is referring to ARE installed on your system??  (or, as likely, the style sheet is overriding the color)

I agree, the fieldset legends now look like buttons, that should be changed (for one or the other)  That should not be too hard now, but they were the style put into place by mvdzwaan. Yes, the un-skinned buttons should have the appropriate class assigned.

 

In any case, I think it is a really great start and the only way to get people like yourself involved is to put the basic framework into place.  I saw how the lime-tech logo gets cut off, I figure it needs to have a width applied, or a local copy made smaller (I think it is being sourced from Tom's site, or at least I think that is what I remember seeing as I was merging in the code.) I actually like the local copy better, as many people have limited connectivity to the internet.

 

What I find fascinating is how little .css style directives needed to be added to existing code to impliment the vertical and horizontal styles.

 

All I can say is everybody with the skills should go for it, and submit any improvements you might make.  It is definitely easy enough to make changes to the source.  The basics are in place.

 

Joe L.

 

yes the 'red' are the items i dont have installed.. for example the 'UPS status'.. I inspected the button but didnt see any class for it to specify its missing/should show red.. so most likely just something that was modified and left off.. would have to dig through the changes to see what

 

just uploaded myMainLogo.gif for you in the previous post if you wanna try that out.. if your going to just hard-code the image.. figure you prob should deff use one with transparent background or restore the ability for those to set their own image per the .conf

Share this post


Link to post

Anyway, the killall awk stuff seems to do the trick. Maybe add that to the instructions.

On that same google.code page it says:

If you had a prior version of unMENU running, you'll need to restart it to see the new version.

This will typically do it:

killall awk

/boot/unmenu/uu

Share this post


Link to post

just uploaded myMainLogo.gif for you in the previous post if you wanna try that out.. if your going to just hard-code the image.. figure you prob should deff use one with transparent background or restore the ability for those to set their own image per the .conf

You can see the changes here for 07-unmenu-mymain.awk:

http://code.google.com/p/unraid-unmenu/source/diff?spec=svn262&r=262&format=side&path=/trunk/07-unmenu-mymain.awk

Share this post


Link to post

just uploaded myMainLogo.gif for you in the previous post if you wanna try that out.. if your going to just hard-code the image.. figure you prob should deff use one with transparent background or restore the ability for those to set their own image per the .conf

You can see the changes here for 07-unmenu-mymain.awk:

http://code.google.com/p/unraid-unmenu/source/diff?spec=svn262&r=262&format=side&path=/trunk/07-unmenu-mymain.awk

 

the sys_info page is the one that isnt applying the 'db' class to the buttons that arent installed.. for example 'UPS Status' in my case. Looked at the 1.6 diff.. I dont see why this would stop working...

      if (system("test -f " file_to_check )!=0) {

unless its because I dont have PERL installed anymore.. which is needed to check if the commands work or not...

Share this post


Link to post

sharing myServer.png I just made of my unraid box. nexus prominent 9 w/three norco ss-500 cages installed. in case anyone happens to have the same setup (having to post link since forums limits attachments to under 192kb) - transparent background, so it looks nice and clean with unmenu 1.6

 

http://s10.postimg.org/5aefm63vt/my_Server.png

 

Share this post


Link to post

well to 'fix' the vertical menu I made the quick adjustment to the css to shift the logo a little to the left and the menu to the right.. this centers the top logo while still using the same 160px width,

 

#topArea {
  background-position: -8px 0;
  padding-left: 4px;
}

 

removed the padding-left line from #topMenu or do:

#topMenu {
  padding-left: 0;
}

 

not sure what this would do to the horz menu though.. but figured I'd share in case you wanted to go test

 

update: i see that each has its own css. so no worries.. yeah theres a ton of css and html that could be optimized. also i noticed that you now use jquery (which you pull down from google cdn) which looks like its only really needed for one js call.. that js could just be rewritten to not require an external js framework let alone one from an outside source.. anyways im off to lunch but ill take a look at this when i get back

unmenu1.png.13ac335e42f4462c482c3e5b52d43fb7.png

Share this post


Link to post

well to 'fix' the vertical menu I made the quick adjustment to the css to shift the logo a little to the left and the menu to the right.. this centers the top logo while still using the same 160px width,

 

#topArea {
  background-position: -8px 0;
  padding-left: 4px;
}

removed the padding-left line from #topMenu or do:

#topMenu {
  padding-left: 0;
}

 

not sure what this would do to the horz menu though.. but figured I'd share in case you wanted to go test

 

update: i see that each has its own css. so no worries.. yeah theres a ton of css and html that could be optimized. also i noticed that you now use jquery (which you pull down from google cdn) which looks like its only really needed for one js call.. that js could just be rewritten to not require an external js framework let alone one from an outside source.. anyways im off to lunch but ill take a look at this when i get back

That looks good.

Should have absolutely no affect on the horiz skin, as it uses a different .css file.

 

The jquery framework was also just added as part of this recent change, not sure of where (or what ) mzvdwaan was intending for it, so I left it for now.

 

Thanks.

 

Share this post


Link to post

alright, try out this unmenu_vertical and see if you like this a bit better. (had to attach as .txt as .css is not allowed)

 

noteable changes:

 

  • includes normalize.css (type of css reset) so that all browsers will look the same -- minified file since we shouldn't be changing this
  • removed the whole absolute positioning for the legend and just let it use padding where it should, fixes numerous issues of the legend getting in the way of other form elements
  • many tweaks and adjustments to padding to be a little more consistent with things, still a bit of stuff that can be done here but for now its a bit better imho
  • tweaked the array status to be a little more readable (spacing / padding / tweaked the table a little bit as well.. should make the '% Used' center not right align.. since the content text is aligned in the middle
  • removed the 'button' css for now and revert to the built in browser look and feel.. since the 1.6 css destroys the usability of buttons with regards to disabled state / hover / button states..  also there was a bit of buttons/inputs missed.. can come back to this but for right now i think its best to just undo it
  • optimized a bit of the css / order by page importance (used twitter recess)

 

now that this is much better shape, still i think we should include the network/disk performance css in the css along with the misc inline css thats sprinkled throughout unmenu to reduce css classes/make it easier to change globally

 

attached ss of default unmenu homepage with this css loaded

unmenu_vertical.txt

unmenu2.png.529299c6543eeebe5cf4fafa910690f0.png

Share this post


Link to post

alright, try out this unmenu_vertical and see if you like this a bit better. (had to attach as .txt as .css is not allowed)

I do like it better. 

noteable changes:

 

  • includes normalize.css (type of css reset) so that all browsers will look the same -- minified file since we shouldn't be changing this
  • removed the whole absolute positioning for the legend and just let it use padding where it should, fixes numerous issues of the legend getting in the way of other form elements
  • many tweaks and adjustments to padding to be a little more consistent with things, still a bit of stuff that can be done here but for now its a bit better imho
  • tweaked the array status to be a little more readable (spacing / padding / tweaked the table a little bit as well.. should make the '% Used' center not right align.. since the content text is aligned in the middle
  • removed the 'button' css for now and revert to the built in browser look and feel.. since the 1.6 css destroys the usability of buttons with regards to disabled state / hover / button states..  also there was a bit of buttons/inputs missed.. can come back to this but for right now i think its best to just undo it
  • optimized a bit of the css / order by page importance (used twitter recess)

 

now that this is much better shape, still i think we should include the network/disk performance css in the css along with the misc inline css thats sprinkled throughout unmenu to reduce css classes/make it easier to change globally

I agree, the css class definitions are better in one spot now.

attached ss of default unmenu homepage with this css loaded

Looks really polished, way better than stock management interface.  Giving simpleFeatures a run for the money.  ;)

 

I uploaded it to google.code... 

 

Joe L.

Share this post


Link to post

alright, try out this unmenu_vertical and see if you like this a bit better. (had to attach as .txt as .css is not allowed)

I do like it better. 

noteable changes:

 

  • includes normalize.css (type of css reset) so that all browsers will look the same -- minified file since we shouldn't be changing this
  • removed the whole absolute positioning for the legend and just let it use padding where it should, fixes numerous issues of the legend getting in the way of other form elements
  • many tweaks and adjustments to padding to be a little more consistent with things, still a bit of stuff that can be done here but for now its a bit better imho
  • tweaked the array status to be a little more readable (spacing / padding / tweaked the table a little bit as well.. should make the '% Used' center not right align.. since the content text is aligned in the middle
  • removed the 'button' css for now and revert to the built in browser look and feel.. since the 1.6 css destroys the usability of buttons with regards to disabled state / hover / button states..  also there was a bit of buttons/inputs missed.. can come back to this but for right now i think its best to just undo it
  • optimized a bit of the css / order by page importance (used twitter recess)

 

now that this is much better shape, still i think we should include the network/disk performance css in the css along with the misc inline css thats sprinkled throughout unmenu to reduce css classes/make it easier to change globally

I agree, the css class definitions are better in one spot now.

attached ss of default unmenu homepage with this css loaded

Looks really polished, way better than stock management interface.  Giving simpleFeatures a run for the money.  ;)

 

Joe L.

 

Nice work, I like the colour scheme...  ;D  something something form of flattery something....

 

Mind, never made any money off simpleFeatures!! If you want some help with refining the CSS feel free to give me a bell.

Share this post


Link to post

 

I like the new look.  However, the menu links are not really links anymore - meaning I can't right click on them to open in a new window.

Share this post


Link to post

Anyway, the killall awk stuff seems to do the trick. Maybe add that to the instructions.

On that same google.code page it says:

If you had a prior version of unMENU running, you'll need to restart it to see the new version.

This will typically do it:

killall awk

/boot/unmenu/uu

True... serious case of PEBKAC i guess. Need more coffee.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.