[Solved] Permissions issues w/ public share


5 posts in this topic Last Reply

Recommended Posts

Upgraded to Unraid 5.0 rc12b from 4.7 and followed the migration guide.  All went fine per the guide and I ran the new permissions utility.

 

Today, I noticed I could not delete files.  From my Windows 7 machine I try to delete and get: "You need permission to perform this action."  Next line reads: "You require permission from TOWER\nobody to make changes to this file"

 

Things I know or have tried:

 

- Have run New Permissions script 10+ times

- My user shares are set to Public

- I checked that I had no stored credentials in my Windows 7 machine. 

- I also rebooted my Windows 7 machine as well as Unraid, but this did not help at all.

- Tried resetting share.cfg and disk.cfg taking the 5.0 rc12b version)

- Confirmed permissions on my user shares as shown in the attached picture.

 

Does someone have any ideas?  This occurs on all user shares.

current_permissions.png.93f5e34de2ce2ce57f2d6825aebe505a.png

Link to post

You seem to have covered most of the obvious bases.  It might be worth giving a screenshot of the share settings that correspond to the Linux permissions that you showed?

 

Thanks for the reply - so after all of that, now randomly it started working (no reboot of either system).  I'll just keep an eye on it I guess.  Maybe write a quick script to run on my Windows 7 machine to testing creating, modifying, and deleting a file from the shares and run that a few times a day just to see if the issue crops up again.

 

So odd...

Link to post
  • 1 month later...
  • 2 weeks later...

Same issue here with the required permission from TOWER\nobody message.

No changes. So strange.

I told the share to use the cache drive since seeing the issue so that I can write new files. But I'm still unable to edit or delete.

 

I've run the permissions script and checked via telnet. Permissions seem to be being set as the script is telling them.

 

Any suggestions for debugging and getting to the root of this? I'm fairly new to the unraid system.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.