[Solved] Transport endpoint is not connected after trying to remove .DS_Store

6 posts in this topic Last Reply

Recommended Posts

I hope I didn't just delete everything...


I ran the command


find /mnt/ -name \.DS_Store -exec rm -rf {} \;


to try to delete all the .DS_Store files and now I cannot access my shares... it looks like the files are there under /mnt/disk1/ and /mnt/disk2/ but when I try to cd to /mnt/user, I get

/bin/ls: cannot access user: Transport endpoint is not connected


Also, when I click on the folder icon in the unraid Shares browser, I get this message:

Warning: scandir(/usr/local/emhttp/mnt/user/Media): failed to open dir: Transport endpoint is not connected in /usr/local/emhttp/plugins/indexer/Browse.php on line 19 Warning: scandir(): (errno 107): Transport endpoint is not connected in /usr/local/emhttp/plugins/indexer/Browse.php on line 19 Warning: array_diff(): Argument #1 is not an array in /usr/local/emhttp/plugins/indexer/Browse.php on line 19 Warning: Invalid argument supplied for foreach() in /usr/local/emhttp/plugins/indexer/Browse.php on line 19


What did I do wrong? And more importantly, how do I fix this?


Please help me fix my mess!



Link to post

basically, stop the array and reboot.


The user-shared file-system crashed, so everything under /mnt/user is not accessible.


The data is still there however, on the actual disk file-systems.


Joe L.

Link to post

Thanks, Joe.


I had a hard time trying to get the array to stop and then shut down... I tried stopping the array from the main unraid GUI but that wasn't working. Then tried other stuff with the command line. And finally got it to shut down with the unmenu shutdown user script...


Anyways, once I rebooted, I tried the command again and got the Transport endpoint is not connected error again... :(


Is there a better way to get rid of all these Apple generated files? I have the DS_Store cleanup script installed but it doesn't seem to be running or working properly with the default settings.


Also, I did recently upgrade from 5.0beta6a (I believe) to the latest 5.0rc12a because the flash drive went bad. I was able to copy the config folder over to the new flash drive from the one that went bad. Could that be causing problems?


Thanks again!

Link to post

I also get the "Transport endpoint" error on any release higher than rc8a.


I do not run Plex (which others were pointing might be a culprit).


rc8a works for me fine... FYI. I have tried the solutions for increasing the ulimit (in GO file) to no avail.

Link to post

Stopping the array and rebooting does rectify the Transport endpoint error but it comes up again when I run the command to remove the irrelevant files.


So should I rename this thread to be Solved though the real problem, whatever's causing this case, isn't solved?


I've also noticed that I am getting permission issues when accessing through my Windows 7 machine but not when I do the same thing on my Mac... i.e. moving files, renaming files, etc. Any ideas?

Link to post

After running new permissions again and rebooting the unraid server as well as my client pc several times, it seems to be working properly again so far. I don't know what exactly got it to work again but here are some of the things I did:

Delete Windows credentials

Disconnect and remap network drives

Run New Permissions utility

Reboot unraid server

Reboot client machine


However, when I run the "find /mnt/ -name \.DS_Store -exec rm -rf {} \;" command, I am still getting the Transport endpoint not connected error and end up having to reboot the server. So I haven't found a way yet to get rid of all these Apple generated files.


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.