Jump to content
Mettbrot

unRaid sometimes does not find /dev/disk/by-label/UNRAID

11 posts in this topic Last Reply

Recommended Posts

Hi there,

 

sometimes I get those weird messages on the screen about unraid not finding the actual USB key it booted from. The only thing to to is to "powerdown" and turn it on again.

 

The USB is labeled UNRAID, this happens maybe 1 out of 5 times.

Foto.JPG.c4cae1e1fcb806fb6e9de8e37d30dd4d.JPG

syslog_label_mount.txt

Share this post


Link to post

I've seen several older small (128MB, 256MB) flash drives that have this problem a lot.

 

If that's not your issue, you could have a marginal USB port ... but I think it's far more likely it's the flash drive.

 

If you're running the free version of UnRAID, put it on another flash drive -- preferably a new, high-quality unit like the Cruzer Micro or a Kingston Data Traveler.    I suspect that will resolve the problem.

 

If you're using a paid version, you need to contact Limetech and ask Tom to switch your key to a new flash drive.    Buy the flash drive first -- install the basic (free) version of UnRAID, and boot to it, so you can capture the GUID, which Tom will need to issue a key.    Or just buy a pre-configured key from LimeTech.

 

Share this post


Link to post

I registered for the pro version.

The USB Port is on a PCI USB 2 controller card since the computer only has USB 1.

I just bought the drive 3 months ago, its a "4 GB Transcend JetFlash 300 black USB 2.0". Do you realy think a brand new USB drive fails that often?

 

Share this post


Link to post

This may be an issue with your add-in card.  Does it boot okay (obviously SLOWLY) on the built-in USB ports on the PC?

 

 

Share this post


Link to post

I would have to try it several times until it eventually failes. But I can do that - ahtough it takes a veeery long time  :o

What could I do about it when it was the card?

Is the syslog okay?

When the start failes - Can I try anything while the system is on? Some commands or something?

Share this post


Link to post

I'm not an expert at reading Linux syslogs, but I glanced through it and don't see anything that indicates a problem.

 

I'd try booting directly from the onboard USB ports ... if that works consistently, then you could just use that => except for the very slow boots, it shouldn't have any impact on the normal functioning of the array, as there's very little interaction with the flash drive while UnRAID is running.

 

IF that DOES prove to be the case, you could try a different add-in card.

 

Share this post


Link to post

The Motherboard is from MSI and is called MS-6583.

 

That must be an old or custom motherboard. I can't find anything on it.

Check the bios if you have legacy USB support enabled.

 

If it boots reliably from the motherboard port, I might consider that a good thing for the lifetime left on the board.

 

I also might try another Flash drive to see how it reacts.

 

You can boot from a different flash drive as long as there are bios options that allow both, the booting and the registered, flash drives to be plugged in and accessible.

Make sure the registered flash drive is labeled with unRAID and anything else you use is not labeled that way. You would have to change the bios order to insure you are booting from what you expect.

 

Sometimes different speeds are used based on how the flash is created.

I.E. Floppy emulation, zip disk emulation, hard drive emulation.

 

To me ,speed wouldn't be that much of an issue unless I was developing, reboot often or I shutdown on a daily basis.

Share this post


Link to post

I was having the same errors on my SuperMicro board. I honestly don't know what fixed it. I know know Tom changed a timeout value in a later release and that helped, but it seemed to be more kernel related as the newer kernel worked.

 

My last Bios update for my board was over 5 years ago, so I'm tempted to think it's mobo related. These new boards are getting faster and faster and new OS's, sometimes I think they just don't work as well on the older hardware.

 

I also got a new flashdrive and did notice it was faster.

 

Sorry, I'm not more help.

Share this post


Link to post

As I noted above, the first thing to do is isolate whether or not it's an issue with the add-in USB card.

 

Just connect your UnRAID flash drive to the onboard USB port, and run it like that for a while.  The boots will obviously be slower ... but the question is whether or not they're more reliable.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.