Dynamix - Web GUI


1279 posts in this topic Last Reply

Recommended Posts

A little tutorial needed...

 

Im using the last version of simple features 1.0.11 and updated to 5.0.5 finally.

 

Can I ask how to safely upgrade to Dynamix without losing my plugins, especially mysql which hosts my "mysql xbmc database".

 

1) Do I just remove simple features from /boot/plugins and just follow this tutorial?

2) How do I restore my current plugins used etc?

Using Airvideo, Plex, plex updater, mysql, transmission.

 

Thanks  8)

Link to post
  • Replies 1.3k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

A little tutorial needed...

 

Im using the last version of simple features 1.0.11 and updated to 5.0.5 finally.

 

Can I ask how to safely upgrade to Dynamix without losing my plugins, especially mysql which hosts my "mysql xbmc database".

 

1) Do I just remove simple features from /boot/plugins and just follow this tutorial?

2) How do I restore my current plugins used etc?

Using Airvideo, Plex, plex updater, mysql, transmission.

 

Thanks  8)

See here:

http://lime-technology.com/forum/index.php?topic=28927.msg279478#msg279478

Simple Features COMPLETE Uninstall

Then install Dynamix.

There's a page of plugins fully supported by Dynamix builtin to the interface.

You can add "CONTROL PANEL IKOSA" PlugIn Manager for an added page of 'managed' plug-ins for more capabilities.

 

My "Control Panel" currently shows available AirVideo, Transmission, and two flavors of mySQL.  Plex and Plex Updater are installed like normal (and then show up nicely in Dynamix).

 


I always recommend backing up your flash to your PC frequently as you go along. That's a lot of changes and you may want to back up a step or two if something glitches. :)

Also, take a SCREENSHOT of your current drive assignments showing DRIVE SERIAL NUMBERS (as shown on the WebGUI page.) IN particular, if something goes wrong, you want to be positive you know which drive is CACHE and which is PARITY....all others are data. :)

Link to post
  • 2 weeks later...

How is the dynamix plugin sending out the mails? unraid doesn't come with sendmail or mail command and I want to email the output of a backup script. Is there any way to use dynamix mail daemon instead of installing another one?

Link to post

How is the dynamix plugin sending out the mails? unraid doesn't come with sendmail or mail command and I want to email the output of a backup script. Is there any way to use dynamix mail daemon instead of installing another one?

Yes, the one installed by Dynamix should work for you. That is how I got emails from my rsync script.
Link to post

And how do you use it from the command line? mail is not found, neither is sendmail.

excerpt from the script I mentioned:

echo -e "Subject: ### $(basename \"$0\") ###\n\nrsync finished successfully" | ssmtp -d root

Something similar should work for you. I am not using Dynamix now because I am on unRAID 6 but it worked for me when I was using Dynamix.

Link to post
  • 2 weeks later...

Server 62 days uptime. Dynamix and 5.0.5. Still no problems.

 

S3, Notifications, Temps, Dashboard, UPS, Cache dir, all running fine.

 

:D

 

Some news.

 

After 90 days and 17 hours uptime dynamix webgui freeze. Server is still up and running but no access via web. Shares works.

 

Edit: console powerdown didnt work, reboot neither so I use the hard button so there is no log in flash about the issue, only old logs.

 

 

 

Link to post

I just noticed in the screenshot it says 5.0.5, where as mine only mentions 5.0 and not 5.0.4. How would i fix this?

 

From your previous posts it looks like you're possibly running esxi, did you update your vmdk (assuming you're booting via that method), or just your USB drive? The vmdk has to be updated as that's what's booting unraid.

 

Sent from a mobile device, sorry for any typos.

 

 

Link to post

I just noticed in the screenshot it says 5.0.5, where as mine only mentions 5.0 and not 5.0.4. How would i fix this?

 

From your previous posts it looks like you're possibly running esxi, did you update your vmdk (assuming you're booting via that method), or just your USB drive? The vmdk has to be updated as that's what's booting unraid.

 

Sent from a mobile device, sorry for any typos.

 

Thanks, i had completely forgotten about that. Will make sure to update it.

Link to post
  • 2 weeks later...

@bonienl - i get an kernel panic with dynamix and unraid 5.0.5 on this hardware.

 

the server is clean, rams are definitely allright and i just installed openssh. but if i start to use the core of dynamix i get a panic while doing a parity check or just idling.

 

Board: MSI MS-7235 http://www.msi.com/product/mb/P965_Neo.html

Chipset: Intel® P965+ICH8

HDDs connected to: 4x Intel® ICH8 Chipset not the 1x JMicron JMB361

BIOS: latest possible Bios 1.11 with optimized Settings loaded http://www.msi.com/product/mb/P965_Neo.html#/?div=BIOS

CPU: Intel C2D 6600

RAM-test time: 3 rounds for 2x2GB DDR2 800, about 5-6h

 

i already started a thread with logs and screenshots (maybe you can also have a look there)

http://lime-technology.com/forum/index.php?topic=32899.0

 

hope you can help, thanks in advance

Link to post

@bonienl - i get an kernel panic with dynamix and unraid 5.0.5 on this hardware.

the server is clean, rams are definitely allright and i just installed openssh. but if i start to use the core of dynamix i get a panic while doing a parity check or just idling.

hope you can help, thanks in advance

 

Hello, I saw your other thread and while I don't use Dynamix something caught my eye in  your hardware list. It's the "optimized Settings loaded" phrase. unRAID usually does better when the settings are set to "default." Do you know what they are optimized for? Windows performance? Gaming?

 

You might want to try default BIOS settings. I should go back and look at your log. Good luck with the fix!!

Link to post

Hello,

 

I am currently using simpleFeatures with the web server enabled and ownCloud on top of that (unRAID 5.0.3). With the recent heartbleed attack having so much attention, I'd like to update my OpenSSL on the box to 1.0.1.g+ where the issue is fixed and switch to Dynamix as well.

 

It looks I can simply delete a couple directories (after backing them up of course) to rid of simpleFeatures then install Dynamix. Any idea how I can modify the Dynamix install to use the latest OpenSSL not vunerable to heartbleed?

 

Update:

I did the following:

[*]Deleted simpleFeatures from the box

[*]Added Dynamix to the box

[*]Pointed to my already existing ownCloud www root

[*]Enabled SSL only the dynamix.lighttpd.cfg, pointed at my certs, etc.

 

This left me non-vunerable to Heartbleed as I'm now using OpenSSL 0.9.8.x. I'd still like to update the OpenSSL libs to 1.0.1g but don't fully understand the .plg black magic for picking Slackware packages (They do have a 1.0.1g in slackware-current)

 

Can you provide more info on how you enabled SSL in lighttp? I can't get it to work with Owncloud and you seem to have gotten past that part.

Link to post

Thanks, I will try it

 

But i have ever test the 2.2.3 version and it does'nt work... Is it possible that older version can run ?

 

You are posting in the wrong thread.  Post in the thread for the version 6 Dynamix...

Link to post

New version 2.2.4 available.

 

See opening topic to view the changes.

 

People who have installed plugin control can update through the GUI.

 

Remember: this is for unRAID v5 only

Link to post
  • 2 weeks later...

So I have installed Dynamix and I get an error when loading up which reads: Could not open input file: plugins/WebGui/template.php

 

It may be because I'm using unraid 5.05 and it says only unraid V5, does that mean version 5.0 only?

Link to post

 

So I have installed Dynamix and I get an error when loading up which reads: Could not open input file: plugins/WebGui/template.php

 

It may be because I'm using unraid 5.05 and it sats only unraid V5, does that mean version 5.0 only?

 

I was having trouble also. Once I removed simple features and unMenu it's been up for 173 days. Not saying they are the culprit but I wasn't lasting 18 hours before.

 

If I had to guess it was SF and 5.0.5.

 

Currently running 5.0.5 - dynamix full addons - plex

 

"Only thing I hate about unRaid, it works so well I forget about it."

 

 

 

Sent from my iPhone using Tapatalk

Link to post

 

So I have installed Dynamix and I get an error when loading up which reads: Could not open input file: plugins/WebGui/template.php

 

It may be because I'm using unraid 5.05 and it sats only unraid V5, does that mean version 5.0 only?

 

I was having trouble also. Once I removed simple features and unMenu it's been up for 173 days. Not saying they are the culprit but I wasn't lasting 18 hours before.

 

If I had to guess it was SF and 5.0.5.

 

Currently running 5.0.5 - dynamix full addons - plex

 

"Only thing I hate about unRaid, it works so well I forget about it."

 

 

 

Sent from my iPhone using Tapatalk

Since Dynamix is intended to replace SimpleFeatures, you should definitely not have SimpleFeatures and Dynamix both installed. In fact, SimpleFeatures is no longer compatible with unRAID 5 so should not be installed in any case. It is unlikely that unMenu has anything to do with it since it is completely independent of the webGUI and I have never heard of it breaking anything.

 

Judging from megalodon's error it may have something to do with Limetech's enhanced webGUI. It should also not be used with Dynamix.

 

megalodon, post a complete syslog.

Link to post
  • Squid locked this topic
Guest
This topic is now closed to further replies.