Jump to content
aspik

X7SPA-HF-D525 and sleep S3

13 posts in this topic Last Reply

Recommended Posts

I recently put my first unraid server. Based on the SP X7SPA-HF-D525 board and latest unraid version. So far everything is working good, except the S3 state, I can't property wake up the system. I'm using the new Dynamix GUI instead of the stock unraid, no other plugins are installed except a few from dynamix and of course the S3 sleep plugin from dynamix.

After all disk spin down and the extra delay is reached the system is going to sleep, but after waking it up the GUI isn't reachable, shares are available. I waking it up from windows cmd with wolcmd.exe http://www.depicus.com/wake-on-lan/wake-on-lan-cmd.aspx typing the MAC and IP address from the unraid server (192.168.1.160) IPMI has a different IP (192.168.1.140). After the wake-up the IPMI View says wrongly: ACPI System Power State: S3 and power of, but the system is ON. I tried to waking it up from IPMI View with the Power Up button, after that IPMI View displays the ACPI state correctly, but still no unraid GUI, can't open the KVM Console too. The only thing I can do, is telnetting the system an execute the powerdown script...

I asked for help in the dynamix S3 sleep plugin forum section and @bonienl advised me that maybe the mb needs custom before sleep and/or after wake-up commands.

Unfortunately I couldn't find anything useful :-[ Can anyone help me how do I correctly put the system to sleep?

Share this post


Link to post

Hi again,

 

just for Info, if anyone has the same problem, I finally solve this one too!:) turns out that IPMI caused this issue... after turning it off I can wake up my server. I have also a guess why everyone with this board hadn't this problem, your all bought this board long time before I and have an older IPMI firmware. My is 2.66, on the Supermicro homepage is a new one 2.67, but i didn't check this out. I tried to contact Supermicro support for a changelog, but didn't become a answer.

So for everyone who newly bought this board and has WOL problems: make sure your disable the the BMC with the jumper 13!

Share this post


Link to post

Thanks for the info.  Interesting that IPMI has this side-effect => I'm a bit surprised, since you can access IPMI even if the system is off.

 

Share this post


Link to post

Hi gary,

 

I know that you can access the system with IPMI even when it's off, somehow during waking up it's "messing the wake up process...

I have to admit that I didn't come alone with the idea to disable IPMI, I found someone that have the same problem and solved it with disabling IPMI: http://forums.gentoo.org/viewtopic-t-954508-start-0.html

Unfortunately I didn't become an answer what firmware version he was using.

Share this post


Link to post

It'd be very interesting to know what version of IPMI firmware that guy was using -- but from his posts in the thread it's not clear he was every really using it (although it was apparently enabled until he tried disabling it and found that it fixed the problem).

 

One thing I'd try is to update your system to the latest firmware - just in case that was one of the fixes (probably not likely, but you never know).

 

The other thing you need to decide is whether the convenience of IPMI is worth the 16-18 watts or so that the board will draw if you simply don't put it to sleep  :)    [Mine idles at 19w ... I suspect the sleep current is probably 2-3 watts, so the "penalty" of not using S3 is likely ~ 16 watts]

 

Share this post


Link to post

Maybe a try again to connect him to make a respond.

I already tried to update to FW, but within IPMIView and that failed, if I correctly recall with an error message "connection refused". There are other options like DOS, but then i have to connect a display and keyboard to the server... Did you update the FW? How did you did that?

 

Yeah, I know that your board draws only 19W (I read a lot here i the forum before I buy this board ;)) but with my board I was never be able to get under 25W (Idle) don't known why...

 

About the not putting it to sleep, I know that many of your are running their servers 24/7, but for me, as I need it only max 7h a day, against 17h idle means that it would be draw more € in idle than in use, what is in my opinion very unfortunate ;)

Share this post


Link to post

My board isn't the "F" version ... it's just a  X7SPA-H-D525 (no IPMI)

 

I'm surprised there's that much difference in the idle power -- do you have an add-in card installed?    Or perhaps you're using a less-efficient power supply.

 

Share this post


Link to post

It could be a difference in the Kill-a-Watt meter calibrations ... although I've used two different units and always get 19-20 watts of idle power.

 

What drives do you have connected to the system?    Even spun-down hard drives still draw a small amount of power ... perhaps you're using drives that aren't quite as efficient as my WD Reds.

 

Share this post


Link to post

Now is my config in my sig:) As you can see there are no power consuming HDDs.

For the kill-a-watt meter, i use this version http://www.conrad.com/ce/en/product/125333/Basetech-COST-CONTROL-3000-LCD-000-999999-kWh- I know it isn't high end, but i think i should be enough for me.

I have been always wonder how did you get it under 20W, if in this review http://www.servethehome.com/supermicro-x7spehfd525-8gb-ddr3-ipmi-pfsense-freenas-unraid-linux-power-consumption/ it is also closer to my measurement.   

Share this post


Link to post

That review shows 23 watts on the D525 board with IPMI.  As I noted, my board doesn't have IPMI and I've got the video disabled.  I consistently measure 19-20 watts idle ... which seems consistent with the 23 watts they show.

 

It's also possible that there's a watt or so of calibration difference between my Kill-a-Watts and the meter you're using -- but not more than a watt.

 

Share this post


Link to post

OK, I will disable also video and measure it again with disabled IPMI and video. Do you have any other tips what can I also disable (tweak) to get the power draw lower?

Share this post


Link to post

No, I think that's about all you can do.    But if S3 sleep is working well for you, that's going to be the absolute lowest you can get ... it should be down to just a couple watts in S3

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.