Jump to content
speeding_ant

Margarita 1.7 - Native macOS Monitoring App and Share Automounts

233 posts in this topic Last Reply

Recommended Posts

Version 1.4 is current under review in the App Store. It includes automounting for shares, which I think is very cool considering it's a sandboxed app. There's no need for automounts or scripts anymore (something that is difficult to implement with 10.12 Sierra).

 

I believe I've resolved the editing server issue, which is under preview with TheMantis. This will make it to version 1.5.

 

Cheers!

Share this post


Link to post

Will the auto mount also re-mount shares as well? That is, if I stop the array of reboot the server, will the shares re-mount when they are once again online? That's the main reason I started using a script that keeps checking to see if the share is available/mounted.

Share this post


Link to post

Release notes:

 

- Ability to mount shares (AFP / SMB)

- Ability to auto mount shares based off the refresh frequency

      - Simply enable the automount checkbox, then mount a share.

      - Eject a share to disable the automount.

Share this post


Link to post

I'm working on setting this up now. The first thing I notice is that "flash" is missing from the list of shares. Is there any way I can add it? It is configured as a share on my unRaid machine and I can connect to it manually.

Share this post


Link to post

Disk commands also don't seem to be working. Tried spinup/spindown, nothing happens. Checked the log, but it has no entries at all regarding this. I attached a diagnostics file. Don't know if its useful or not.

 

Server commands are working though.

 

Resolved in next version.

Share this post


Link to post

I'm working on setting this up now. The first thing I notice is that "flash" is missing from the list of shares. Is there any way I can add it? It is configured as a share on my unRaid machine and I can connect to it manually.

 

I'm only going to allow mounting of 'User' shares, as dealing with disk shares (like Flash, disk1, etc) will get messy. They're always available in the Finder sidebar if required, and the SMB/AFP session will have been made by Margarita making mounting the disk shares easy.

Share this post


Link to post

This looks good, but a bit of a bug if your unRaid is on a non-standard port (like mine).

 

I can add the unraid server on port 8080 by adding the server with 10.0.1.2:8080

 

However, this seems to break the mount function, see image:

 

wUoWf_bIf_Z3sKJSJFMDW9cexd3biSGUHMNrp45tlac?size=2048x1536&size_mode=3

Share this post


Link to post

This looks good, but a bit of a bug if your unRaid is on a non-standard port (like mine).

 

I can add the unraid server on port 8080 by adding the server with 10.0.1.2:8080

 

However, this seems to break the mount function, see image:

 

wUoWf_bIf_Z3sKJSJFMDW9cexd3biSGUHMNrp45tlac?size=2048x1536&size_mode=3

 

Yeah good catch - I'll resolve that. Cheers!

Share this post


Link to post

The new auto mount feature is excellent.

 

For ages I've been suffering from mounts disappearing from the Finder Sidebar. If I connect directly via Go->Connect To Server it works fine. If I restart the service on UnRaid it reappears in the finder sidebar. Hopefully your auto mount will solve this.

 

Can are ask if you would consider allowing protocol to be specified on a mount by mount basis? I use Unraid for my Time Machine backup, which has to be over AFP. Everything else is via SMB. The AFP mount also drops, meaning Time Machine fails. Being able to choose the protocol (or a special setting for keeping the time machine mount alive) would be great.

Share this post


Link to post

I don't think I'll implement that feature, mainly because 10.12 will officially support SMB for TimeMachine (and therefore should hopefully fix your issues)!

 

I may have another solution in the works if it's absolutely necessary though.

 

Cheers!

Share this post


Link to post

I don't think I'll implement that feature, mainly because 10.12 will officially support SMB for TimeMachine (and therefore should hopefully fix your issues)!

 

I may have another solution in the works if it's absolutely necessary though.

 

Cheers!

ah, I didn't know 10.12 supported time machine over smb. Excellent.

Share this post


Link to post

If I were to integrate support for the inbuilt unRAID notifications in version 6.0, would you like it to replicate the webGUI functionality via the OS notification centre? Example, shows an alert that stays visible until you 'Archive' it. Archiving it will remove the notification from the webGUI (like you pressed the 'x' in the webGUI).

 

Screen_Shot_2016-09-17_at_9_04.50_PM.png.2e74e4a0633b60a3ff7c548ae2ecb700.png

Share this post


Link to post

I like that, It would give a better chance of seeing higher priority notifications. I sometimes miss the email ones coming through when I'm busy at work. I have a slight panic attack when I look back at them later and see a UPS warning came in.

 

Not to mention, unRaid has been so rock solid for the last few years that only the "PASS" email comes through.

 

I'm sure whatever you decide will work for us though. If not someone will tell you.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post

Would you want only warning and above alerts (not notice)? Curren't it's set to show all alerts that you set to display in the browser.

 

IMO i like them all.

 

Docker Image Alerts come across as a notice I believe.

 

Even though it's overkill, I like knowing everything that's going on.

 

I even like being notified of app updates in case there is a problem I can remember/recall that that app updated very recently.

 

Strictly my opinion though.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post

Can you maybe explain this. Giving me that error when I hit the mount button. Tried unmounting everything and starting over. Tried restarting mac.

 

The disk area button says "Mount" and not "Eject" like my unRaid share.

Screen_Shot_2016-09-18_at_7_16.46_PM.png.e087bf261d51fe5fb73172273b04f067.png

Share this post


Link to post

Interesting. Can you please go to directory: ~/Library/Containers/nz.co.pixeleyes.Margarita/Data/Library/Application Support/Margarita/Mounts

 

Let me know what's in it.

 

Cheers

Share this post


Link to post

OK - it's definitely a stale mount, so Libraries must be mounted via another means (ie, Finder).

 

Please remove that folder. I'll add some code in to remove stale mounts if they are empty, and will make the error message more verbose if it's not.

 

Cheers.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.