Jump to content
PhAzE

[PhAzE] Plugins for Unraid 5/6

3606 posts in this topic Last Reply

Recommended Posts

 

I'll need a few fork URL examples to verify the layout is similar but I do plan on adding that

 

This is a highly popular fork nowadays

https://github.com/echel0n/SickRage

Mr orange has stopped developing so now this guy has taken over development of his awesome fork.

 

 

Sent from my SM-N9005 using Tapatalk

 

Would not call it awesome yet

been running it in a vm for a few days and there are still a lot of issues with it

lot of database errors

like editing the whole database for a new path doesn't work and it is slow to not responding sometimes when searching for new shows already on the hdd ...

Share this post


Link to post

Well since you just released Mylar, thanks for that and again for all your work on these, I'd like to put a vote in for an updated Screen plugin. From what I can see after doing a search, it looks like the only one anyone released is way out of date. Or even a plugin for the Sickbeard Anime fork, but I'm not sure who here also downloads Anime like me so I may be just a minority and might be just a pipe dream. :)

 

Also a question for anyone that might know. I had an issue yesterday where when I took down my system to update the Influenzer plugins I had to Phaze's my WebGUI became unresponsive and I couldn't get it to work. It finally decided to start behaving itself earlier when I got home and tried again, and is currently running a parity check. I'd like to get my plugins up and running, but was curious. As I was glancing through my flash drive to figure out what might have caused the non-responsive WebGUI issue I noticed a package directory that doesn't look like it exists in the original 5.0.5 zip file I have. In the directory I see a lot of .txz  and .gz files which I assume are packages downloaded by the various plugins I've used, but I also see multiple versions of some of the files like python 2.6.6 and 2.7.3 and openssl 0.9.8r and 1.0.1g and mono 2.10.8.1 and 3.4.0 and I'm wondering if upon reboot the system tries to install each version and that might be a possible cause to what happened. Any idea? Would it also be prudent to just clear out all of the files and just have them re-downloaded again when the plugins run? Thanks.

Share this post


Link to post

Your system should only be installing the files that the plugins tell unRAID to install. All the other ones will be ignored. You could make a copy of your packages folder to another computer and then deleted it from your flash drive and restart your server. UnRAID will only install the plugins that it is told to. Then check and make sure you do not have multiple versions trying to install on every reboot. If you do then that may be causing problems for you.

Share this post


Link to post

PhAsE,

 

When you get transmission and flexget up let me know, I'll be happy to test.  Also, it's about time you put up a donation link so we can shout you a beer or two.

Share this post


Link to post

don't know what happened, I installed the plex plugin and when I go to the webpage port I am getting this

 

This XML file does not appear to have any style information associated with it. The document tree is shown below.

<MediaContainer size="11" friendlyName="Tower" machineIdentifier="38d5d0fda60858644b40b7cefa278ed8c4333831" myPlex="1" myPlexMappingState="unknown" myPlexSigninState="unknown" myPlexSubscription="0" myPlexUsername="" platform="Linux" platformVersion=" (#13 SMP Thu Jan 30 20:56:49 PST 2014)" requestParametersInCookie="1" sync="1" transcoderActiveVideoSessions="0" transcoderAudio="1" transcoderVideo="1" transcoderVideoBitrates="64,96,208,320,720,1500,2000,3000,4000,8000,10000,12000,20000" transcoderVideoQualities="0,1,2,3,4,5,6,7,8,9,10,11,12" transcoderVideoResolutions="128,128,160,240,320,480,768,720,720,1080,1080,1080,1080" updatedAt="1400413975" version="0.9.9.7.429-f80a8d6">

<Directory count="1" key="butler" title="butler"/>

<Directory count="1" key="channels" title="channels"/>

<Directory count="1" key="clients" title="clients"/>

<Directory count="1" key="library" title="library"/>

<Directory count="1" key="playQueues" title="playQueues"/>

<Directory count="1" key="player" title="player"/>

<Directory count="1" key="playlists" title="playlists"/>

<Directory count="1" key="search" title="search"/>

<Directory count="1" key="servers" title="servers"/>

<Directory count="1" key="system" title="system"/>

<Directory count="1" key="transcode" title="transcode"/>

</MediaContainer>

 

 

com.plexapp.system.log.txt

Share this post


Link to post

don't know what happened, I installed the plex plugin and when I go to the webpage port I am getting this

 

This XML file does not appear to have any style information associated with it. The document tree is shown below.

<MediaContainer size="11" friendlyName="Tower" machineIdentifier="38d5d0fda60858644b40b7cefa278ed8c4333831" myPlex="1" myPlexMappingState="unknown" myPlexSigninState="unknown" myPlexSubscription="0" myPlexUsername="" platform="Linux" platformVersion=" (#13 SMP Thu Jan 30 20:56:49 PST 2014)" requestParametersInCookie="1" sync="1" transcoderActiveVideoSessions="0" transcoderAudio="1" transcoderVideo="1" transcoderVideoBitrates="64,96,208,320,720,1500,2000,3000,4000,8000,10000,12000,20000" transcoderVideoQualities="0,1,2,3,4,5,6,7,8,9,10,11,12" transcoderVideoResolutions="128,128,160,240,320,480,768,720,720,1080,1080,1080,1080" updatedAt="1400413975" version="0.9.9.7.429-f80a8d6">

<Directory count="1" key="butler" title="butler"/>

<Directory count="1" key="channels" title="channels"/>

<Directory count="1" key="clients" title="clients"/>

<Directory count="1" key="library" title="library"/>

<Directory count="1" key="playQueues" title="playQueues"/>

<Directory count="1" key="player" title="player"/>

<Directory count="1" key="playlists" title="playlists"/>

<Directory count="1" key="search" title="search"/>

<Directory count="1" key="servers" title="servers"/>

<Directory count="1" key="system" title="system"/>

<Directory count="1" key="transcode" title="transcode"/>

</MediaContainer>

Can you tell me a few things, is this a fresh install or an upgrade from another plugin?  When you say "when I go to the webpage port" do you mean the settings page in the Unraid GUI, or is that ok and this shows when you go to the plex page http://tower:32400/web?  If that's not the address you are using to access plex go to the plugin settings and press the green "running" button, which will take you to the management interface for plex.  All of my plugins have that running button and it always incorporates the proper ports, https/http, and url base when required.

 

Also, which version of unraid are you using?

 

From reading on plex website, this happens if you forget to add /web at of the URL after the port.  It's actually (honestly) just lazy programming on the plex side, as they could have setup a redirect in their software to the proper URL. ;)

Share this post


Link to post

sorry you are correct I only inserted the tower:32400 address not the /web bit at the end...

However now the stock unraid web interface stopped loading and the syslog I see this line

 

May 18 12:47:14 Tower sudo:    root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; /usr/local/plexmediaserver/"Plex Media Server" --version

May 18 12:47:37 Tower sudo:    root : TTY=unknown ; PWD=/ ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; nohup /usr/local/plexmediaserver/"Plex Media Server" > /dev/null 2>&1 &

May 18 12:47:48 Tower sudo:    root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; /usr/local/plexmediaserver/"Plex Media Server" --version

May 18 12:48:35 Tower sudo:    root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; /usr/local/plexmediaserver/"Plex Media Server" --version

May 18 12:50:55 Tower sudo:    root : TTY=unknown ; PWD=/ ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; /mnt/cache/.plexmediaserver/"Plex Media Server" --version

May 18 12:50:59 Tower sudo:    root : TTY=unknown ; PWD=/ ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; nohup /mnt/cache/.plexmediaserver/"Plex Media Server" > /dev/null 2>&1 &

May 18 12:51:05 Tower sudo:    root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; /mnt/cache/.plexmediaserver/"Plex Media Server" --version

May 18 12:52:51 Tower sudo:    root : TTY=unknown ; PWD=/ ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; nohup /mnt/cache/.plexmediaserver/"Plex Media Server" > /dev/null 2>&1 &

May 18 12:52:57 Tower sudo:    root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; /mnt/cache/.plexmediaserver/"Plex Media Server" --version

May 18 14:04:13 Tower emhttp: emhttp_read_line: emhttp_read_line: input line too long

 

Share this post


Link to post

look with ps x in the terminal or while running top if there is a process called "du" running

 

if there is once that process is done the gui will respond again (in my case 30 minutes plus)

next time you start disable storage size

 

Share this post


Link to post

look with ps x in the terminal or while running top if there is a process called "du" running

 

if there is once that process is done the gui will respond again (in my case 30 minutes plus)

next time you start disable storage size

I'll set that to "no" as default in the next update.  Turning it off makes the plugin GUI more usable since DU is used to get size of the directory, however with a million little metadata files that plex makes, it can take forever in a large database. 

Share this post


Link to post

Plex plugin updated to 1.4.3

 

- Now has 'Show storage memory usage:" set to NO by default on new installs (I recommend you set yours to no also if you installed previous versions. Can be changed in the plugin GUI) As this will speed up the GUI loading and prevent DU from being run.

 

- Now capable of finding data.tar.gz or data.tar.xz files in the DEB file should plex start using the .xz extension in future releases. This is important to keep the install process functional if the file name changes in the deb.

Share this post


Link to post

Any ideas?

 

 

May 18 11:44:36 nas sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; /usr/local/plexmediaserver/"Plex Media Server" --version
May 18 11:44:36 nas kernel: Plex Media Serv[7977]: segfault at fffffffffffffff8 ip 00007f096449881b sp 00007fffa9991650 error 5 in libstdc++.so.6.0.18[7f09643df000+e4000]
May 18 11:44:45 nas sudo: root : TTY=unknown ; PWD=/ ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; nohup /usr/local/plexmediaserver/"Plex Media Server" > /dev/null 2>&1 &
May 18 11:44:45 nas kernel: Plex Media Serv[7988]: segfault at fffffffffffffff8 ip 00007ff44cbee81b sp 00007fffb01acb30 error 5 in libstdc++.so.6.0.18[7ff44cb35000+e4000]
May 18 11:44:59 nas sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=nobody ; COMMAND=/bin/bash -c . /boot/config/plugins/plexmediaserver/startcfg.sh; /usr/local/plexmediaserver/"Plex Media Server" --version
May 18 11:44:59 nas kernel: Plex Media Serv[8060]: segfault at fffffffffffffff8 ip 00007ff819ea781b sp 00007fffca91ce20 error 5 in libstdc++.so.6.0.18[7ff819dee000+e4000]

 

I also have a couple .dmp files in \\nas\cache\apps\Plex\Library\Plex Media Server\CrashReports

 

Share this post


Link to post

It does it with plexmediaserver_0.9.9.10.458-008ea34_amd64 as well.

Share this post


Link to post

Nevermind!  I changed it to run as root and all is good.

Share this post


Link to post

The segfault happens right after initial install. I call --version so that plex is initialized and it throws a segfault because the config folder doesn't have the proper Preferences.xml file.  When Plex throws this segfault, ti creates the necessary file that was missing.  It is intentional as I have no other way of getting plex to start with that Preferences.xml file since its unique to each server running plex, containing a unique PC ID number inside.  Because this number is unique to everyone's PC i can't just place a standard Preferences.xml file in the config folder as plex will refuse to start if that ID doesn't match its internal findings.

 

Because this only happens on a new install, you will see this after each reboot the first time the plugin runs, but I've hidden the error message from the console and plugin gui, it only shows in the system log now.  Unless someone else has a better way to get plex to create that xml file on first startup without it throwing a segfault, I can't get around that.

 

Most applications will actually just create the file on startup and continue, but plex actually crashes first round.

Share this post


Link to post

Nevermind!  I changed it to run as root and all is good.

Even as root, you should see that after a reboot again.

Share this post


Link to post

Nevermind!  I changed it to run as root and all is good.

Even as root, you should see that after a reboot again.

 

Thanks!  Plex wouldnt start either, so it seemed, to me, that it was related.  All looks good running as 'root'.

Share this post


Link to post

Not sure what I did wrong, but I just tried to install Sickbeard and SabNZBD and got a long string of errors for both.

 

These are the error lines for SabNZBD, Sickbeard looked to be the same.

Warning: simplexml_load_file(): ss="select-menu-modal-holder js-menu-content js-navigation-container" data-pjax  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:348: parser error : Opening and ending tag mismatch: input line 347 and div in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():         </div> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():               ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ' id='LC353'>           cd "$ORIG_LOC"</div><div class='line' id='LC354'>  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                         ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): LC353'>         cd "$ORIG_LOC"</div><div class='line' id='LC354'>   in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                       ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): >               cd "$ORIG_LOC"</div><div class='line' id='LC354'>    in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                             ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): "$ORIG_LOC"</div><div class='line' id='LC354'>     in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): $ORIG_LOC"</div><div class='line' id='LC354'>      in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): LOC"</div><div class='line' id='LC354'>       in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ot;</div><div class='line' id='LC354'>        in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): iv><div class='line' id='LC354'>         in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): }</div><div class='line' id='LC1382'>}</div><div class='line' id='LC1383'>  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2047: parser error : Entity 'hellip' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ejump-input js-jump-to-line-field" type="text" placeholder="Jump to line… in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2047: parser error : Specification mandate value for attribute autofocus in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  js-jump-to-line-field" type="text" placeholder="Jump to line…" autofocus in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2049: parser error : Opening and ending tag mismatch: input line 2047 and form in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():   </form> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():          ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2050: parser error : Opening and ending tag mismatch: form line 2046 and div in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): </div> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():       ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2079: parser error : Entity 'copy' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():       <li>© 2014 <span title="0.07157s from github-fe119-cp1-prd.iad.github in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                 ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2119: parser error : Opening and ending tag mismatch: div line 68 and body in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():   </body> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():          ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2120: parser error : Opening and ending tag mismatch: div line 60 and html in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): </html> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():        ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag body line 58 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag link line 26 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag link line 25 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag meta line 10 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag meta line 9 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag head line 8 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag html line 7 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13
xml parse error

Share this post


Link to post

Not sure what I did wrong, but I just tried to install Sickbeard and SabNZBD and got a long string of errors for both.

 

These are the error lines for SabNZBD, Sickbeard looked to be the same.

Warning: simplexml_load_file(): ss="select-menu-modal-holder js-menu-content js-navigation-container" data-pjax  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:348: parser error : Opening and ending tag mismatch: input line 347 and div in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():         </div> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():               ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ' id='LC353'>           cd "$ORIG_LOC"</div><div class='line' id='LC354'>  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                         ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): LC353'>         cd "$ORIG_LOC"</div><div class='line' id='LC354'>   in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                       ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): >               cd "$ORIG_LOC"</div><div class='line' id='LC354'>    in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                             ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): "$ORIG_LOC"</div><div class='line' id='LC354'>     in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): $ORIG_LOC"</div><div class='line' id='LC354'>      in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): LOC"</div><div class='line' id='LC354'>       in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ot;</div><div class='line' id='LC354'>        in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): iv><div class='line' id='LC354'>         in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): }</div><div class='line' id='LC1382'>}</div><div class='line' id='LC1383'>  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2047: parser error : Entity 'hellip' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ejump-input js-jump-to-line-field" type="text" placeholder="Jump to line… in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2047: parser error : Specification mandate value for attribute autofocus in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  js-jump-to-line-field" type="text" placeholder="Jump to line…" autofocus in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2049: parser error : Opening and ending tag mismatch: input line 2047 and form in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():   </form> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():          ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2050: parser error : Opening and ending tag mismatch: form line 2046 and div in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): </div> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():       ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2079: parser error : Entity 'copy' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():       <li>© 2014 <span title="0.07157s from github-fe119-cp1-prd.iad.github in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                 ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2119: parser error : Opening and ending tag mismatch: div line 68 and body in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():   </body> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():          ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2120: parser error : Opening and ending tag mismatch: div line 60 and html in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): </html> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():        ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag body line 58 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag link line 26 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag link line 25 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag meta line 10 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag meta line 9 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag head line 8 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag html line 7 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13
xml parse error

I'm not sure. I just donwloaded those and installed them just fine.  It's possible a bad download?  Perhaps try and redownload those two plugins from the first post, and on the USB/config/plugins folder remove the sabnzbd and sickbeard folders, then reboot.

Share this post


Link to post

Not sure what I did wrong, but I just tried to install Sickbeard and SabNZBD and got a long string of errors for both.

 

These are the error lines for SabNZBD, Sickbeard looked to be the same.

Warning: simplexml_load_file(): ss="select-menu-modal-holder js-menu-content js-navigation-container" data-pjax  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:348: parser error : Opening and ending tag mismatch: input line 347 and div in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():         </div> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():               ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ' id='LC353'>           cd "$ORIG_LOC"</div><div class='line' id='LC354'>  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                         ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): LC353'>         cd "$ORIG_LOC"</div><div class='line' id='LC354'>   in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                       ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): >               cd "$ORIG_LOC"</div><div class='line' id='LC354'>    in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                             ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): "$ORIG_LOC"</div><div class='line' id='LC354'>     in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): $ORIG_LOC"</div><div class='line' id='LC354'>      in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): LOC"</div><div class='line' id='LC354'>       in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ot;</div><div class='line' id='LC354'>        in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): iv><div class='line' id='LC354'>         in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2036: parser error : Entity 'nbsp' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): }</div><div class='line' id='LC1382'>}</div><div class='line' id='LC1383'>  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2047: parser error : Entity 'hellip' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ejump-input js-jump-to-line-field" type="text" placeholder="Jump to line… in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2047: parser error : Specification mandate value for attribute autofocus in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  js-jump-to-line-field" type="text" placeholder="Jump to line…" autofocus in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                                                                                ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2049: parser error : Opening and ending tag mismatch: input line 2047 and form in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():   </form> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():          ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2050: parser error : Opening and ending tag mismatch: form line 2046 and div in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): </div> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():       ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2079: parser error : Entity 'copy' not defined in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():       <li>© 2014 <span title="0.07157s from github-fe119-cp1-prd.iad.github in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():                 ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2119: parser error : Opening and ending tag mismatch: div line 68 and body in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():   </body> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():          ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2120: parser error : Opening and ending tag mismatch: div line 60 and html in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): </html> in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():        ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag body line 58 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag link line 26 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag link line 25 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag meta line 10 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag meta line 9 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag head line 8 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): /boot/config/plugins/sabnzbd.plg:2122: parser error : Premature end of data in tag html line 7 in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13
xml parse error

I'm not sure. I just donwloaded those and installed them just fine.  It's possible a bad download?  Perhaps try and redownload those two plugins from the first post, and on the USB/config/plugins folder remove the sabnzbd and sickbeard folders, then reboot.

Looks like you were right. I re-downloaded them straight to my flash drive and reran them and everything seemed to install fine. Thanks.

Share this post


Link to post

PhAsE,

 

When you get transmission and flexget up let me know, I'll be happy to test.  Also, it's about time you put up a donation link so we can shout you a beer or two.

I will get up a donation link this week, hopefully at the same time I release the transmission plugin. Made good progress on it today.

Share this post


Link to post

Hoping for some help again. I was preclearing a new drive the last few days so I wasn't able to reboot and test the plugins that I re-downloaded. It looks like both Sabnzbd and Sickbeard install correctly. I was able to configure and install them, however ran into a couple of issues.

 

First a minor issue. Sabnzbd installs and runs with no issue. The interesting part is that I configured the port to be 8081 and for whatever reason, the settings page wants to list the port as 8080. When I access Sab through my web browser accessing the address tower:8081 works, but for some weird reason the settings page will not change from 8080. Minor issue.

 

Secondly, the major issue. For some reason I cannot get Sickbeard to run. It looks to install correctly. The settings page looks to take and save the configuration correctly, but the application will not start no matter how many times I click the start button. I'll click start, a scripts runs, the page refreshes, but the status still reads Stopped. No response from tower:8082, so it does indeed look to be not running. I managed to get a quick grab of the script that ran, but other than that I'm unsure of the problem.

/etc/rc.d/rc.sickbeard buttonstart
Removing stale lock file from previous execution.
Starting Sick-Beard: sudo -u nobody python /usr/local/sickbeard/SickBeard.py --daemon --port 8082 --datadir /mnt/cache/AppData/sickbeard --pidfile /var/run/sickbeard/sickbeard.pid > /dev/null 2>&1

I've also rebooted multiple times and installed the plugin automatically when unRAID booted and also by deleting the plugin, rebooting, re-downloading the plugin, and manually installing. Issue occurs no mater the install method. Any clue as to what I'm doing wrong and what I can do to get this application up and running? Thanks.

 

Attached a copy of my cfg file incase that might help.

 

/usr/bin/tail -f /var/log/syslog
May 20 15:59:01 Tower last message repeated 3 times
May 20 16:00:24 Tower last message repeated 4 times
May 20 16:01:37 Tower last message repeated 5 times
May 20 16:02:00 Tower sudo: root : TTY=unknown ; PWD=/ ; USER=nobody ; COMMAND=/usr/bin/python /usr/local/sickbeard/SickBeard.py --daemon --port 8082 --datadir /mnt/cache/AppData/sickbeard --pidfile /var/run/sickbeard/sickbeard.pid > /dev/null 2>&1
May 20 16:05:21 Tower sudo: root : TTY=console ; PWD=/tmp ; USER=nobody ; COMMAND=/usr/bin/python -OO /usr/local/sabnzbd/SABnzbd.py -d -s 0.0.0.0:8081 --config-file /mnt/cache/AppData/sabnzbd --pidfile /var/run/sabnzbd/sabnzbd.pid
May 20 16:13:52 Tower sudo: root : TTY=unknown ; PWD=/ ; USER=nobody ; COMMAND=/usr/bin/python /usr/local/sickbeard/SickBeard.py --daemon --port 8082 --datadir /mnt/cache/AppData/sickbeard --pidfile /var/run/sickbeard/sickbeard.pid > /dev/null 2>&1
May 20 16:18:02 Tower sudo: root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/bin/python /usr/local/sickbeard/SickBeard.py --daemon --port 8082 --datadir /mnt/cache/AppData/sickbeard --pidfile /var/run/sickbeard/sickbeard.pid > /dev/null 2>&1
May 20 16:18:10 Tower sudo: root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/bin/python /usr/local/sickbeard/SickBeard.py --daemon --port 8082 --datadir /mnt/cache/AppData/sickbeard --pidfile /var/run/sickbeard/sickbeard.pid > /dev/null 2>&1
May 20 16:18:22 Tower sudo: root : TTY=unknown ; PWD=/ ; USER=nobody ; COMMAND=/usr/bin/python /usr/local/sickbeard/SickBeard.py --daemon --port 8082 --datadir /mnt/cache/AppData/sickbeard --pidfile /var/run/sickbeard/sickbeard.pid > /dev/null 2>&1
May 20 16:21:20 Tower sudo: root : TTY=unknown ; PWD=/ ; USER=nobody ; COMMAND=/usr/bin/python /usr/local/sickbeard/SickBeard.py --daemon --port 8082 --datadir /mnt/cache/AppData/sickbeard --pidfile /var/run/sickbeard/sickbeard.pid > /dev/null 2>&1

Forgot to add a copy of the syslog.

sickbeard.cfg

Share this post


Link to post

I will get up a donation link this week, hopefully at the same time I release the transmission plugin. Made good progress on it today.

 

Thanks, looking forward to both Transmission and Flexget

 

Hoping for some help again. I was preclearing a new drive the last few days so I wasn't able to reboot and test the plugins that I re-downloaded. It looks like both Sabnzbd and Sickbeard install correctly. I was able to configure and install them, however ran into a couple of issues.

 

Stab in the dark here but are you sure you only have one copy of the plugins in the directory and it's not trying to load both Phaze and Influencer plugins ?

Share this post


Link to post

I will get up a donation link this week, hopefully at the same time I release the transmission plugin. Made good progress on it today.

 

Thanks, looking forward to both Transmission and Flexget

 

Hoping for some help again. I was preclearing a new drive the last few days so I wasn't able to reboot and test the plugins that I re-downloaded. It looks like both Sabnzbd and Sickbeard install correctly. I was able to configure and install them, however ran into a couple of issues.

 

Stab in the dark here but are you sure you only have one copy of the plugins in the directory and it's not trying to load both Phaze and Influencer plugins ?

 

Yep. Currently only have Sabnzbd and Sickbeard plugins in the plugin directory. I deleted everything else just in case.

Share this post


Link to post

I would have a look at the dependencies that are downloaded and saved in your USB/packages folder. Might be one of them as a bad download or missing.

 

You can install sickbeard, then go to prompt and try to load it manually by going to the install directory and running python sickbeard.py and it will dump it's error in the prompt if it fails to load. Start there and see what the error says.

Share this post


Link to post

I would have a look at the dependencies that are downloaded and saved in your USB/packages folder. Might be one of them as a bad download or missing.

 

You can install sickbeard, then go to prompt and try to load it manually by going to the install directory and running python sickbeard.py and it will dump it's error in the prompt if it fails to load. Start there and see what the error says.

 

Cap of the process that occurred after I tried to manually run the application.

 

root@Tower:/usr/local/sickbeard# python SickBeard.py
Starting up Sick Beard master
Unable to find '/usr/local/sickbeard/config.ini' , all settings will be default!
22:49:49 INFO::MAIN :: Checking database structure...
22:49:49 INFO::MAIN :: Database upgrade required: Initial Schema
22:49:49 INFO::MAIN :: Checking database structure...
22:49:49 INFO::MAIN :: Database upgrade required: Initial Schema
22:49:49 INFO::MAIN :: Database upgrade required: Add Scene Exceptions
22:49:49 INFO::MAIN :: Database upgrade required: Add Scene Name Cache
22:49:49 INFO::MAIN :: No duplicate show, check passed
22:49:49 INFO::MAIN :: No duplicate episode, check passed
22:49:49 INFO::MAIN :: No orphan episodes, check passed
22:49:49 INFO::MAIN :: Starting Sick Beard on http://0.0.0.0:8081/
22:49:55 ERROR::MAIN :: Unable to start web server, is something else running on port: 8081
22:49:55 ERROR::MAIN :: Launching browser and exiting
Unable to start web server, is something else running on port: 8081

 

If I'm reading this correctly it's trying to setup 8081 as it's port, but I checked the sickbeard.cfg file and the port there is indeed pointing to 8082.

root@Tower:/usr/local/sickbeard# ls
CONTRIBUTING.md  autoProcessTV/  config.ini     init.solaris11  readme.md
COPYING.txt      cache/          data/          init.systemd    sickbeard/
Logs/            cache.db        init.fedora*   init.ubuntu*    sickbeard.db
SickBeard.py*    cherrypy/       init.freebsd*  lib/            tests/
root@Tower:/usr/local/sickbeard#

ls of the sickbeard directory. config.ini does exist.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now