Jump to content
PhAzE

[PhAzE] Plugins for Unraid 5/6

3606 posts in this topic Last Reply

Recommended Posts

I restarted my server because my power went out. I check my PhAzE plugin to make sure everything is running properly.

 

I'm running Sickbeard, Couchpotato, Sabnzbd, and Transmission. Everything is connected through my server and running fine except SABnzbd. I kept getting error "failed MD5 Checksum" everytime I'm trying to reinstall.

 

Anyone know a solution to this? I can't grab anymore media files without sabnzbd running. Please help and thanks in advance.

screncap.png.415bad55c1a13b2bfad0a37c44cb0f99.png

Share this post


Link to post

I'm getting this errors for Transmission (either automatically on startup or manual install)

 

2016-02-20 22:36:55 [iNFO] *** Install Initiated ***

2016-02-20 22:36:55 [iNFO] Installing Transmission...

2016-02-20 22:36:56 [iNFO] Updating dependencies

2016-02-20 22:36:56 [ERROR] Failed updating dependencies: Install file missing

2016-02-20 22:36:56 [iNFO] Updating export file

2016-02-20 22:36:56 [ERROR] Export update failed: Dependencies missing

2016-02-20 22:36:56 [ERROR] Install failed: Unable to update export file

 

I don't have issues for other plugins. Any idea why?

Share this post


Link to post

I'm getting this errors for Transmission (either automatically on startup or manual install)

 

2016-02-20 22:36:55 [iNFO] *** Install Initiated ***

2016-02-20 22:36:55 [iNFO] Installing Transmission...

2016-02-20 22:36:56 [iNFO] Updating dependencies

2016-02-20 22:36:56 [ERROR] Failed updating dependencies: Install file missing

2016-02-20 22:36:56 [iNFO] Updating export file

2016-02-20 22:36:56 [ERROR] Export update failed: Dependencies missing

2016-02-20 22:36:56 [ERROR] Install failed: Unable to update export file

 

I don't have issues for other plugins. Any idea why?

Go to /boot/config/plugins/Transmission and delete all the files in there except the .cfg file. Then reboot the server.

 

The dependency install file is hosted in github and the plugin probably failed to download it.

Share this post


Link to post

I restarted my server because my power went out. I check my PhAzE plugin to make sure everything is running properly.

 

I'm running Sickbeard, Couchpotato, Sabnzbd, and Transmission. Everything is connected through my server and running fine except SABnzbd. I kept getting error "failed MD5 Checksum" everytime I'm trying to reinstall.

 

Anyone know a solution to this? I can't grab anymore media files without sabnzbd running. Please help and thanks in advance.

I will look at this today.

Share this post


Link to post

I'm getting this errors for Transmission (either automatically on startup or manual install)

 

2016-02-20 22:36:55 [iNFO] *** Install Initiated ***

2016-02-20 22:36:55 [iNFO] Installing Transmission...

2016-02-20 22:36:56 [iNFO] Updating dependencies

2016-02-20 22:36:56 [ERROR] Failed updating dependencies: Install file missing

2016-02-20 22:36:56 [iNFO] Updating export file

2016-02-20 22:36:56 [ERROR] Export update failed: Dependencies missing

2016-02-20 22:36:56 [ERROR] Install failed: Unable to update export file

 

I don't have issues for other plugins. Any idea why?

Go to /boot/config/plugins/Transmission and delete all the files in there except the .cfg file. Then reboot the server.

 

The dependency install file is hosted in github and the plugin probably failed to download it.

 

Is it possible for me to do it without restarting the server? Like a Re-Download & Install option? I can do it manually as well (I have some stuff installed which I have to manually resetup again if I were to restart + downtime for other users)

Share this post


Link to post

Thank you, but it's weird, I downloaded both Transmission-PhAzE-Control-2.1.tar.gz and Transmission-PhAzE-Dependency-1.4_x86.tar.gz onto my flash\config\plugins\Transmission, clicked on Install, and it still gave me the same error

Share this post


Link to post

My apologies... I thought I had the x64 version.. stupid me. I'm too tired. Also made a small donation..thank you very much

Share this post


Link to post

I restarted my server because my power went out. I check my PhAzE plugin to make sure everything is running properly.

 

I'm running Sickbeard, Couchpotato, Sabnzbd, and Transmission. Everything is connected through my server and running fine except SABnzbd. I kept getting error "failed MD5 Checksum" everytime I'm trying to reinstall.

 

Anyone know a solution to this? I can't grab anymore media files without sabnzbd running. Please help and thanks in advance.

I will look at this today.

 

Thank you in advance. I really am stuck on this and can't find a solution.

Share this post


Link to post

Go into /boot/config/plugins/Sabnzbd and delete the sab file and .md5 of the same name. Then try to install again.

Share this post


Link to post

That... Doesn't look like the right folder. What version is your plugin at?

 

Your on your USB stick in /config/plugins/Sabnzbd folder?

 

All the install files are missing. A reboot of the server will force there plugin to download them again.

Share this post


Link to post

I search my file system for sabnzbd and I don't have any thing that end with .md5. I have a file with .ini and .bak.

Share this post


Link to post

Does your phone app have access to the usb stick? /boot is the directory for the usb.

Share this post


Link to post

That... Doesn't look like the right folder. What version is your plugin at?

 

Your on your USB stick in /config/plugins/Sabnzbd folder?

 

All the install files are missing. A reboot of the server will force there plugin to download them again.

 

I also searched the file system for all *.sab files and I don't have any for sabnzbd.

 

I checked in /boot/plugins AND /boot/config/plugins and there's nothing there for sabnzdb.

Share this post


Link to post

/boot/config/plugins

 

If nothing is there then you do not have my plugin installed.

Share this post


Link to post

/boot/config/plugins

 

If nothing is there then you do not have my plugin installed.

 

Hmm, there's nothing there. When I try to install the plugin I get an MD5 error that aborts.

Share this post


Link to post

Ok I see. This md5 error is when you install the plugin, not the app.

 

Sounds like you are having trouble downloading from github, not uncommon though.  In /boot/config/plugins make a folder called Sabnzbd (the capital matters on the s) and download the files from here:

 

https://github.com/PhAzE-Variance/unRAID/tree/master/AppSupport/Sabnzbd

 

You need control-2.5 and both dependency-1.7 files and put them in that folder. Then install the plugin again.

Share this post


Link to post

Ok I see. This md5 error is when you install the plugin, not the app.

 

Sounds like you are having trouble downloading from github, not uncommon though.  In /boot/config/plugins make a folder called Sabnzbd (the capital matters on the s) and download the files from here:

 

https://github.com/PhAzE-Variance/unRAID/tree/master/AppSupport/Sabnzbd

 

You need control-2.5 and both dependency-1.7 files and put them in that folder. Then install the plugin again.

 

This happened after my server lost power. I'm unable to create a folder because my file systems in read-only mode. I suspect maybe I need to run fsck, but maybe you have an idea?

Share this post


Link to post

Read only would be a pretty big problem for installing anything to it. :)

 

I'm not sure the best way to do this. Perhaps one of the tools under the tools tab.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.