[PhAzE] Plugins for Unraid 5/6


3606 posts in this topic Last Reply

Recommended Posts

Thanks for this PhAzE - I just wanted to ask if there were problems with the links today.  I have a fresh install and am trying to get some of the apps installed.  I was only able to get nzbget to stick - everything else seems to not be there in the Settings area?

 

plugin: installing: https://github.com/PhAzE-Variance/unRAID/raw/master/Plugins/Headphones.plg
plugin: downloading https://github.com/PhAzE-Variance/unRAID/raw/master/Plugins/Headphones.plg
plugin: downloading: https://github.com/PhAzE-Variance/unRAID/raw/master/Plugins/Headphones.plg ... done
Installing Headphones plugin
Checking for current bundle files
Control file: Found correct version
Dependency file: Found wrong version, deleting
Check OK!
Downloading new dependency file 

Link to post
  • Replies 3.6k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Just a quick update, unRaid 6.4 looks like it will be using nginx for the web front end over emhttp (which is a good switch IMO) but that means there is a good chance all of my plugins will not work o

Important info regarding unRAID 6.2 and beyond.          ***unRAID 6.2 Compatible*** Hello again!   I've done another overhaul of the plugins

Unfortunately, @PhAzE no longer seems to be active at all within these forums.  His last time online was March 23, and his last posting was on February 22.  I'm sure I speak for all of us in hoping th

Posted Images

Possibly a problem with GitHub, you can go to that URL and download the files manually then put them in the proper folder under /boot/config/plugins/ and try the install again.

 

It doesn't seem like it or at least I'm not understanding how it works on GitHub's side - during installation, the status just looks like it's successful, but it doesn't show up in Settings to be configured.

 

Has anyone else tried it on 6.2rc5 - maybe it's just me.

 

-Update-

Disregard, I guess I needed to restart my unRAID server.  After it came back up, all the plugins reported in.

Link to post

Hey PhaZe - BTSync plugins seem broken since I updated to Unraid V6.20

It was reporting a new version but couldn't install the new version.

I tried uninstalling and reinstalling but I'm getting: Install failed: App executable not found

 

However, it does install the Plugins section but the Installed Version state: NOT Installed.

Manually clicking the install button -> error out with:  Installing BitTorrent Sync... Install failed: App executable not found

 

 

------------------------------------------------------------------------------

plugin: installing: https://raw.githubusercontent.com/PhAzE-Variance/unRAID/master/Plugins/Btsync.plg

plugin: downloading https://raw.githubusercontent.com/PhAzE-Variance/unRAID/master/Plugins/Btsync.plg

plugin: downloading: https://raw.githubusercontent.com/PhAzE-Variance/unRAID/master/Plugins/Btsync.plg ... done

Installing Btsync plugin

Checking for current bundle files

Control file: Not Found

Dependency file: Not found

Check OK!

Downloading new control file

Download OK: Control file passed MD5 check

Running install script for BitTorrent Sync

Installing control file

Control file install OK!

Cleaning up temp files and folders

Install complete!

plugin: installed

Done

Link to post

I don't claim to know how much effort it would take to make this work, but would it be possible to make a plugin that simply stops, starts, restarts the installed plugins? In the main window for it, you could simply have a checkbox for each Phaze plugin currently available. You check the boxes for the plugins you have installed, and if you need to stop all the plugins, click stop one time and it takes care of the rest.

 

I only ask because I am using multiple plugins and the system always seems to hang if I don't manually stop all of them prior to taking it offline.

 

In any event, I appreciate what you have brought to this community.

 

 

Link to post

Hey PhaZe - BTSync plugins seem broken since I updated to Unraid V6.20

It was reporting a new version but couldn't install the new version.

I tried uninstalling and reinstalling but I'm getting: Install failed: App executable not found

 

However, it does install the Plugins section but the Installed Version state: NOT Installed.

Manually clicking the install button -> error out with:  Installing BitTorrent Sync... Install failed: App executable not found

 

I don't think this is a 6.2 issue. I rebooted my server running 6.1.9 and now am seeing the same thing.

 

2016-09-15 20:26:33 [iNFO]	*** Install Initiated ***
2016-09-15 20:26:33 [iNFO]	Installing BitTorrent Sync...
2016-09-15 20:26:34 [iNFO]	Updating dependencies
2016-09-15 20:26:34 [iNFO]	No dependencies required for this application
2016-09-15 20:26:34 [iNFO]	Updating export file
2016-09-15 20:26:34 [iNFO]	Updating shorcut file
2016-09-15 20:26:36 [iNFO]	Latest version found: 2.4.0 - Checking USB for same install file
2016-09-15 20:26:36 [iNFO]	Copy found on USB, checking for MD5 file
2016-09-15 20:26:36 [iNFO]	Located MD5 file - Testing against install file
2016-09-15 20:26:37 [iNFO]	MD5 of Btsync-PhAzE-2.4.0-x64.tar.gz is valid - Proceeding with install
2016-09-15 20:26:37 [iNFO]	Updating application directories
2016-09-15 20:26:37 [iNFO]	Updating application config file
2016-09-15 20:26:37 [ERROR]	Install failed: App executable not found 

Link to post

noob question... I use Phaze plugin and want to update to the latest Plex Beta to use the DVR function. I downloaded the thx file from Plex website but have no idea where to put it to be install it. The way I installed it, I ended with 2 Plex, which is obviously not what I wanted. I removed the thx file from the boot key, rebooted and the 2nd version is gone. Now how to I simply upgrade my Phaze Plex version to the Plex beta?

 

Any help would be appreciated.

 

thanks

Link to post

I already have a PlexPass and it's already set up. The problem is it's a manual download since it's a beta version. The download is done here https://forums.plex.tv/discussion/230212/

When you have the install beta file downloaded, put it in the /boot/config/plugins/Plexmediaserver folder.

 

You will see two files in there similar to:

Plexmediaserver-PhAzE-1.1.4.2757-24ffd60-x64.txz*

Plexmediaserver-PhAzE-1.1.4.2757-24ffd60-x64.txz.md5*

 

You need to delete the .md5 file, and the old .txz file, and rename your new beta one the same as the one you just deleted.  Then force the plugin to install again with:

 

/etc/rc.d/rc.Plexmediaserver install

 

Just note that in the settings page GUI it will show an update is available (to the latest stable plex pass version) which you can safely ignore.

Link to post

I already have a PlexPass and it's already set up. The problem is it's a manual download since it's a beta version. The download is done here https://forums.plex.tv/discussion/230212/

When you have the install beta file downloaded, put it in the /boot/config/plugins/Plexmediaserver folder.

 

You will see two files in there similar to:

Plexmediaserver-PhAzE-1.1.4.2757-24ffd60-x64.txz*

Plexmediaserver-PhAzE-1.1.4.2757-24ffd60-x64.txz.md5*

 

You need to delete the .md5 file, and the old .txz file, and rename your new beta one the same as the one you just deleted.  Then force the plugin to install again with:

 

/etc/rc.d/rc.Plexmediaserver install

 

Just note that in the settings page GUI it will show an update is available (to the latest stable plex pass version) which you can safely ignore.

 

Thanks a lot. It worked.

Link to post

Hey, PhAzE

 

I'm using your PlexConnect plugin, but it looks like it's not honoring the custom repo field. I'm attempting to use the repo at https://github.com/CyberGhost84/PlexConnect, but when I do so it just installs the same repo as default.

 

Hey Everyone,

 

Seems github has changed their formatting slightly on their site which was causing my plugins to get incorrect BRANCH variables.  I've updated all of the GIT related plugins and correct this.

 

This also fixes them from not honoring the custom repo field.

Link to post

Could someone verify CouchPotato install process is working. I have nzbget, headphones, sonarr installing just fine, but pasting Couchpotatoe's plg URL, it doesn't look like it's installing properly.

 

Thanks!

 

plugin: installing: https://github.com/PhAzE-Variance/unRAID/raw/master/Plugins/Couchpotato.plg
plugin: downloading https://github.com/PhAzE-Variance/unRAID/raw/master/Plugins/Couchpotato.plg
plugin: downloading: https://github.com/PhAzE-Variance/unRAID/raw/master/Plugins/Couchpotato.plg ... done
Installing Couchpotato plugin
Checking for current bundle files
Control file: Found correct version
Dependency file: Found wrong version, deleting
Check OK!
Downloading new dependency file 

 

 

Edit Comments: My english is terrible when I lack sleep.

Link to post

What is the error it shows, and can you post your settings?

 

PhAzE, I modified my previous post for the messages once I paste the plg file in for install.  As far as settings - are you referring to the plugin settings themselves? I had not configured anything yet.

Link to post

Couchpotato won't start when config directory is set anywhere on /use/local/*

 

You need to set the config directory to a disk or the array for it to start. Not sure why, but the program detects that unRAID is set as a ram drive and fails to start because of that.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.