Jump to content
PhAzE

[PhAzE] Plugins for Unraid 5/6

3606 posts in this topic Last Reply

Recommended Posts

It's OK, it might have been their site also, but I'm glad it is working because I've been breaking my brain trying to learn and solve all these recent ssl issues which I thought the latest update had fixed. ;) (which it seems it did fix after all)

 

Share this post


Link to post

Oh, if you upgrade via plugin tab there will be no option to downgrade because unraid doesn't have that functionality built in. The updater in my plugins do, for future reference.

Share this post


Link to post

Odd.. none of the persistent directories had the trailing / but the repo did.. removed that and I'm back in although all of my settings were wiped. Changed a couple of things and did a restart just to test and it's letting me back in after the restart with the saved settings.

 

Thanks!

Share this post


Link to post

Hey PhAzE

 

I'm still running unRaid 5 with your excellent plugins and I just noticed that SickBeard (well SickRage) isn't starting any more.

 

I've updated to the latest plugin version and that hasn't helped.

 

I tweaked the rc.Sickbeard file so that I could see the output from Sick Beard as it starts up and it says

 

The Python module Cheetah is required.

 

I've tried re-installing the plugin and it says it's skipping python-cheetah as it's already installed!  What can I do to either resolve the problem, or help debug it further?

 

Cheers!

Share this post


Link to post

I will try to have a look later on, if you reboot out will install all the dependencies again. It should be included and installed properly though.

Share this post


Link to post

Further update

 

If (from the command line) I run the EXPORTs from startcfg.sh I can then run python from the command line (and can see its 2.7.10)

 

I can see cheetah is installed in /usr/local/PhAzE-Common/usr/bin as it should be

 

If I try and run it it complains

 

bash: /usr/local/PhAzE-Common/usr/bin/cheetah: /usr/bin/python: bad interpreter: No such file or directory

 

/usr/bin/python isn't there...

 

Shouldn't it be looking for it in /usr/local/PhAzE-Common/usr/bin ? Presumably if python was in /usr/bin then it would be accessible from the commandline without requiring all your careful work to keep it separate..

 

On the offchance I upgraded Sab and CP to the latest plugins too.. now SAB wont' start either due to the lack of Cheetah :-(

 

 

Share this post


Link to post

been trying for an hour or so to get Plex to work. I keep getting the plugin to only mount /tmp/Plexmediaserver for my temporary converting directory. no matter what I do I cannot force that dir to change to anything else. I've stopped, changed, applied, restarted and the plugin keeps reverting back to /tmp/Plexmediaserver.

 

Share this post


Link to post

Further update

 

If (from the command line) I run the EXPORTs from startcfg.sh I can then run python from the command line (and can see its 2.7.10)

 

I can see cheetah is installed in /usr/local/PhAzE-Common/usr/bin as it should be

 

If I try and run it it complains

 

bash: /usr/local/PhAzE-Common/usr/bin/cheetah: /usr/bin/python: bad interpreter: No such file or directory

 

/usr/bin/python isn't there...

 

Shouldn't it be looking for it in /usr/local/PhAzE-Common/usr/bin ? Presumably if python was in /usr/bin then it would be accessible from the commandline without requiring all your careful work to keep it separate..

 

On the offchance I upgraded Sab and CP to the latest plugins too.. now SAB wont' start either due to the lack of Cheetah :-(

Hmm unraid 5 I guess? I've got both running in unraid 6.

Share this post


Link to post

been trying for an hour or so to get Plex to work. I keep getting the plugin to only mount /tmp/Plexmediaserver for my temporary converting directory. no matter what I do I cannot force that dir to change to anything else. I've stopped, changed, applied, restarted and the plugin keeps reverting back to /tmp/Plexmediaserver.

Can other settings change? Try editing it in the config file in /boot/config/plugins/Plex/ folder.

 

That folder shouldn't break plex though. Sounds more like a corrupt application config file. In which case you would need to delete your config folder.

Share this post


Link to post

For some reason I am unable to connect to the Headphones main page after it is installed. I get the same thing I was getting with the SickRage (unable to connect), except this time I am never able to get in initially. I have tried uninstalling/reinstalling/powering down/etc several times. I have tried different ports, and adding/removing a "/" after the config/logs/cache lines. Don't have a custom repo for that installed. Have also tried with SSL/non-SSL. Not sure what else I can try at this point to get it working.

 

Any ideas or any other info I can provide to help troubleshoot?

Share this post


Link to post

Try using the IP instead of the DNS name, I find the DNS is spotty sometimes.

Share this post


Link to post

Try using the IP instead of the DNS name, I find the DNS is spotty sometimes.

 

Just tried that, along with all the other options again and still getting the same deal.

Share this post


Link to post

Did the app start? Does it say running?

 

If so check the apps log file for errors.

Chances are, each app having that problem will point to the same issue.

Share this post


Link to post

Did the app start? Does it say running?

 

If so check the apps log file for errors.

Chances are, each app having that problem will point to the same issue.

 

Yes, it's started and says "Status: RUNNING with version: 24165fb5f3b8304bb844ac293bdb041517574e8d"

 

2xsSSob.jpg?1

 

I've attached the log, but glanced through it and couldn't see anything that I could identify as sticking out as an indicator of an issue. Normally if something like this happens I just uninstall and then reinstall and it resolves. This time it didn't even work initially and after several reinstalls I could never get the page to load.

headphones.txt

Share this post


Link to post

Try runas nobody, there's no need to run this as root. See if it's able to start then. However, change it, hit apply, then reboot the server.

 

Share this post


Link to post

One of the things that happens is when running as root, all the files are chowned as root, and some apps won't start when set to that. That's where user nobody comes in handy.

Share this post


Link to post

Try runas nobody, there's no need to run this as root. See if it's able to start then. However, change it, hit apply, then reboot the server.

 

I changed it to run as "nobody" and then the headphones server wouldn't start, got some "PID created but process did not start" error. This persisted even upon uninstalling/reinstalling.

 

So I removed the plugin (via the plugins panel, instead of settings, not sure if that makes a difference), and powered down (as directed to clear dependencies). Deleted all old Headphones folders and any reference to it on the NAS. Rebooted, and reinstalled running as user nobody, this time it allowed Headphones to start but again got the same issue (unable to connect). I also tried the different directories with and without "/" still with no luck.

 

Also, try a different web browser.  Try and clear the cache on your existing browser.

 

After reinstalling and setting to user nobody I also tried 3 different browsers, using the http://IP:port using a couple of different ports just to be sure.

 

Edit: Again I should also mention that all of my other PhAzE plugins work perfectly (Maraschino, CP, SR, Emby, BTSync).. not sure why I can't even get access to a basic home screen with this one.

Share this post


Link to post

 

Thanks PhAzE. Updated everything, following the test script from yesterday that worked well. Everything is still working.

For some reason though, I had to start from scratch configuring SAB again - got the Wizard screen...

 

 

Same here with the 7/23 update. unRAID 5 for me if that make a difference. I tried downgrading to the previous version but it didn't resolve it.

 

I ended up restoring my various SAB config files from backup and it appears to be operating normally now.

 

Share this post


Link to post

I just updated the plugin on my server and also had my config directory disappear, so there is a bug in the update process which i'm trying to figure out. I'ts very strange because my code doesn't deal with teh config directory at all when updating the plugin, that I can tell. :S

Share this post


Link to post

PhAzE, I'm trying to reinstall Emby server, but having trouble. The installation stops/times out  trying to download dependencies. I think I have deleted all the old related files on the flash drive, but don't know where to go from here. Any suggestions?

Share this post


Link to post

You can download them directly from my github and place them in /boot/config/plugins/Embyserver

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.