Jump to content
PhAzE

[PhAzE] Plugins for Unraid 5/6

3606 posts in this topic Last Reply

Recommended Posts

Outstanding news- hope you didn't burn your entire Labor Day holiday on the effort.  FWIW, the first post still indicates the links are for v2 of the plugins.

Share this post


Link to post

Yea lol I burned most of August actually, and went for dinner before I changed the post in page one... Oops ;) I'll fix that soon.

Share this post


Link to post

Hey Everyone,

 

Updates have been released, please REBOOT YOUR SERVER after updating the these new v3 plugins, to clear out old dependencies.

 

Check out the first page for all the changes, and yes they are 6.1 compatible.  As usual, let me know if you come across any oddities!

 

-=PhAzE=-

 

Well done!

 

I'm currently using the SickBeard plugin (pointing to the SickRage repo) - if I want to use the new SickRage specific plugin is there anyway to transfer the settings across (other than by hand?)

 

Cheers

Chris

Share this post


Link to post

J just load both plugins, so the sickbeard one, copy and paste. There aren't that many to swap over. As long as you point it to your sickrage install folder and config folder, everything should work like normal.

Share this post


Link to post

Alternatively, install the sickrage plugin, so sickbeard and from console type:

 

cp -f /boot/config/plugins/Sickbeard/Sickbeard.cfg /boot/config/plugins/Sickrage/Sickrage.cfg

 

 

Share this post


Link to post

Updated all my plugins and all seem to be working except for SABNZBD.

 

I'm getting the following error on the UNRAID console

 

sed: -e expression #1, char 41: unterminated 's' command

 

Any help would be appreciated.

 

Thanks

 

Mike

Share this post


Link to post

...and on the GUI it says: Starting SABnzbd ... Start Failed: No PID created.

 

But thanks for the hard work and for the fact that all others of your plugins that I use seem to be running smoothly.  ;D

Share this post


Link to post

6.1 for me.

And, yes, I rebooted (all your other plugins that I use - Transmission, Sickbeard, Coiuchpotato - run without a hitch as far as I can tell).

Share this post


Link to post

Hmm I booted up a fresh unraid 6.1 vm and it installed and started without any issue. 

 

Try first to change the port. Are you also seeing the sed error in the console?

Share this post


Link to post

Updated all my plugins and all seem to be working except for SABNZBD.

 

I'm getting the following error on the UNRAID console

 

sed: -e expression #1, char 41: unterminated 's' command

 

Any help would be appreciated.

 

Thanks

 

Mike

Can you tell me what you do when that shows up?  For example, is it only when the page loads, or when you press the start button? Also, does this happen after a reboot?

Share this post


Link to post

Hmm I booted up a fresh unraid 6.1 vm and it installed and started without any issue. 

 

Try first to change the port. Are you also seeing the sed error in the console?

 

Whoopsy - changed the port from 9090 to 9093 - and it works now.

What was the consequence of the port change?

Share this post


Link to post

Likely just a port being held open by something. Perhaps there initial version check. The app functions the same regardless of port being used.

 

On the new port, try a reboot then change back to your original port and see if it works, unless your OK using the new port then all is good.  You'll need to update any other apps you use that point to sab to use the new port number also.

Share this post


Link to post

Likely just a port being held open by something. Perhaps there initial version check. The app functions the same regardless of port being used.

 

On the new port, try a reboot then change back to your original port and see if it works, unless your OK using the new port then all is good.  You'll need to update any other apps you use that point to sab to use the new port number also.

 

Just upgraded to 6.1.1. - same problem on reboot: Now SAB does not start on 9093 - and starts once I changed the port back to 9090.

???

Share this post


Link to post

Changed my port as suggested and it worked!  Immediately changed it back and it still worked!  Thanks!  Not sure why it happened in the first place but I'm up and running.

 

Mike

 

Share this post


Link to post

After upgrading, Mylar was telling me with red text that my cache drive in ram and would be lost on reboot. I clicked the checkboxes to enable changing that, and added them in. Upon applying the changes, those checkboxes are now unchecked. The red text is gone. However, the log and cache files both seem accessible and my logs are updating in that directory. There is no green text for either of those saying I have them configured right, but there is still for my config directory.

 

Basically, the WEBUI seems to clear those values, but they are working correctly from what I can tell. Additionally, if I'm supposed to see green text saying the config is good for those 2 folders, well, I'm not seeing it.

Share this post


Link to post

If they reside as sub directories of the config directory, then only the alert for the config directory will show.  So if they aren't there and config directory days all good, then your good.

Share this post


Link to post

Hello,

 

Hopefully a quick question... I am on latest 6.1.1. I want to use Headphones and have it re-encode loss-less downloads. Headphones is the only plugin I have installed. Which encode option is available? ffmpeg, libav, lame? On the console I type any of the commands and I get "command not found". I also tried "which ffmpeg" and I get nothing useful.

 

Many thanks!

 

H.

 

 

Share this post


Link to post

They are "jailed" and need the environment variables loaded before they are accessible straight from the OS.

Share this post


Link to post

They are "jailed" and need the environment variables loaded before they are accessible straight from the OS.

 

Thank you Phaze... but I am a little confused on how to do what you suggest...

 

At the command when I type:

    Headphones-env ffmpeg

I get:

    /bin/bash: ffmpeg: command not found

 

If I type:

  headphones-env ffmpeg

I get:

  -bash: headphones-env: command not found

 

How do I set the environment variables you suggest?

 

Thanks again.

 

Hernando

 

Share this post


Link to post

If they reside as sub directories of the config directory, then only the alert for the config directory will show.  So if they aren't there and config directory days all good, then your good.

 

Thank!

 

The work has been much appreciated! Get some of that rest!

Share this post


Link to post

They are "jailed" and need the environment variables loaded before they are accessible straight from the OS.

 

Thank you Phaze... but I am a little confused on how to do what you suggest...

 

At the command when I type:

    Headphones-env ffmpeg

I get:

    /bin/bash: ffmpeg: command not found

 

If I type:

  headphones-env ffmpeg

I get:

  -bash: headphones-env: command not found

 

How do I set the environment variables you suggest?

 

Thanks again.

 

Hernando

Oops my mistake, ffmpeg is not included in headphones. I believe you need to use lamemp3. Does it not work from within the app when you tell it to re-encode? Or can you explain the problem a bit more?

Share this post


Link to post

They are "jailed" and need the environment variables loaded before they are accessible straight from the OS.

 

Thank you Phaze... but I am a little confused on how to do what you suggest...

 

At the command when I type:

    Headphones-env ffmpeg

I get:

    /bin/bash: ffmpeg: command not found

 

If I type:

  headphones-env ffmpeg

I get:

  -bash: headphones-env: command not found

 

How do I set the environment variables you suggest?

 

Thanks again.

 

Hernando

Oops my mistake, ffmpeg is not included in headphones. I believe you need to use lamemp3. Does it not work from within the app when you tell it to re-encode? Or can you explain the problem a bit more?

 

Hi Phaze,

 

I have been using your plugins for a long time. But for some reason, something got corrupt with Headphones and I am basically doing a clean install. In the "settings > advanced" screen, there is the choice of which encoder to use if you want to go from lossless to mp3 format. I keep my library all in mp3. But I want the ability to find lossless and re-encode to the highest quality mp3. Because I could not tell which encoders are installed/active in unRAID, I did the testing of typing any of the following at the command line to determine:

 

    lame

    ffmpeg

    libav

    xcd

    lamemp3

 

But all of those returned "command not found" and the command prompt. Thus I am asking the question if any dependencies that allow re-encoding are installed with your Headphones plugins.

 

Many thanks for your help and for the awesome plugins.

 

H.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.