Jump to content
dmacias

*DEPRECATED* Apache Web Server for unRAID 6.2

174 posts in this topic Last Reply

Recommended Posts

It works! is the default apache index.html.  Either the document root is pointed to the wrong directory or phpvirtualbox isn't in the right place. There should be a phpvirtualbox directory in the document root directory from the apache plugin.

 

as far as I can tell I have everything in the right place. I havent moved anything or changed DIRs since I had it working before.

 

link

http://imgur.com/a/OVK8o

Try extracting phpvirtualbox again. I think apache copied its default index.html

Share this post


Link to post

Just tried that. Same error. I opened index.html and it opens to the virtualbox page but gives and error cause I am opening it from my PC. So I have the files I need, just something isnt pointed in the right direction.

Share this post


Link to post

Just tried that. Same error. I opened index.html and it opens to the virtualbox page but gives and error cause I am opening it from my PC. So I have the files I need, just something isnt pointed in the right direction.

Try clearing your browser cache. In Firefox it's Ctrl F5.

Share this post


Link to post

Just tried that. Same error. I opened index.html and it opens to the virtualbox page but gives and error cause I am opening it from my PC. So I have the files I need, just something isnt pointed in the right direction.

Try clearing your browser cache. In Firefox it's Ctrl F5.

 

HERP DERP!!! That did it. Im at the log in screen. Thank you for the help!

Share this post


Link to post

Just tried that. Same error. I opened index.html and it opens to the virtualbox page but gives and error cause I am opening it from my PC. So I have the files I need, just something isnt pointed in the right direction.

Try clearing your browser cache. In Firefox it's Ctrl F5.

 

HERP DERP!!! That did it. Im at the log in screen. Thank you for the help!

Haha I almost always hit Ctrl F5 anymore.

Share this post


Link to post

Just tried that. Same error. I opened index.html and it opens to the virtualbox page but gives and error cause I am opening it from my PC. So I have the files I need, just something isnt pointed in the right direction.

Try clearing your browser cache. In Firefox it's Ctrl F5.

 

HERP DERP!!! That did it. Im at the log in screen. Thank you for the help!

Haha I almost always hit Ctrl F5 anymore.

 

Do I still need to edit the GO file if the username vbox and pass dont get me in?

 

Nevermind. Disabled the login in config.php. Thanks again for the help.

Share this post


Link to post

Just tried that. Same error. I opened index.html and it opens to the virtualbox page but gives and error cause I am opening it from my PC. So I have the files I need, just something isnt pointed in the right direction.

Try clearing your browser cache. In Firefox it's Ctrl F5.

 

HERP DERP!!! That did it. Im at the log in screen. Thank you for the help!

Haha I almost always hit Ctrl F5 anymore.

 

Do I still need to edit the GO file if the username vbox and pass dont get me in?

It had been awhile and I couldn't remember how to login. I don't use virtualbox so I didn't try very hard.

Share this post


Link to post

Hi

 

I have ; short_open_tag

;  Default Value: On

;  Development Value: Off

;  Production Value: Off

 

is it correct for phpmyadmin ?

 

 

 

 

For phpMyAdmin on your flash drive in /config/plugins/apache/httpd edit php.ini and "change short_open_tag = On".

Share this post


Link to post

 

 

Hi

 

I have ; short_open_tag

;  Default Value: On

;  Development Value: Off

;  Production Value: Off

 

is it correct for phpmyadmin ?

 

 

 

 

For phpMyAdmin on your flash drive in /config/plugins/apache/httpd edit php.ini and "change short_open_tag = On".

 

Right below those lines you may have

short_open_tag = Off

Change it to

short_open_tag = On

Then restart apache

Share this post


Link to post

Ok I have founded the correct line :) But after restart apache... where is phpmyadmin ?

Share this post


Link to post

Ok I have founded the correct line :) But after restart apache... where is phpmyadmin ?

Well you still have to download that and place in your document root. Then follow their tutorials top setup

Share this post


Link to post

I have copied files on www but when i try to launch a php file there is

 

phpMyAdmin - Error

 

Error during session start; please check your PHP and/or webserver log file and configure your PHP installation properly. Also ensure that cookies are enabled in your browser.

 

 

 

 

 

Any idea ?

Share this post


Link to post

Not sure.  You could try uninstalling the plugin and renaming the apache plugin to apache.old then reinstall the plugin and point it to your document root.

Share this post


Link to post

No effects... I continue searching... Thanks for your help dmacias ;)

What version phpmyadmin?

Share this post


Link to post

It seems it's a rights problem.

 

In have created a folder with o+rw permission, when i put a php file from root to this folder, it works.

 

 

Share this post


Link to post

It seems it's a rights problem.

 

In have created a folder with o+rw permission, when i put a php file from root to this folder, it works.

I'll have to double check if it's something on my end. I know I set the user recursively but maybe not write permissions.

Share this post


Link to post

I don'y very well understand rights needed for phpMyAdmin folder by Folder... Linux is not my "cup of tea" :)

Share this post


Link to post

Is there a memory and processes issue with the Apache WebServer?

 

* Before I enable the web server I have ~1.4GB memory in usage (see attached "Before" picture).

 

* After I enable the web server I have ~1.4GB memory in usage and 4 running httpd processes (see attached "After" picture).

 

* after I open phpVirtualBox web server page and browse about in it I have ~2.8GB memory in usage and 5 running httpd processes (see attached "Open_phpVirtualBox" picture).

 

* after I close phpVirtualBox web server page I have ~2.7GB memory in usage and 5 running httpd processes (see attached "Close_phpVirtualBox" picture).

 

Questions:

* Should there be 4 "httpd" processes running initially?

* Should another one be opened when opening a web page (another single process is opened for all open web pages)?

* Should this process not be closed and memory freed up when closing all web pages?

Before.gif.09862e767349826254cad2dfe8a265bc.gif

After.gif.7d9db2ccf8d7a7446b8e808e06d28b91.gif

Open_phpVirtualBox.gif.e99569aecd865c5c2f0d689bf88dcca7.gif

Close_phpVirtualBox.gif.2134546b635881e56f8a079c91258fd7.gif

Share this post


Link to post

Is there a memory and processes issue with the Apache WebServer?

 

* Before I enable the web server I have ~1.4GB memory in usage (see attached "Before" picture).

 

* After I enable the web server I have ~1.4GB memory in usage and 4 running httpd processes (see attached "After" picture).

 

* after I open phpVirtualBox web server page and browse about in it I have ~2.8GB memory in usage and 5 running httpd processes (see attached "Open_phpVirtualBox" picture).

 

* after I close phpVirtualBox web server page I have ~2.7GB memory in usage and 5 running httpd processes (see attached "Close_phpVirtualBox" picture).

 

Questions:

* Should there be 4 "httpd" processes running initially?

* Should another one be opened when opening a web page (another single process is opened for all open web pages)?

* Should this process not be closed and memory freed up when closing all web pages?

I know I always thought that was weird but it's normal. I checked my mythbuntu vm which has an apache webserver for mythweb and it has the same initial 4 processes running. See here under process creation. http://httpd.apache.org/docs/2.4/misc/perf-tuning.html You can tweak settings in the httpd.conf in the plugin's config folder. Restart the apache server after editing. I was actually thinking about adding an editor like the vm manager for this. But anyway every time you access the virtual box webpage it should create a httpd child process and will stay alive while the page is in use and for a bit afterwards just in case. If you close the web browser after some time the process should close. As long as you aren't opening a billion webpages you should be fine.

Share this post


Link to post

After how much time since i closed the web page should it destroy the process and clear the memory. It has been over an hour and it is still there and taking up much memory.

 

Edit:

It's been almost 12 hours and the 5th "httpd" process still exists and memory is still high ~2.6GB - not released.

 

Share this post


Link to post

After how much time since i closed the web page should it destroy the process and clear the memory. It has been over an hour and it is still there and taking up much memory.

 

Edit:

It's been almost 12 hours and the 5th "httpd" process still exists and memory is still high ~2.6GB - not released.

Unless you're actually running out of memory, I wouldn't worry too much.  Even if you stop apache the memory will still be cached but free for other programs to use.  I did test some settings to reduce the memory footprint of apache. You can try commenting out these modules in your httpd.conf. and any others that you don't need.

#LoadModule authz_groupfile_module lib64/httpd/modules/mod_authz_groupfile.so
#LoadModule env_module lib64/httpd/modules/mod_env.so
#LoadModule version_module lib64/httpd/modules/mod_version.so
#LoadModule proxy_ftp_module lib64/httpd/modules/mod_proxy_ftp.so
#LoadModule proxy_scgi_module lib64/httpd/modules/mod_proxy_scgi.so
#LoadModule proxy_wstunnel_module lib64/httpd/modules/mod_proxy_wstunnel.so
#LoadModule proxy_ajp_module lib64/httpd/modules/mod_proxy_ajp.so
#LoadModule status_module lib64/httpd/modules/mod_status.so
#LoadModule autoindex_module lib64/httpd/modules/mod_autoindex.so
#LoadModule vhost_alias_module lib64/httpd/modules/mod_vhost_alias.so
#LoadModule alias_module lib64/httpd/modules/mod_alias.so

Also I uncommented "Include /etc/httpd/extra/httpd-mpm.conf" and edited the extra/httpd-mpm.conf as follows

# prefork MPM
# StartServers: number of server processes to start
# MinSpareServers: minimum number of server processes which are kept spare
# MaxSpareServers: maximum number of server processes which are kept spare
# MaxRequestWorkers: maximum number of server processes allowed to start
# MaxConnectionsPerChild: maximum number of connections a server process serves
#                         before terminating
<IfModule mpm_prefork_module>
    StartServers             1
    MinSpareServers          1
    MaxSpareServers          3
    MaxRequestWorkers       10
    MaxConnectionsPerChild 3000
</IfModule>

# worker MPM
# StartServers: initial number of server processes to start
# MinSpareThreads: minimum number of worker threads which are kept spare
# MaxSpareThreads: maximum number of worker threads which are kept spare
# ThreadsPerChild: constant number of worker threads in each server process
# MaxRequestWorkers: maximum number of worker threads
# MaxConnectionsPerChild: maximum number of connections a server process serves
#                         before terminating
<IfModule mpm_worker_module>
    StartServers             1
    MinSpareThreads          5
    MaxSpareThreads         15 
    ThreadsPerChild         25
    MaxRequestWorkers      200
    MaxConnectionsPerChild  25
</IfModule>

Share this post


Link to post

It looks like I am missing something here. I've installed the plugin (since I am trying to setup Virtualbox as well). After installing the plugin, I am unable to run any of the VM's, with message "Error:invalid argument: could not find capabilities for arch=x86_64 domaintype=(null)". Tested several times (install plugin / reboot /VMs not working - uninstall plugin / reboot / VMs working). Images attached... Any ideas?

 

 

unraid_apache_error.jpg.41b22b808acebd2cb9d341e2cb5dfc7c.jpg

unraid_apache_running.jpg.7ece6ecfc0ed2a7f4ad2e8dfb49211c5.jpg

Share this post


Link to post

Unless you're actually running out of memory, I wouldn't worry too much.  Even if you stop apache the memory will still be cached but free for other programs to use.  I did test some settings to reduce the memory footprint of apache. You can try commenting out these modules in your httpd.conf. and any others that you don't need.

I am running out of memory.

 

After starting up Apache the memory footprint is very small (less than 10MB).

At what stage are the modules loaded? at Apache startup or only when needed by the specific web page?

If it is on startup then it doesn't explain the memory rise afterwards.

 

Once I start loading phpVirtualBox the memory starts rising as I navigate around the site and reaches over 1.6GB of memory usage by httpd processes.

This memory is kept in use and NOT cached !!!

 

Only when I disable Apache web server do all the httpd processes get removed and memory is returned to the system (freed not cached).

 

I have also tried it with eXplorer and also there the memory rises and not freed up, but not as much - only ~200MB.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.