Dockerization of some popular applications.


1313 posts in this topic Last Reply

Recommended Posts

Apparently. nzbDrone does get the path of the downloaded file from SAB over the API. I was reading other outdated stuff that never mentioned this last night. I'm running SAB natively on the server which means the post-processing can't work without either using drone factory or having the actual server path as a Volume in the nzbDrone docker or changing to the SAB docker so /downloads is common between them.

 

 

Link to post
  • Replies 1.3k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Odds on because of the DMCA currently in place against Sickrage by an angry contributor to the project.   Better off switching to the lsio or binhex versions of this app 

the general place at the moment is in the Docker Engine section, i agree its not REALLY the right place but its a lot better than posting in a support thread from a guy who hasn't been here for 1.5 ye

No.  This is the needo / gfjardim support thread.  But what are you going to do?  Users will post where users post.   If you really want to enforce things, then the SQL posts should never have been po

Posted Images

I installed plex using docker run -d --net="host" --name="plex" -v /path/to/plex/config:/config -v /path/to/video/files:/data -v /etc/localtime:/etc/localtime:ro needo/plex as described. When trying to log in using

 

http://192.168.2.200:32400/web/index.html#!/dashboard  (using my unraid server ip number) or http://tower:32400/web/index.html#!/dashboard or even http://server:32400/web/index.html#!/dashboard I get "This web page is not available" - I can not connect to plex.  :'( Still it is supposed to be running. I tried adding a user "plex" to unraid and unistalling and installing - but no change. What am I missing? I have no previous installation of plex - it has never been running on this server. I do have a plex pass and unraid plus (but no experience running plex and only a week with unraid, which is working well though.

 

Being new to both unraid and plex I'm guessing I'm missing something rather basic here?? Any help much appreciated!  :)

screencapture-tower-Docker_min.png.68f936887de8600afe0cb2ab1a97e0c7.png

Link to post

your path settings in the docker command are wrong.

 

you have to change /path/to/plex/config and /path/to/video/files to something existing...

 

for example this:

docker run -d --net="host" --name="plex" -v /mnt/disk1/appdata/plex:/config -v /mnt/user/Media:/data -v /etc/localtime:/etc/localtime:ro needo/plex

(make sure, you change these folders accordingly to how you named your shares)

 

it's easier to add new docker containers with the web interface

Link to post

your path settings in the docker command are wrong.

 

you have to change /path/to/plex/config and /path/to/video/files to something existing...

 

for example this:

docker run -d --net="host" --name="plex" -v /mnt/disk1/appdata/plex:/config -v /mnt/user/Media:/data -v /etc/localtime:/etc/localtime:ro needo/plex

(make sure, you change these folders accordingly to how you named your shares)

 

it's easier to add new docker containers with the web interface

 

How would I do this through the web app, I am not sure how to use it? Thank you so much

Link to post

I recently changed from ADSL to cable internet and therefore have new modem/router. Since the switch I have not been able to get Sickbeard or PlexWatch to run. (Also Headphones which I believe is based on the Couchpotato docker)

 

They all start and then stop about 20 seconds later throwing up something like the following.

 

*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/edge.sh...
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Cloning into '/opt/sickbeard'...
fatal: unable to access 'https://github.com/midgetspy/Sick-Beard.git/': Could not resolve host: github.com
chown: cannot access '/opt/sickbeard': No such file or directory
*** /etc/my_init.d/edge.sh failed with status 1

*** Killing all processes...

 

I've tried pinging github.com from unraid and there were no issues. I'm scratching my head.

Any ideas what could be causing this?

 

UPDATE: I have managed to rectify the problem by removing the EDGE parameters, starting the dockers, then re-adding the EDGE parameters and now they are working fine.

Link to post
  • 2 weeks later...

It does look like there is an issue with long filenames/long paths/long passwords in nzbget under Docker that doesn't occur when unrar is used outside the Docker: http://nzbget.net/forum/viewtopic.php?f=3&t=1489&p=9733#p9732

 

Anyone have any thoughts on how to fix it?

 

How do I get unrar 5.11 in the nzbget Docker? Or is there a binary I can use? The unrar in nzbget is 5.00 BETA 8, which is out of date.

 

Cheers,

 

Neil.

 

We think that has been fixed in the latest build of nzbget. It only affects unraring on certain platforms, including Docker/unRAID.

 

To get that new version, if you are running Needo's Docker, stop the Docker, change the EDGE variable to 1171 and it will update to that version with the fix. http://nzbget.net/forum/viewtopic.php?f=3&t=1603&p=10877#p10877

Link to post

To get that new version, if you are running Needo's Docker, stop the Docker, change the EDGE variable to 1171 and it will update to that version with the fix. http://nzbget.net/forum/viewtopic.php?f=3&t=1603&p=10877#p10877

 

Very nice! And yall just remember that it will take some time to compile the new version, depending on the CPU/memory available (~ 10min here). If you don't, you might waste time troubleshooting for no reason ... :)

Link to post

Yup, I run htop to keep an eye on what it's doing. When you see the compiling is done, and the CPU is idle, open up the web interface for nzbget and the new version should be running.

 

P.S. The fix is now also in release version 14.1

Link to post

Yup, I run htop to keep an eye on what it's doing. When you see the compiling is done, and the CPU is idle, open up the web interface for nzbget and the new version should be running.

 

P.S. The fix is now also in release version 14.1

 

I'm having trouble getting 14.1 to compile in Docker.  Typically the compile log file is ~98K when finished.  I've now tried to install 14.1 twice and the log is only ~24K both times and the GUI is not accessible.  I have completely removed any traces of the existing container (renamed to the old folder to nzbget.old) and have the same result.

 

Attaching the log files.

 

Anyone else seeing the same?

 

John

nzbget-14.1-compile.log.txt

libpar2-compile.log.txt

Link to post

Is it possible to get an update to PlexWatch?  As already stated the old version no longer works with the latest Plex release but it has been updated to correct this.

 

Alternatively, is the a way for up to add a variable for us to update by ourselves?

Link to post

Is it possible to get an update to PlexWatch?  As already stated the old version no longer works with the latest Plex release but it has been updated to correct this.

 

Alternatively, is the a way for up to add a variable for us to update by ourselves?

 

I'm on

 

plexWatch/Web Version: v1.5.4.2

plexWatch Version: v0.3.1

PMS Version: v0.9.11.4

 

and everything is working great for me.

Link to post

I'm on

 

plexWatch/Web Version: v1.5.4.2

plexWatch Version: v0.3.1

PMS Version: v0.9.11.4

 

and everything is working great for me.

 

Im on the same as you and it doesn't work.  But it did work before the update to Plex Server v0.9.11.4.

 

Apparently there is a plexWatch Version v0.3.2 which fixes this issue.

Link to post

I'm on

 

plexWatch/Web Version: v1.5.4.2

plexWatch Version: v0.3.1

PMS Version: v0.9.11.4

 

and everything is working great for me.

 

Im on the same as you and it doesn't work.  But it did work before the update to Plex Server v0.9.11.4.

 

Apparently there is a plexWatch Version v0.3.2 which fixes this issue.

 

I tried setting this up new (never had plexwatch but want it) with these same versions and could not get it working

Link to post

Found the fix more me.. 

 

Needo's plexwatch does run for me but didn't connect to plex after I installed Needo's latest update for plex.

 

This is how I fixed it..

 

In Plex got to seetings/server/network/

 

and add the IP of the unraid server to the  "List of networks that are allowered without auth"

 

I attached a picture as well.

 

Hope this works for you guys.

fix.jpg.4bc991d06e3d127b05bb11ec3b14e15f.jpg

Link to post

Found the fix more me.. 

 

Needo's plexwatch does run for me but didn't connect to plex after I installed Needo's latest update for plex.

 

This is how I fixed it..

 

In Plex got to seetings/server/network/

 

and add the IP of the unraid server to the  "List of networks that are allowered without auth"

 

I attached a picture as well.

 

Hope this works for you guys.

 

Unfortunately that does not work.  The only thing that seems to work is disabling the new Plex Home feature in the server which means losing this new function.

Link to post

I am having some issues with PlexWatch as well.

 

PlexWatch does not show a version # and I've setup the IP correctly:

 

http://d.pr/i/18j2l

 

But it still cannot connect:

 

http://d.pr/i/1bpjE

 

http://d.pr/i/10C1h

 

I have it running on a separate VM without issue but would love to run it on my unRAID box! Any ideas what I have wrong here? BTW, I am not using Plex Home.

Link to post

I am having some issues with PlexWatch as well.

 

PlexWatch does not show a version # and I've setup the IP correctly:

 

http://d.pr/i/18j2l

 

But it still cannot connect:

 

http://d.pr/i/1bpjE

 

http://d.pr/i/10C1h

 

I have it running on a separate VM without issue but would love to run it on my unRAID box! Any ideas what I have wrong here? BTW, I am not using Plex Home.

 

I get this as soon as I enable plex home..... I have put my passwords in both files indicated.... once i turn off plex home, all works fine!!

Link to post

I am having some issues with PlexWatch as well.

 

PlexWatch does not show a version # and I've setup the IP correctly:

 

http://d.pr/i/18j2l

 

But it still cannot connect:

 

http://d.pr/i/1bpjE

 

http://d.pr/i/10C1h

 

I have it running on a separate VM without issue but would love to run it on my unRAID box! Any ideas what I have wrong here? BTW, I am not using Plex Home.

 

I get this as soon as I enable plex home..... I have put my passwords in both files indicated.... once i turn off plex home, all works fine!!

 

I can confirm I don't use PlexHome.

Link to post

I tried updating my Docker containers and noticed that SabNZBD is still at 0.7.19 while 0.7.20 was released a few days ago. Does anyone know if there is an EDGE option to update, or do we need to wait for needo to update the container? I had thought one of the benefits of moving to Docker containers was to break dependencies on the plugin/Docker creator.

 

I know it's unrealistic for needo (or whoever) to always be on top of updates as they come out. It would be great to have the container update itself as needed. Is this just misconfigured on my side, or a limitation of the existing container?

Link to post

I tried updating my Docker containers and noticed that SabNZBD is still at 0.7.19 while 0.7.20 was released a few days ago. Does anyone know if there is an EDGE option to update, or do we need to wait for needo to update the container? I had thought one of the benefits of moving to Docker containers was to break dependencies on the plugin/Docker creator.

 

I know it's unrealistic for needo (or whoever) to always be on top of updates as they come out. It would be great to have the container update itself as needed. Is this just misconfigured on my side, or a limitation of the existing container?

 

The dockerfile shows it just pulls from apt-get.  You should be able to delete the container and re-add with the same variables and it will pull the newest version (if apt-get has been updated)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.