Can't install plugins from github

Recommended Posts

I have been trying to install tvheadend plugin and it keeps failing when trying to connect to download it.


So I put the tvheadend_mod.plg file into the config/plugins directory

and then I ran installplg tvheadend_mod.plg and got and ssl certificate authtentication error:

root@Media:/boot/config/plugins# installplg tvheadend_mod.plg

installing plugin: tvheadend_mod

file /boot/config/plugins/tvheadend/tv_grab_file: downloading from ... Cookie coming from attempted to set domain to

Cookie coming from attempted to set domain to

ERROR: cannot verify's certificate, issued by `/C=US/O=DigiCert Inc/ SHA2 High Assurance Server CA':

  Unable to locally verify the issuer's authority.

To connect to insecurely, use `--no-check-certificate'.

bad download, deleting


I found out that this is occuring during the wget command within the installplg script, and can produce the same error

by running wget


I tried it in both cases to add the --no-check-certificate but that still fails with this error:

OpenSSL: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

Unable to establish SSL connection.


It seems like ssl handshaking is always failing.


I tried upgrading from unraid 5.0.0 to latest 5.0.5, but still the same error. :(


Anyone know how to solve this issue ?







Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.