Jump to content
nsta

User Share Exclusions not working!...please help

15 posts in this topic Last Reply

Recommended Posts

My Unraid is 4.4.2

 

Hey All - Unraid has been running perfect recently....until now :(....here is my current unraid setup:

 

1 500GB disk parity

2 x 500GB disks for my "movies" share - Disk1 and Disk2 set as included disks and Disk3 set to exclude

1 x 500GB disk for my "data" share - I have set Disk3 as included, and Disk1 and 2 as Excluded disks....

 

here's the problem....the high water mark for my Movies share (disk 1 and 2) reached 50%...i transfer a file onto my user share, and to my suprise the files moved accross to Disk3 which is set as a excluded disk on the share!!!....

 

What am i doing wrong, i have attached my user share setup if you can see anything wrong!....i need to sort this asap.

 

Also, since the file has been moved to my excluded disk, is there any reason why i cannot transfer it over to the movie share manually?....it wont harm anything will it?

 

Thanks

 

untitled_16.gif

 

http://f.imagehost.org/view/0033/untitled_16

Share this post


Link to post
Also, since the file has been moved to my excluded disk, is there any reason why i cannot transfer it over to the movie share manually?....it wont harm anything will it?

 

I don't now why it ignored your exclusion rule.  What I *can* say is, there is no problem just moving the file to the right drive and folder.

 

Did you possibly have a Movies folder on Disk 3?  That still would not justify the wrong copy location, but would help us understand what is wrong.  After moving the file, I would delete the current Movies folder off Disk 3 and reboot, and it should recreate the virtual User Shares without Disk 3.

Share this post


Link to post

Following up on RobJ's comment, if a disk has a subdirectory called the same thing as a user share, it is going to be in that user share.  You cannot use exclusions to keep it out.  So if you had a "Movies" directory on disks 1, 2, 3 and 4; and you excluded disk3 from the user share, movies on Disk3 would still show up.  Exclusions, I believe, would stop unRAID from creating the directory on a new disk, but once the directory exists, it seems that exclusions are ignored.

 

I'd suggest deleteing the user share, then renaming directories on disks you DON'T want to participate, and then recreate the users share and set your exclusions.  Hopefully that will have the desired effect.

 

 

Share this post


Link to post

Cheers ill give that a shot tonight, i hope it works....

 

And i think i do remember creating a TEMPORARY "movies" folder on the root of DISK3 which explains all of this!....

 

Just to make sure, it's only if the folder is on the ROOT of the User share, that it will disregard the exclusions??

 

i.e in my case: i had a movies share on the root of Disk1 and Disk2 (which is how it should be)....and i had a temporary movies folder on the root of Disk3, which is why it started copying files accross to it and disregarded my exclusions???

 

....if say i had this structure: Disk3/data/movies...would it still have adverse affects (even though its not in the root of the user share)???

 

Thanks :)....hope this was all it is

 

 

 

Share this post


Link to post

PROBLEM - IT didnt work!!!

 

I deleted the movies folder off disk3, and rebooted my unraid box.....transferred file over to my movies share......and it re created a movies folder on Disk3 (data share), and started copying to it accordingly!!!

 

What should i try next???

Share this post


Link to post

PROBLEM - IT didnt work!!!

 

I deleted the movies folder off disk3, and rebooted my unraid box.....transferred file over to my movies share......and it re created a movies folder on Disk3 (data share), and started copying to it accordingly!!!

 

What should i try next???

 

hum, I'm not sure if case matters but when i include and exclude disks i always use lowercase letters.  I would imagine that would change nothing but it is worth a shot.

 

Also, if all else fails i would disable user shares, delete the movies folder on disk3, and shut the server down.  Then start the server back up and set up the user shares from scratch.  If you have done this already then i am not quite sure where to go from there.

Share this post


Link to post

Just to make sure....if i disable user shares.....will that remove the contents on that share aswell???....

Share this post


Link to post

Just to make sure....if i disable user shares.....will that remove the contents on that share aswell???....

No, it will not. The content should remain the same.

 

I have disabled and re-enabled user shares many times without ill effect.

 

Cheers,

Matt

Share this post


Link to post

So deleting the user shares within the Unraid console is ok aswell?

well that is a different question.. deleting, I don't know.. I've only deleted user shares that had empty folders in the root of the drive but when I delete the share, the folder was removed as well... i don't know how it will handle the folder if there is content in it..

 

Your previous question was about disabling user shares, not deleting them...

 

Matt

Share this post


Link to post

BE VERY CAREFUL.

 

You do not want to delete the user share files, you want to TURN OFF the user shares option.

 

This is done from the Web GUI, not from the unRAID console.

 

First stop the array (from the "Main" page) then go to the "Settings" page, and change the setting called "User shares:" to "Disabled".

Share this post


Link to post

FIXED :)))

 

Thanks to all for their HELP....i dont know which part fixed it, but here were my steps:

 

*Removed movies folder off disk3 (which shouldnt have been there)

*used all lowercase format for all my exclusions in the webgui

*Disabled user shares and restarted

*re-enabled shares after reboot and didn't touch the share settings (left them as they were)

 

Tested and now everything i copy to my "Movies" share will go to the appropriate disk :)))

 

THANKS TO ALL

 

Share this post


Link to post

The problem (bug?) was that the the 'disk' identifier must be all lowercase, ie, 'disk1', not 'Disk1', or 'DISK1'.

 

Also in general you only need 'included' set to non-blank, OR 'excluded' set to non-blank.

 

The 'included' mask says, "Only these disks will be considered for creation of a new object".

The 'excluded' mask says, "All disks will be considered for creation of a new object except for these disks".

 

In your case, it is sufficient to specify this:

 

For 'Data' share:

  included = disk3

  excluded =

For 'Movie' share:

  included =

  excluded = disk3

 

For the 'Movie' share you could also do this:

  included = disk1-2

  excluded =

 

But let's say that you know that eventually your Movie share will fill up and you will install a new disk (disk4).  If you use the method of just setting 'excluded = disk3' then when you add disk4 the Movie share will automatically start using it without you having to change the config - make sense?

Share this post


Link to post

Making Perfect sense, and helps to know it has to be lower case :) aswell......

 

THANKS :)

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.