Jump to content
limetech

AFP update

15 posts in this topic Last Reply

Recommended Posts

update netatalk to 3.1.3 (or later).

 

Once this feature is completed, you might need to rebuild the cnid database.

 

Share this post


Link to post

This is the biggest part of the update for me since I run 100% apple products in my house. I will be testing this religiously when it comes out.

 

Share this post


Link to post

Ok, noted.  I think I said somewhere we'd try to get this into the "next beta" - well next is -beta8 and it's not there yet, sorry.  Actually it was just supposed to be a patch, -beta7a, but then a docker issue pushed itself urgently to the top of the list to get done and we decided to just release as -beta8.  But good news is that -beta8 will make it much easier to users to update and for us to produce releases, so hopefully we get smaller releases out more often...

Share this post


Link to post

This is the biggest part of the update for me since I run 100% apple products in my house. I will be testing this religiously when it comes out.

 

I also run Apple stuff, what exactly is this patch for? Is this to have AFP working with latest OS X ? I'm running Yosemite beta, I still access my Unraid (probably in SMB...).

Share this post


Link to post

it’s to hopefully fix some of the flakiness in using AFP with Mac OS X. The version of netatalk in unRAID is very old. Yes, things work as they are now, but Time Machine is quite volatile.

 

Tom, I’m just happy to know it’s on the v6.0 roadmap. Beta 8, beta 9, beta 10, whatever, I don’t care.

Share this post


Link to post

Something worth noting on this feature.  Tom actually found a bug in the netatalk 3.1.6 code and let the netatalk devs know so they could fix for which they responded quickly and patched.

 

This is a great example of why we can't always "just apply the open source update and release it.". This is also a great example of where something like an "apt-get update" method could actually have created more problems for our users than it would have solved.

Share this post


Link to post

Just to note, since moving to v6b10a I haven’t had a single issue with Time Machine backing up. Previously I would routinely get messages that the backup failed for a variety of reasons. Now, not a single one. Thanks!

Share this post


Link to post

Just to note, since moving to v6b10a I haven’t had a single issue with Time Machine backing up. Previously I would routinely get messages that the backup failed for a variety of reasons. Now, not a single one. Thanks!

 

This has been my experience too on 6b10a;  Time Machine (Mavericks) will remount the Backup volume without any notice at all.  My wired Time Machine volume doesn't usually do that.

 

Thanks!!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.