Container for Duck DNS dynamic dns updates


42 posts in this topic Last Reply

Recommended Posts

Sometimes my docker container host will lose internet connection. This will cause the curl command to fail and duck.sh/container to quit. Would it be possible to swallow the error and just keep running?

 

Initially I was doing this..,

 

DOMAINS=domain1,domain2TOKEN=xxxxxxxxxxxxxxx

 

After reading your reply I tried quotes

DOMAINS="domain1,domain2"TOKEN=xxxxxxxxxxxxxxx

 

this seems to work fine.  One domain works without quotes.  Anyway, thanks for your help

 

Link to post
  • 2 weeks later...
  • 3 weeks later...

Are there any ports that I need to open for this that might have changed? It worked great but after an update I'm posting "KO" in the log. the token and domain seem fine. I tried with and w/o quotes.

 

No, there aren't any ports to open. Here's the default config:

 

DOMAINS='yourdomain'
TOKEN='yourtoken'

 

It's pretty simple.

 

Try logging into your unraid server and running this:

 

curl -S -s "https://www.duckdns.org/update?domains=yourdomain&token=yourtoken"

 

replacing yourdomain and yourtoken as appropriate. If that works but the container doesn't, let me know.

Link to post
  • 2 weeks later...

I've added an "INTERVAL" configuration value.

 

If you are upgrading from a previous version, you will need to add an interval to your config file. Example:

 

INTERVAL='30m'

 

The new default interval for new config files is 30m. The minimum allowed is 5m.

Link to post

I'm not sure what I'm doing wrong. It keeps stopping on me. Here is my config file.

 

DOMAINS='<myname>.duckdns.org'TOKEN='5xxxxx7'INTERVAL='30m'

 

/config points to /mnt/user/appdata/duckdns/

 

Thats where my duck.conf is.

 

What other information can I provide?

 

EDIT: I did the curl -S -s "my url and key" and it says "KO" in front of root@Tower now

 

Link to post
  • 10 months later...
  • 4 weeks later...

It's so simple, it's hard to imagine how it could stop working, as long as the server side of their service keeps going.

 

I noticed this at work... I need a pithy way to capture it... Something like "Mo' code, Mo' problems". The idea is that every bit of complicated code has cost that is higher than it seems. So if you find yourself writing complicated code, you're going to regret it later. :)

 

KISS principle, I guess.

Link to post
  • 2 years later...

New update is out.

 

I moved from the phusion (Ubuntu-based) base image to Alpine. The image is 5x smaller.

 

Also, you can now specify all the settings using only environment variables. In this case you don't need the config file. Env vars take precedence over the config file values.

Link to post
  • 9 months later...

Having an issue with the docker communicating to DuckDNS. Vars are specified in the settings but seeing the below error:

 

./run: line 3: /etc/envvars.merged: No such file or directory
Will detect ipv4 automatically
[May 15 04:35:26] DuckDNS reported an error. Check your settings. Result was "KO"

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.