Container for No-IP dynamic DNS updates


Recommended Posts

  • 4 months later...

This no longer works, I'm now getting the following in the log.

 

[Aug 18 13:14:05] Couldn't update. Trying again in 5 minutes. Output from curl command was "<html><body><h1>400 Bad request</h1>

Your browser sent an invalid request. </body></html>".

[Aug 18 13:19:06] Couldn't update. Trying again in 5 minutes. Output from curl command was "<html><body><h1>400 Bad request</h1>

Your browser sent an invalid request. </body></html>".

 

Link to comment
  • 1 month later...

After a little configuring on the .conf file I was able to get it up and running but I get this error in the log. Everything I enter is correct and there is no error codes on that website that matches it. Any help would be great... now not sure if it mattered where it ran from but I put the conf file in /mnt/cache/appdata/No-Ip vise the default one on the user drive. I didn't know if it would make a difference.

 

/tmp/noip.conf: line 1: $'\357\273\277#': command not found

[sep 19 00:33:38] For an explanation of error codes, see http://www.noip.com/integrate/response

Link to comment

/tmp/noip.conf: line 1: $'\357\273\277#': command not found

 

You've somehow injected some bogus characters at the top of the file, and perhaps elsewhere. I try to scrub out windows line endings, but I'm not sure what to do about those unicode (?) characters. Log into your server and run "nano noip.conf". If there are any characters before the "#", delete them.

 

Then restart your container and see if that clears up the problem.

Link to comment

This no longer works, I'm now getting the following in the log.

 

[Aug 18 13:14:05] Couldn't update. Trying again in 5 minutes. Output from curl command was "<html><body><h1>400 Bad request</h1>

Your browser sent an invalid request. </body></html>".

 

Log into your server, and run:

 

USERNAME='<username from your conf file>'
PASSWORD='<password from your conf file>'
DOMAINS='<domains from your conf file>'

curl -S -k --user-agent "coppit docker no-ip/.1 $USERNAME" -u "$USERNAME:$PASSWORD" "https://dynupdate.no-ip.com/nic/update?hostname=$DOMAINS"

 

If that works, then check your conf file for correctness, and see if there are any other errors in the container logs. If you can't find any problem, I can add more logging so that we can figure it out.

Link to comment
  • 4 weeks later...

I am getting the error

 

[Oct 14 10:22:01] Couldn't update. Trying again in 5 minutes. Output from curl command was "<html><body><h1>400 Bad request</h1>
Your browser sent an invalid request.
</body></html>".

 

I was successful with the below code saying "nochg (my current IP)" however no-ip.com does not update my ip address:

 

USERNAME='<username from your conf file>'
PASSWORD='<password from your conf file>'
DOMAINS='<domains from your conf file>'

curl -S -k --user-agent "coppit docker no-ip/.1 $USERNAME" -u "$USERNAME:$PASSWORD" "https://dynupdate.no-ip.com/nic/update?hostname=$DOMAINS"

 

Not sure what to do next. Thank you.

Link to comment
  • 1 month later...
  • 4 months later...

Hi,

 

tried a a clean install of the new one and I get this message:


Can't locate configuration file /config/no-ip2.generated.conf. (Try -c). Ending!

I tried copying the new edited conf file to no-ip2.generated.conf and then I get a message:

 

'/config/no-ip2.generated.conf' is not a valid configuration file. Ending!

Any idea?

 

thank you 

Edited by hernandito
Link to comment
1 hour ago, hernandito said:

tried a a clean install of the new one and I get this message:



Can't locate configuration file /config/no-ip2.generated.conf. (Try -c). Ending!

 

 

Look up higher in the output. There's probably an error with the no-ip domain registration. I've pushed a change that should help make that more clear.

 

Also, keep your noip.conf separate from the generated one.

Link to comment
On 7/11/2015 at 3:24 PM, hernandito said:

Could I impose on someone to please write directions how to set this up?

 

Can the template be re-written so that one can enter our login information as variables...?

 

I have no-ip and would love to get this going.

 

Thanks,

 

H.

 

 

 

Seconded

 

I just installed the "improved" version and there is no folder in /mnt/cache/appdata to store the config file.. So where should it be then? I have no problem editting the file but finding it!?!? ;)

Link to comment

Did you follow the link in the first post? It says:

 

Quote

When run for the first time, a file named noip.conf will be created in the config dir, and the container will exit. Edit this file, adding your username (email), password, and domains. Then rerun the command.

On subsequent runs, a binary config file /config/dir/path/no-ip2.generated.conf will be generated. Please do not edit this file, as it is used by the noip2 agent.

 

Let me know if anything is unclear.

Link to comment
4 hours ago, coppit said:

Did you follow the link in the first post? It says:

 

 

Let me know if anything is unclear.

 

Yes, did you read my post? The "instructions" ARE unclear!!. Where is the confg dir as it is not in the standard location for unRAID dockers and it has no config dir variable...

Link to comment
2 hours ago, methanoid said:

 

Yes, did you read my post? The "instructions" ARE unclear!!. Where is the confg dir as it is not in the standard location for unRAID dockers and it has no config dir variable...

 

I just deleted my container. I then re-created it from Community Applications. When I was done, there was a new folder  /mnt/cache/appdata/No-Ip. Further, if I clicked "Show advanced settings..." before applying the template (or by clicking the container after it is created), I see the path right there.

 

I suppose I could make the folder path an "always show" configuration value. But I'm not sure what you mean about there not being a path in the standard location. Can you elaborate? Are you creating the container on the command line or something?

Link to comment
15 hours ago, coppit said:

 

I just deleted my container. I then re-created it from Community Applications. When I was done, there was a new folder  /mnt/cache/appdata/No-Ip. Further, if I clicked "Show advanced settings..." before applying the template (or by clicking the container after it is created), I see the path right there.

 

I suppose I could make the folder path an "always show" configuration value. But I'm not sure what you mean about there not being a path in the standard location. Can you elaborate? Are you creating the container on the command line or something?

 

My bad..  Seeing as I cannot find the thing by using search on CA but can from searching for your handle I guess I must have installed it from CA by adding things found from Dockerhub.. Doing same as you created the folder and hence file... and all running now.. Thanks... I wonder if it was called NoIP (no spaces/dashes) it might be easier to find when searching CA since "No-IP" is replaced with "No IP" and finds zero items ??? 

Link to comment

Hi Coppit,

 

Back at my desk.

 

I tried erasing the previous container and installed the docker from Community Applications into a non-existing config folder.

 

After installing, the log screen showed a message about editing the /mant/cache/appdata/No-IP2/noip.conf. The docker was stopped at that time. I edited the .conf file and started the docker I get this in the log window.

 

 

Creating config file. Please do not forget to enter your info in noip.conf.
spawn /files/noip2-x86_64 -C -c /config/no-ip2.generated.conf

Auto configuration for Linux client of no-ip.com.

spawn /files/noip2-x86_64 -C -c /config/no-ip2.generated.conf

Auto configuration for Linux client of no-ip.com.

Please enter the login/email string for no-ip.com myemail@email.com
Please enter the password for user 'archi@inch.com' **********

2 hosts and 1 group are registered to this account.
Do you wish to have them all updated?[N] (y/N)
ERROR: Timed out looking for host information

[Mar 28 10:17:45] Failed to create noip2 configuration file /config/no-ip2.generated.conf. Exiting

It does look like it finds the account as it lists 2 hosts and 1 group which is what I have in my no-ip account. Also there is no file called "no-ip2.generated.conf" in my appdata config folder.

 

Any ideas please?

 

Thanks!

 

H.

Edited by hernandito
Link to comment
Just now, hernandito said:

Hi Coppit,

 

Back at my desk.

 

I tried erasing the previous container and installed the docker from Community Applications into a non-existing config folder.

 

After installing, the log screen showed a message about editing the /mnt/cache/appdata/No-IP2/noip.conf. The docker was stopped at that time. I edited the .conf file and started the docker I get this in the log window.

 

 


Creating config file. Please do not forget to enter your info in noip.conf.
spawn /files/noip2-x86_64 -C -c /config/no-ip2.generated.conf

Auto configuration for Linux client of no-ip.com.

spawn /files/noip2-x86_64 -C -c /config/no-ip2.generated.conf

Auto configuration for Linux client of no-ip.com.

Please enter the login/email string for no-ip.com myemail@email.com
Please enter the password for user 'archi@inch.com' **********

2 hosts and 1 group are registered to this account.
Do you wish to have them all updated?[N] (y/N)
ERROR: Timed out looking for host information

[Mar 28 10:17:45] Failed to create noip2 configuration file /config/no-ip2.generated.conf. Exiting

It does look like it finds the account as it lists 2 hosts and 1 group which is what I have in my no-ip account. Also there is no file called "no-ip2.generated.conf" in my appdata config folder.

 

Any ideas please?

 

Thanks!

 

H.

 

Link to comment
9 hours ago, methanoid said:

Seeing as I cannot find the thing by using search on CA but can from searching for your handle I guess I must have installed it from CA by adding things found from Dockerhub.

 

Yeah! I updated the meta data, and dropped a few references to noip2 and noip and no-ip into the description. Hopefully something works. :) I also updated my top post to tell people to search for "coppit" first.

 

I looked into making the path always show up in the template page, but that appears to be a feature of the new XML format that is only supported by 6.2. I'd rather not leave pre-6.2 out in the cold, so I'll have to leave that as it is.

 

9 hours ago, hernandito said:

2 hosts and 1 group are registered to this account.

 

Dang. You found (hopefully) the one scenario I didn't test for. Congrats!

 

I just pushed a fix that simplifies and generalizes the code. It should fix the problem for you. 

Link to comment
1 hour ago, coppit said:

Dang. You found (hopefully) the one scenario I didn't test for. Congrats!

 

I just pushed a fix that simplifies and generalizes the code. It should fix the problem for you. 

 

Awesomeness.... I had a little trouble, but it was with my noip.conf file. Basically I had a "Group" at No-IP that has all my domains. In the .conf file, I only used the group name (not the domains) and it worked. I hope this helps others.

 

Coppit... :D I thank you!

 

This is awesome.

 

H.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.