OpenVPN Server & Client for unRAID 6.2+ (6.1 are still supported)


peter_sm

941 posts in this topic Last Reply

Recommended Posts

  • Replies 940
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I have updated the OpenVPN Server & Client plugins for the V6.2+ plugin manager. Post all issue you have in this thread !! To install. Install the plugins, go to the 'Extensions' pa

Had the same issue, you need to edit that line and replace "-f16" with "-f14". Install works great after this edit. Github probably modified its HTML.

Hi,   I changed from OpenVPN AS from Linuxservers to yours. At first, good job Everything is working fine for me at the moment.   But I have one question, maybe I oversee som

Posted Images

6 hours ago, Aluavin said:

I know how to find the flash drive ;) I want to minimize the read access to this one. that's why I want to move those .ovpn files to my SSD.

Ahh. I'd imagine they'd only be read when the connection is started. Shifting them off the flash wouldn't give any real benefit I think..

Link to post
  • 2 weeks later...

Just upgraded to 6.7.0-rc1, for some reason I can't start my plugin anymore, the following is all the entries I see in the Logs

 

Jan 22 11:19:01 Test ool www[18957]: /usr/local/emhttp/plugins/openvpnserver/scripts/rc.openvpnserver 'start'
Jan 22 11:19:01 Test sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/openvpn --writepid /var/run/openvpnserver/openvpnserver.pid --config /mnt/cache/appdata/OpenVPN/openvpnserver.ovpn --script-security 2 --daemon

Also found:

openvpn: error while loading shared libraries: libcrypto.so.l: cannot open shared object file: No such file or directory

 

Edited by clowrym
Link to post

+1 here

 

system log ends like this

 

Jan 22 18:47:59 AlsServer root: Starting OpenVPN Server Jan 22 18:47:59 AlsServer root: Starting Openvpn server..... Jan 22 18:48:00 AlsServer avahi-daemon[10878]: Service "AlsServer" (/services/ssh.service) successfully established. Jan 22 18:48:00 AlsServer avahi-daemon[10878]: Service "AlsServer" (/services/smb.service) successfully established. Jan 22 18:48:00 AlsServer avahi-daemon[10878]: Service "AlsServer" (/services/sftp-ssh.service) successfully established. Jan 22 18:48:00 AlsServer sudo: root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/sbin/openvpn --writepid /var/run/openvpnserver/openvpnserver.pid --config /mnt/cache/appdata/myVPNserver/openvpnserver.ovpn --script-security 2 --daemon Jan 22 18:48:01 AlsServer root: An error occurred, server not started!. More info in /var/log/openvpnserver.log or /var/local/emhttp/plugins/openvpnserver/openvpnserver.out

 

in the openvpnserver.out

 

penvpn: error while loading shared libraries: libcrypto.so.1: cannot open shared object file: No such file or directory

 

Link to post
29 minutes ago, clowrym said:

Just upgraded to 6.7.0-rc1, for some reason I can't start my plugin anymore, the following is all the entries I see in the Logs

 


Jan 22 11:19:01 Test ool www[18957]: /usr/local/emhttp/plugins/openvpnserver/scripts/rc.openvpnserver 'start'
Jan 22 11:19:01 Test sudo: root : TTY=unknown ; PWD=/usr/local/emhttp ; USER=root ; COMMAND=/usr/sbin/openvpn --writepid /var/run/openvpnserver/openvpnserver.pid --config /mnt/cache/appdata/OpenVPN/openvpnserver.ovpn --script-security 2 --daemon

Also found:


openvpn: error while loading shared libraries: libcrypto.so.l: cannot open shared object file: No such file or directory

 

This plugin will need to upgrade to using the openvpn-2.4.6-x86_64-2 package since it is compiled to work with the newer versions of openssl.  The legacy version of openssl (libcrypto.so) was removed in 6.7.0-rc1.

Link to post
4 hours ago, tr0910 said:

I was just about to reboot my server after upgrading to 6.7rc2 when I saw this.  OpenVPN is required for me.  I will postpone this reboot now, possibly for a long time........

If use the docker based versions then they are not affected by this upgrade as they are isolated from host OS changes..   Thought I should mention it in case this plugin never gets updated

Link to post

I fix this if I got time soon.... you can always DL the latest package and install it from the extra folder? Not sure if I shall priorities this? need to work and earn money ;-) 

Edited by peter_sm
Link to post
39 minutes ago, peter_sm said:

I fix this if I got time soon.... you can always DL the latest package and install it from the extra folder? Not sure if I shall priorities this? need to work and earn money ;-) 

I didint think of this... Done, installed, confirmed working & set up a script to re-install it after reboot.

Link to post
On 10/15/2018 at 10:59 PM, vitis said:

Hello, I have installed the client and I am having issues while connecting. I have a working unified ovpn profile and also ovpn/cert/ca - both verified and working. But when I am trying to connect with this Unraid client, the plugin inserts 10 lines saying "dev tap5" to my ovpn profile and that breaks it, so it does not work. Has anybody encountered this problem? You can see part of the ovpn profile below.

 


##############################################
# Sample client-side OpenVPN 2.0 config file #
dev tap5
# for connecting to multi-client server.     #
dev tap5
#                                            #
# This configuration can be used by multiple #
# clients, however each client should have   #
dev tap5
# its own cert and key files.                #
#                                            #
# On Windows, you might want to rename this  #
# file so it has a .ovpn extension           #
##############################################

# Specify that we are a client and that we
dev tap5
# will be pulling certain config file directives
# from the server.
client
dev tap5


 

I just wanted to let you know that I solved this issue. I was using a template config file, which had a lot of examples and commented lines and I guess that the plugin could not handle this while inserting it's own stuff to it. I downloaded PIA's ovpn files which worked, so I changed my files to look alike the PIA ones and then it started working.

 

It is not really a fix, it's just a workaround. :) 

Link to post
2 hours ago, peter_sm said:

you can always DL the latest package and install it from the extra folder

1 hour ago, clowrym said:

I didint think of this... Done, installed, confirmed working & set up a script to re-install it after reboot.

If you put it in a folder named "extra" on flash it will be automatically re-installed on boot, no script required. That method isn't discussed a lot these days with all the plugins and dockers we have for additional functionality, but that is how it was done on older versions of Unraid. Any slackware compatible package (.txz .tgz) in the "extra" folder on the flash drive is installed with the installpkg command when Unraid boots.

 

Use this technique sparingly. It may not be supported and it is easy to get yourself in trouble by installing packages that conflict with other packages installed by your plugins.

Link to post
11 minutes ago, ximian said:

Care to share ... what exactly did you re-install? How (Command line, apps ....)  

 

Thanks.

Downloaded THIS, placed in the /boot/extra folder & added a script to run after start of array. 

 

#!/bin/bash
cd /boot/extra
installpkg openvpn-2.4.6-x86_64-2.txz

I tried just adding it to the extra folder and rebooting, but it still installed the older version requiring me to do an installpkg after.....

Edited by clowrym
Link to post
2 minutes ago, clowrym said:

I tried just adding it to the extra folder and rebooting, but it still installed the older version requiring me to do an installpkg after.....

Did you remove the plugin? If not that is probably where the old version came from.

Link to post
3 hours ago, peter_sm said:

I fix this if I got time soon.... you can always DL the latest package and install it from the extra folder? Not sure if I shall priorities this? need to work and earn money ;-) 

We await your fix at your convenience.  The docker is ok, but Peter's plugin is better.  His works even if the array is stopped.  If Peters Open-vpn plugin is important to you wait on installing 6.7 for a bit.  It will get fixed.

Link to post

Hi. I have installed your plugin on the latest Unraid stable version. It works fine, however when the server is rebooted I cannot connect to openvpnserver. I have to manually restart the openvpnserver in the plugin config webpage or from the commandline.

This issue is reproducable after every reboot.

How can I fix this?

Link to post
  • 2 weeks later...

I just installed on my server. I'm trying to get a good client configuration. If I configure with Adaptive compression my Mac complains that LZO compression is deprecated but works fine on both Mac and my iOS devices. If I select LZ4 compression it works fine on my Mac but my iOS devices connect but can't seem to communicate. If I select no compression iOS works fine but my Mac Tunnelblick complains that the ovpn file has unrecognized options or missing parameters. What to do?

 

I'm actually switching from linuxserver.io's Docker. In that configuration I have compression disabled but it works fine.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.